NetworkManager fails to set IP and route information entered

Bug #438454 reported by Peter Belew on 2009-09-28
74
This bug affects 14 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Gerry C.
network-manager (Ubuntu)
High
Unassigned
Nominated for Karmic by Gerry C.
resolvconf (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Gerry C.

Bug Description

Binary package hint: network-manager

uname -a output: Linux lightning 2.6.31-11-generic #36-Ubuntu SMP Fri Sep 25 06:37:51 UTC 2009 i686 GNU/Linux
Karmic alpha 6 with updates up to the current time
CPU model name : VIA Samuel 2

With a default /etc/network/interfaces file, running by default using dhcp, I tried to set a static IP, mask, default route, and one other route using Network Manager (running either from the System menu or from the Network Manager applet on the panel).

It does not save any of the settings, and remains to have the IP address from dhcp. I have to hand-edit /etc/network/interfaces to get the IP and default route I want, restarting /etc/init.d/networking.

I have the resolvconf package installed, but this was happening even without resolvconf installed.

ProblemType: Bug
Architecture: i386
CRDA: Error: [Errno 2] No such file or directory
Date: Mon Sep 28 16:03:06 2009
DistroRelease: Ubuntu 9.10
Gconf:

IpRoute:
 192.168.2.0/24 dev eth0 proto kernel scope link src 192.168.2.17 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
 default via 192.168.2.1 dev eth0 proto static
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Package: network-manager 0.8~a~git.20090923t064445.b20cef2-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
RfKill:

SourcePackage: network-manager
Uname: Linux 2.6.31-11-generic i686

Peter Belew (peterbe) wrote :
Peter Belew (peterbe) wrote :

Notes about the UI:

- The fields for entering IPs, masks, etc. are very narrow - it's necessary to drag the edges of the dialogs to provide enough space.
- You can't use tab or space to move from field to field - you have to use the mouse to move from the IP field to the netmask field, etc. If there is a reasonable keyboard way to do this, it isn't clear what that might be.

Patrice Vetsel (vetsel-patrice) wrote :

I confirm this bug under 20090929.2 and I can confirm that it was not here under Alpha6

I can't set a wired connexion with static IP/gateway + DNS, all is forgotten.

Changed in network-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in network-manager (Ubuntu):
assignee: nobody → Ubuntu Desktop (ubuntu-desktop)
milestone: none → ubuntu-9.10
Patrice Vetsel (vetsel-patrice) wrote :

Steps :

Install a fresh 9.10 beta

Go to network-manager and create a new profil of wired network (anyone can do, even those with no wired network)
Give it a name
Go to ipv4
Set to static IP (no dhcp)
add a network 192.168.1.20/255.255.255.0/192.168.1.1
add an IP for DNS 82.82.82.82
Save it

re-enter in the profil and see that your static configuration is lost (it's set to dhcp)

vexorian (vexorian) wrote :

in my case, the configuration dialog also crashes, can't send the report since internet does not work correctly ...

vexorian (vexorian) wrote :

Only crashed once, but is still unable to save my IP settings, I am also running the 64 bits version.

It sounds like you need to configure your networking manually - in
particular /etc/resolv.conf and /etc/network/interfaces - which have
manual pages.

On Fri, Oct 2, 2009 at 4:15 PM, vexorian <email address hidden> wrote:
> in my case, the configuration dialog also crashes, can't send the report
> since internet does not work correctly ...
>
> --
> NetworkManager fails to set IP and route information entered
> https://bugs.launchpad.net/bugs/438454
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alexander Sack (asac) on 2009-10-05
Changed in network-manager (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.8~a~git.20091005t192303.1d28ad1-0ubuntu1

---------------
network-manager (0.8~a~git.20091005t192303.1d28ad1-0ubuntu1) karmic; urgency=low

  * upstream snapshot 2009-10-05 19:23:03 (GMT)
    + 1d28ad1aa54bacf6b6b64582ee7c41d9728d7304
  * fixed upstream
    - LP: #413622 - Network manager does not unmanage devices configured as
      "mapping" in /etc/network/interfaces
    - LP: #413967 - Network manager does not connect wlan0 on startup
    - LP: #417719 - Disconnected static wired network initially treated as
      connected
    - LP: #422597 - 802.11x fails for wired connections (wireless works)
    - LP: #438771 - Creating a wireless or DSL connection fails with
      "Error editing connection: property '%s' / '%s' invalid: %d"
    - LP: #443423 - Connection properties are not stored
    - LP: #439221 - cannot create wireless Wpa & Wpa2 connection with GUI
    - LP: #441668 - network-manager does not save modifications on GSM
      connections
    - LP: #438454 - NetworkManager fails to set IP and route information entered

  [ Mathieu Trudel <email address hidden> ]
  * updated pkcs11 smartcard patch
    - updated debian/patches/lp120363_smartcard_pkcs11.patch
  * add new 802.1x symbols to libnm-util1.symbols
    - update debian/libnm-util1.symbols

  [ Alexander Sack <email address hidden> ]
  * drop cherry-pick now applied upstream
    - delete debian/patches/lp436884.patch
    - update debian/patches/series
  * extend apport hook to also append /etc/NetworkManager/nm-system-settings.conf
    - update debian/source_network-manager.py

 -- Alexander Sack <email address hidden> Mon, 05 Oct 2009 23:46:01 +0200

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
Peter Belew (peterbe) wrote :

Having tried this a few minutes ago, I'm convinced that this is still
very buggy, and also very confusing to use.

I'll have to wait until tomorrow to retest this and provide more details.

On Mon, Oct 5, 2009 at 3:25 PM, Launchpad Bug Tracker
<email address hidden> wrote:
> This bug was fixed in the package network-manager -
> 0.8~a~git.20091005t192303.1d28ad1-0ubuntu1
>
> ---------------
> network-manager (0.8~a~git.20091005t192303.1d28ad1-0ubuntu1) karmic; urgency=low
>
>  * upstream snapshot 2009-10-05 19:23:03 (GMT)
>    + 1d28ad1aa54bacf6b6b64582ee7c41d9728d7304
>  * fixed upstream
>    - LP: #413622 - Network manager does not unmanage devices configured as
>      "mapping" in /etc/network/interfaces
>    - LP: #413967 - Network manager does not connect wlan0 on startup
>    - LP: #417719 - Disconnected static wired network initially treated as
>      connected
>    - LP: #422597 - 802.11x fails for wired connections (wireless works)
>    - LP: #438771 - Creating a wireless or DSL connection fails with
>      "Error editing connection: property '%s' / '%s' invalid: %d"
>    - LP: #443423 - Connection properties are not stored
>    - LP: #439221 - cannot create wireless Wpa & Wpa2 connection with GUI
>    - LP: #441668 - network-manager does not save modifications on GSM
>      connections
>    - LP: #438454 - NetworkManager fails to set IP and route information entered
>
>  [ Mathieu Trudel <email address hidden> ]
>  * updated pkcs11 smartcard patch
>    - updated debian/patches/lp120363_smartcard_pkcs11.patch
>  * add new 802.1x symbols to libnm-util1.symbols
>    - update debian/libnm-util1.symbols
>
>  [ Alexander Sack <email address hidden> ]
>  * drop cherry-pick now applied upstream
>    - delete debian/patches/lp436884.patch
>    - update debian/patches/series
>  * extend apport hook to also append /etc/NetworkManager/nm-system-settings.conf
>    - update debian/source_network-manager.py
>
>  -- Alexander Sack <email address hidden>   Mon, 05 Oct 2009 23:46:01 +0200
>
> ** Changed in: network-manager (Ubuntu)
>       Status: Fix Committed => Fix Released
>
> --
> NetworkManager fails to set IP and route information entered
> https://bugs.launchpad.net/bugs/438454
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I agree with Peter, it is too buggy.

Alexander Sack (asac) wrote :

be sure you have everything really updated to latest. and test again. thanks!

Edmundo Álvarez (edmundoa) wrote :

It seems to works fine in my system after upgrade.

Thank you!

Peter Belew (peterbe) wrote :

I'll test that tomorrow - possibly after further upgrades.

What should be the state of /etc/network/interfaces before trying
this? - before booting?

Should this be run from the System>Preference menu or from the
network-manager-applet icon on the upper panel?

One issue which I keep repeating is that there have been problems with
the user interfaces even in previous releases - like you can't tab or
space from field to field (have to click with the mouse on each
field), and depending on font size the fields start out too small, so
you have to drag the edge of the dialog wider to see the entries
better.

Sorry I can't get to this for nearly 24 hours!

On Wed, Oct 7, 2009 at 12:35 PM, edm <email address hidden> wrote:
> It seems to works fine in my system after upgrade.
>
> Thank you!
>
> --
> NetworkManager fails to set IP and route information entered
> https://bugs.launchpad.net/bugs/438454
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Yes, works as expected now. Thanks.

Peter Belew (peterbe) wrote :

This is STILL not working for me. (I just reinstalled network-manager and network-manager-gnome a few minutes ago).

If I start with /etc/network/interfaces in a 'clean' state - just showing the loopback interface, and try to set the IPv4 network parameters, including IP, mask. gateway, and an additional route, I can save all those values, which are retained (somewhere) when I re-run network-manager, either from the System>Preferences menu or from the NetworkManagerApplet (0.7.996), the set values will appear, but have no effect: ifconfig shows no IP for eth0, the route is empty, etc. This remains the case even after restarting /etc/init.d/networking.

I can configure the interface manually in /etc/network/interfaces either for dhcp or for a fixed address and route. My current manual configuration is attached.

Also, I had been running with the resolvconf package installed and configured. So I just tried removing that for a test. This had no effect, I still have the problem with network-manager.

Peter Belew (peterbe) wrote :

Also I've attached a tar file containing the contents of /etc/NetworkManager/

It appears the settings I've made are actually saved here, but I don't know how to make networking use settings in this place.

Possibly there is some setting necessary to make networking use this information.

Peter Belew (peterbe) wrote :

Also I've attached a tar file containing the contents of /etc/NetworkManager/

It appears the settings I've made are actually saved here, but I don't know how to make networking use settings in this place.

Possibly there is some setting necessary to make networking use this information.

Peter Belew (peterbe) wrote :

Installed version of network-manager: 0.8~a~git.20091007t192810.e8982ab-0ubuntu1~nmt1
Version of network-manager-gnome: 0.8~a~git.20091008t034340.7619541-0ubuntu2~nmt1

An additional issue is that the icon for the panel applet doesn't show up, or shows up as only a faint grey triangle.

Tom Wood (woodts) wrote :

Static route still not honored on a fully updated Karmic system. Have to still issue "route add default gw x.y.a.b" at root prompt.

Peter Belew (peterbe) wrote :

I found out that my problem was at least partially that I did not check 'connect automatically' in the edit dialog.

As with Tom Wood in #19, the default gateway does not work - I had to issue a "route add default gw ..." command as well. However the dialog for adding additional routes does work .. possibly that will work for the default route if you enter the right numbers.

I note that a new applet and its icon have been added to the panel - 'Network Connections' - this runs the same connection editor. Also the NetworkManager Applet 0.7.996 now works to connect and disconnect the configured interface(s).

I did have some trouble editing the initial eth0 connection, when first starting the connection editor. Perhaps I didn't have the focus on the line for that connection, and didn't click on it. The first line of the list should have the focus set on it by default - a small user-interface issue.

And I repeat an earlier comment - you have to click with the mouse on every field to enter IP, mask, gateway, etc. on a line - it would be better to use a tab or space to move from field to field (Try the corresponding MS Windows dialog! - and I'm not a Windows advocate.)

The principal remaining functional issue is that the default gateway doesn't work. Without that, this is NOT FIXED.

Peter Belew (peterbe) wrote :

Note that I reinstalled the resolvconf package and determined it had
no bearing on this problem.

Peter Belew (peterbe) wrote :

Regarding the default route issue, the ipv4 section of the file in
/etc/NetworkManager/system-connections for eth0 on my system looks
like:

[ipv4]
method=manual
addresses1=192.168.2.205;24;192.168.2.2;
routes1=192.168.1.0;24;192.168.2.201;2;
ignore-auto-routes=false
ignore-auto-dns=false
dhcp-send-hostname=false
never-default=true

I presume the last entry in the 'addresses1' line should be the
default route, but that seems to have no effect. The route in the
'routes1' line does work.

- Peter

On Fri, Oct 9, 2009 at 8:21 AM, Tom Wood <email address hidden> wrote:
> Static route still not honored on a fully updated Karmic system.  Have
> to still issue "route add default gw x.y.a.b" at root prompt.
>
> --
> NetworkManager fails to set IP and route information entered
> https://bugs.launchpad.net/bugs/438454
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Peter Belew (peterbe) wrote :

Furthermore, if the Network Connections applet is used to change the IP or some other IPv4 parameter, any previously-set default route is deleted: (see comment #22 etc.)

Before using the applet:

peter@lightning:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 * 255.255.255.0 U 1 0 0 eth0
192.168.1.0 linux.router 255.255.255.0 UG 2 0 0 eth0
link-local * 255.255.0.0 U 1000 0 0 eth0
default cisco831 0.0.0.0 UG 66 0 0 eth0

After:

peter@lightning:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 * 255.255.255.0 U 1 0 0 eth0
192.168.1.0 linux.router 255.255.255.0 UG 2 0 0 eth0
link-local * 255.255.0.0 U 1000 0 0 eth0
peter@lightning:~$

The route through the Linux router (192.168.2.201) is kept, but the default route through the Cisco router is not.

Peter Belew (peterbe) wrote :

As of today, this has NOT been completely fixed. As in comment #23 and earlier, the default route specified in the dialog is not set, and in fact deletes any default route previously set by another command or program.

Changed in network-manager (Ubuntu):
status: Fix Released → In Progress
Peter Belew (peterbe) wrote :

The default route is still not set, even though it appears in the NetworkManager data, as in comment #22. There was some sort of update of network-manager that was just installed within the last half hour, but this problem was not fixed in that update.

Peter Belew (peterbe) wrote :

The problem with the default route not working is still not fixed as of Wed Oct 14 17:06:05 UTC 2009.

The value is set in "/etc/NetworkManager/system-connections/Auto eth0", but this has no effect (after disabling and re-enabling eth0 with Network Manager). Only the IP/mask and other routes are set. Also an existing default route is removed.

Peter Belew (peterbe) wrote :

I am adding a new tar of the /etc/NetworkManager directory.

Peter Belew (peterbe) wrote :

Still not fixed as of Oct 15.

Peter Belew (peterbe) wrote :

Regarding comment #18 (about the network-manager applet icon), I just filed a bug report #452786 about that, with an attached screen shot.

Alexander Sack (asac) wrote :

Peter,

> [ipv4]
> method=manual
> addresses1=192.168.2.205;24;192.168.2.2;
> routes1=192.168.1.0;24;192.168.2.201;2;
> ignore-auto-routes=false
> ignore-auto-dns=false
> dhcp-send-hostname=false
> never-default=true

the never-default=true is a problem ... no?

Peter Belew (peterbe) wrote :

Alexander:

Yes: changing that manually to never-default=false, and disabling, then enabling the interface, sets the default route.

So 'false' should be the default, which works for the primary interface. I don't see a GUI setting for selecting that - there should be one, as one doesn't necessarily want a default route on secondary interfaces.

Thanks for finding that!

So the problem is basically that the dialog doesn't allow one to set this; and the default should be 'false'.

Peter Belew (peterbe) wrote :

So this should be assigned to network-manager-gnome or network-manager-applet.

I don't know if similar problems occur with the Xubuntu and Kubuntu versions of this.

Peter Belew (peterbe) wrote :

This appears to be fixed in network-manager-gnome

Version: 0.8~a~git.20091016t162115.6787217-0ubuntu2~nmt1 as installed today.
.

Peter Belew (peterbe) wrote :

It seems that this update is not being built for all CPUs. An older version is being installed on my Averatec 3280 laptop -

$ dpkg -s network-manager-gnome
Package: network-manager-gnome
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 4736
Maintainer: Ubuntu Core Developers <email address hidden>
Architecture: i386
Source: network-manager-applet
Version: 0.8~a~git.20091014t134532.4033e62-0ubuntu1
Depends: libatk1.0-0 (>= 1.20.0), libc6 (>= 2.4), libcairo2 (>= 1.2.4), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2.1), libgconf2-4 (>= 2.23.2), libglade2-0 (>= 1:2.6.1), libglib2.0-0 (>= 2.18.0), libgnome-bluetooth7 (>= 2.27.8), libgnome-keyring0 (>= 2.20.3), libgtk2.0-0 (>= 2.16.0), libnm-glib2 (>= 0.8~a~git.20090923t064445.b20cef2), libnm-util1 (>= 0.8~a~git.20090930t162132.866d48b), libnotify1 (>= 0.4.5), libnotify1-gtk2.10, libpango1.0-0 (>= 1.14.0), libxml2 (>= 2.6.27), zlib1g (>= 1:1.1.4), gconf2 (>= 2.10.1-2), network-manager (>= 0.8~a~git.20090831t055002), gksu, mobile-broadband-provider-info (>= 20090622)

This version still fails to enable the default route.

Ubuntu version and kernel version
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.10
DISTRIB_CODENAME=karmic
DISTRIB_DESCRIPTION="Ubuntu karmic (development branch)"
Linux cupid 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux
model name : Mobile AMD Sempron(tm) Processor 2800+

Hopefully, the fixed version will be built for this CPU type.

Peter Belew (peterbe) wrote :

More on comment #34 - it turns out that the problem has to do with the setting "Use this connection only for resources on its own network" in the "Editing ipv4 routes for ... " dialog. Since the user sees this setting only when adding or changing additional routes, it isn't visible to someone who only wants to set a default route. This setting should be moved to the main "Network Connections" dialog, for that reason.

There is another problem with this version of network-manager-gnome - sometimes, when saving changed settings, an authentication dialog comes up without an entry field for the password. In this case, the Authenticate and Cancel buttons don't work, and it's necessary to close this dialog with the close [x] on the title bar. Again, this is version:

Source: network-manager-applet
Version: 0.8~a~git.20091014t134532.4033e62-0ubuntu1

Changed in network-manager (Ubuntu):
status: In Progress → Fix Released
status: Fix Released → In Progress
Tom Wood (woodts) wrote :

Exactly what's the purpose behind the setting "Use this connection only for resources on its own network"? I just don't see the necessity of having this setting.

Peter Belew (peterbe) wrote :

The name of the control isn't very clear. It should say "Do not set
the default gateway address", which is what it does, and it should be
in the main dialog, not the dialog for extra routes.

It does have a very definite purpose, though - you may have an
interface to a LAN which has no connection to the Internet or to other
networks, in which case there would be no default gateway for the
interface whose settings are being edited. Setting one might cause
some routing problems, in this case.

On Tue, Oct 20, 2009 at 4:17 PM, Tom Wood <email address hidden> wrote:
> Exactly what's the purpose behind the setting "Use this connection only
> for resources on its own network"?  I just don't see the necessity of
> having this setting.
>
> --
> NetworkManager fails to set IP and route information entered
> https://bugs.launchpad.net/bugs/438454
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
It's completely normal that you lose data on "Windows" platforms.
That's why you have a UNIX server for backups.
  SMAUG: http://scruz.org/
  My Web: http://www.armory.com/~peterbe/

tags: added: iso-testing
Changed in resolvconf (Ubuntu):
assignee: nobody → MOTU (motu)
Changed in linux (Ubuntu):
assignee: nobody → Kernel Bugs (kernel-bugs)
Richard Hansen (rhansen) wrote :

reverting invalid bug changes

Changed in linux (Ubuntu):
assignee: Kernel Bugs (kernel-bugs) → nobody
status: New → Invalid
Changed in resolvconf (Ubuntu):
assignee: MOTU (motu) → nobody
status: New → Invalid
Karsten W. Rohrbach (byteborg) wrote :

I can second the behaviour of not saving connection data and losing the network connectivity on 10.04 x86.

It happens, when the connection is set to "Manual" and the "Available for alls users" option is selected when applying.

AFAICT, the initial issue expressed in this bug report has long since been fixed -- if you see further issues relating to default routes, or configuring connections, please file new separate bugs using 'ubuntu-bug network-manager' which will also make sure we have all the pertinent information about the version of NetworkManager you're using, logs, and error messages.

Since the original issue appears to be fixed, I'll mark this bug Fix Released.

Thanks!

Changed in network-manager (Ubuntu):
assignee: Ubuntu Desktop (ubuntu-desktop) → nobody
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers