Network manager does not show EVDO, device detected by hal

Bug #366772 reported by Binoy on 2009-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
network-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: network-manager

EVDO Device : AC8700
# lsusb
Bus 005 Device 012: ID 05c6:3197 Qualcomm, Inc. CDMA Wireless Modem/Phone

# hal-find-by-capability --capability modem
/org/freedesktop/Hal/devices/usb_device_5c6_3197_noserial_if0_serial_usb_0

The entry for this modem is there in /usr/share/hal/fdi/information/10freedesktop/10-modem.fdi
However network manager does not show the device when its connected
I am able to dial using wvdial.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
IfupdownConfig:
 auto lo
 iface lo inet loopback
Package: network-manager 0.7.1~rc4.1.cf199a964-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: network-manager
Uname: Linux 2.6.28-11-generic i686

Binoy (mailbinoyv) wrote :
Binoy (mailbinoyv) wrote :

posted this to gnome bugzilla. Fix here
http://bugzilla.gnome.org/show_bug.cgi?id=583713

Pedro Villavicencio (pedro) wrote :

thanks for sent it there.

Changed in network-manager (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.8~a~git.20090911t130220.4c77fa0-0ubuntu1

---------------
network-manager (0.8~a~git.20090911t130220.4c77fa0-0ubuntu1) karmic; urgency=low

  * upstream snapshot 2009-09-11 13:02:20 (GMT)
    + 4c77fa08623f41dd710c545ec859dd7e942a3f2c
    + fix LP: #411668 - NetworkManager crashes in g_type_check_instance_cast ()
      when connecting to 3G
    + fix LP: #366772 - Network manager does not show EVDO, device detected by hal
    + fix LP: #424092 - ifupdown connection device locking regressions caused by
      system-settings rework
    + fix LP: #424603 - Not closing modems when disconnected

  [ Tony Espy <email address hidden> ]
  * fix build error due to upstream re-factoring
    - update debian/patches/lp291564_ifupdown_unmanage_mapping_and_iface.patch
  * fix install problem due to new PolicyKit changes
    - update debian/network-manager.install
  * fix install problem due to libnm-glib naming changes
    - update debian/libnm-glib-dev.install
    - update debian/libnm-glib0.install
  * handle upstream soname version bump for libnm-glib
    - update debian/control
    - rename debian/libnm-glib0.install => debian/libnm-glib2.install
    - rename debian/libnm-glib0.symbols => debian/libnm-glib2.symbols
    - update debian/libnm-glib2.symbols
  * add new olpc_mesg symbols to libnm-util1.symbols
    - update debian/libnm-utils1.symbols
  * fix lintian errors: update Standards-Version to 3.8.3, add missing
    ${misc:Depends}, and replace deprecated ${Source-Version} variables
    with ${binary:Version}
    - update debian/control

  [ Alexander Sack <email address hidden> ]
  * drop -0ubuntu1 suffix from ip6 symbols added in previous upload
    - update debian/libnm-glib0.symbols
  * remove hal from build-depends and depends (LP: #416988)
    - update debian/control
  * adjust patches to new upstream codebase
    - update debian/patches/lp291564_ifupdown_unmanage_mapping_and_iface.patch
    - update debian/patches/lp291902_IFUPDOWN_dont_export_connection_in_unmanaged_mode.patch
  * build depend on libpolkit-gobject-1-dev instead of libpolkit-dbus-dev
    - update debian/control
  * make GET_SOURCE not go mad for git versions that use a different abbrev-id syntax
    - update debian/rules
  * drop patches applied upstream
    - delete debian/patches/lp291564_ifupdown_unmanage_mapping_and_iface.patch
    - delete debian/patches/lp291902_IFUPDOWN_dont_export_connection_in_unmanaged_mode.patch
    - update debian/patches/series

  [ Mathieu Trudel <email address hidden> ]
  * adjust patches to new upstream codebase
    - update debian/patches/lp291564_ifupdown_unmanage_mapping_and_iface.patch
  * add rule to retrieve current snapshot information
    - update debian/rules
  * fix missing character in GET_SOURCE code
    - update debian/rules
  * use current snapshot hash from changelog instead of latest in get-snapshot-info
    - update debian/rules
  * update GET_SOURCE code: exit on any error
    - update debian/rules

 -- Alexander Sack <email address hidden> Mon, 14 Sep 2009 11:29:38 +0200

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
Changed in network-manager:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.