Ubuntu

Network Manager does not remember WEP/WPA key

Reported by hackel on 2006-03-25
132
This bug affects 9 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Unassigned
Nominated for Hardy by DJ_Barney
Nominated for Intrepid by Duncan Lithgow

Bug Description

== Regression details ==
Discovered in version: 0.7~~svn20080908t183521+eni0-0ubuntu4
Last known good version: 0.6.6-0ubuntu5

- Version: 0.5.1-0ubuntu19
+ Version: network-manager-gnome 0.6.5-0ubuntu8

Network manager is working fine for me aside from requiring me to type in my WEP password again each time I start my computer or re-init the wireless connection. First it asks for my gnome-keyring password, then a short time later it asks for my WEP key again. I've tried deleting my keyring and starting from scratch but it doesn't seem to help. It won't remember it no matter what. This is really annoying, since now I have to type in BOTH my gnome-keyring password and my WEP key for my home network every time I start my computer.

I'm not sure how to debug this further, but here are the relevent bits from my syslog:

Mar 25 16:52:32 localhost NetworkManager: process_scan_results: assertion `res_buf_len > 0' failed
Mar 25 16:52:32 localhost NetworkManager: <WARNING>^I (): nm_device_wireless_process_scan_results(wlan0): process_scan_results() returned an error.
[repeats many times]

<information>^ISWITCH: no current connection, found better connection 'wlan0'.

Mar 25 16:53:11 localhost NetworkManager: <information>^IActivation (wlan0/wireless): access point 'xxx' is encrypted, but NO valid key exists. New key needed.

Then I give it the key and it works fine. I can't wait for the next version without gnome-keyring, but hope this problem gets fixed before then! Let me know what additional information is required.

Duncan Lithgow (duncan-lithgow) wrote :

I have the same bug in Ubuntu Gutsy, Tribe 3 updated today Aug 10th.

Every time I restart the network I have to re-enter the WEP password, and supply a new password for gnome-keyring.

* Bug occurs on rebooting.
* Bug occurs if I right click to deactivate wireless and then the same to reactivate wireless.
* No bug if I use the hardware switch to kill the network and then unkill the network. That gives no trouble.
* (No action if I left click and try to log off and then back onto my preferred WEP network.)

Hardware:
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

Network:
eth1 Scan completed :
          Cell 01 - Address: 00:17:3F:53:D4:96
                    ESSID:"Nina og Nis"
                    Protocol:IEEE 802.11bg
                    Mode:Master
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Quality=71/100 Signal level=-63 dBm Noise level=-63 dBm
                    IE: WPA Version 1
                        Group Cipher : WEP-40
                        Pairwise Ciphers (1) : WEP-40
                        Authentication Suites (1) : PSK
                    Extra: Last beacon: 176ms ago
          Cell 02 - Address: 00:90:4B:E4:D8:77
                    ESSID:"wireless_44C"
                    Protocol:IEEE 802.11bg
                    Mode:Master
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 9 Mb/s; 11 Mb/s
                              6 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Quality=71/100 Signal level=-63 dBm Noise level=-63 dBm
                    Extra: Last beacon: 36ms ago

duncan@new-host-2:~$

description: updated
louis (l-jean-richard) wrote :

The WEP key goes lost also when trying to set up a network profile.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? the gnome-keyring part is already fixed btw. Thanks in advance.

Changed in network-manager:
status: New → Incomplete
Markus Kienast (elias1884) wrote :

I am still experiencing this bug in Tribe 5. Actually for me it looks slightly different than mentioned above. The WEP passphrase is asked first and the keyring password is only asked, since NM thereafter wants to store the passphrase in the keyring again. I checked for the password via the keyring-manager and it appears to be there.

If you need any more help, please contact me.

Markus Kienast (elias1884) wrote :

NM behaves right after hibernation.

Aaron Whitehouse (luna-tick) wrote :

Elias - I think those differences are what they meant when they said that "the gnome-keyring part is already fixed btw".

I am the same. Under Tribe *4*, I had the same issue: every time that I restarted, I was asked for the WPA/WEP key and then asked to set a new password for Gnome Keyring.

Under Tribe 5:
- Each time that I restart, I am asked for the WPA key, but when I enter it, I am only asked to type in the existing Gnome Keyring password (not to set a new password - i.e. Gnome Keyring is working correctly).
- Changing manually between wired and wireless, without rebooting, does not require me to re-enter the key. It works correctly.

Let me know if I can be of further help.

Aaron Whitehouse (luna-tick) wrote :

Can we bump the tag off incomplete now?

Aaron Whitehouse (luna-tick) wrote :

Hmm... I haven't done any updates, but everything is working okay now in Tribe 5.

I wonder if it is something unusual like Gnome Keyring needing to be set up before NM tries to save to it.

On Mon, Aug 27, 2007 at 08:20:06AM -0000, Aaron Whitehouse wrote:
> Hmm... I haven't done any updates, but everything is working okay now in
> Tribe 5.
>
> I wonder if it is something unusual like Gnome Keyring needing to be set
> up before NM tries to save to it.
>

Note, that only WPA can be taken as an example, because for WEP
network-manager cannot see if its a wrong password or just a bad
connection as there is no feedback about that in the protocol.

 - Alexander

Aaron Whitehouse (luna-tick) wrote :

Interesting.

I am using WPA now. As I say, I tested WEP on Tribe 4.

Kent (skent33) wrote :

I have installed 710 tribe 5 and am current with all updates as of 30-8-07 00:33 UTC. I am using WPA1 (TKIP). I am still getting the problems listed here:

Upon each reboot I am immediately asked for my gnome keyring password: Enter password for default keyring to unlock The application 'nm-applet' (/usr/bin/nm-applet) wants access to the default keyring, but it is locked.

I enter the gnome keyring password, then I get: Passphrase required for Wireless Network A passphrase or encrypted key is required to access the wireless network 'brn721'

After entering the passphrase, I still have to select brn721 from the Network Monitor menu in the top panel, regardless if it the only network in the list or not. (sometimes it is the only one detected, sometimes it isn't. Regardless, I have to select it)

After I select brn721, I finally get online.

Please let me know if I can be any more help.

Kent

Mike (mike0999) wrote :

I was able to make the problem go awayfor WPA by reverting to the feisty version of the network-manager (0.6.4-6ubuntu7) and to the feisty version of network-manager-gnome (0.6.4-6ubuntu7).

Alexander Sack (asac) wrote :

still an issue with up-to-date gutsy today?

Pedro Villavicencio (pedro) wrote :

Closing this bug for now, feel free to re open it if you can reproduce it with an up to date gutsy installation, thanks in advance.

Changed in network-manager:
status: Incomplete → Fix Released
hachi-roku (j-bondmi6) wrote :

Hello,
Im new to all of this kind of stuff.... I get this problem using gusty with all the lastet updates.

Im using WPA and each time i boot wireless doesnt work. If i get into the eth1 properties screen i see that the password is there, but wireless will not work until i delete and re-write the unchanged password in. Seems strange.

I noticed the thread has 'fix released', but im still getting it with an up to date distro (21/3).

any help wickedly appreciated.

I'm also getting this problem on a fully up to date Hardy beta install.

Additionally in the 'wireless networks' properties if I click 'show password' it shows what looks like a hex representation, whereas it should be showing a passphrase.

re-opening as it seems to have re-occurred.

Changed in network-manager:
status: Fix Released → Confirmed
Freemor (freemor) wrote :

I can confirm that this bug is present in a fully up-to-date Hardy install (release candidate)

I have 2 profiles/locations set:

profile 1. Roaming - the default set-up with all interfaces in roaming mode
profile 2. Home - with wireless settings for my home router and roaming on the wireless turned off

As long as I leave the settings on "Home" no problem. but if I stitch to "Roaming" the wireless password for "Home" gets Flushed.
The password for Roaming is never lost.. just for the manually configured profile/location

This bug seems to be fixed for me with a fully up to date Hardy.

Correction, it's not fixed. Seemed to work once but I may have been mistaken.

NobleSavage (nsavage-gmail) wrote :

I just installed Hardy and I'm having this issue. Sometimes network manager remembers the password, sometimes I have to type it in. I haven not been able to pin down a rhyme or reason as to when it works and when it doesn't. It just seems intermittently buggy.

Download full text (10.9 KiB)

I am experiencing the exact same problem, I must admin it's really frustrating. I upgraded my Toshiba Tecra M3 last night, and upon rebooting the Wireless was in a funny broken state. It prompts me for my WPA key, sometimes it accepts the key and sometimes not :(, was working fine in Gutsy.....also when I click on "Configure" for eth1 in the network manager it says "The interface does not exist", I way happy with Gutsy and thought upgrading to Hardy will make things better, instead I am now frustrated and thinking of reverting back to my old PowerBook G4 for work stuff...

May 11 11:25:40 jonathan-laptop NetworkManager: <info> New VPN service 'vpnc' (org.freedesktop.NetworkManager.vpnc).
May 11 11:25:53 jonathan-laptop NetworkManager: <info> Found radio killswitch /org/freedesktop/Hal/devices/ipw_wlan_switch
May 11 11:25:53 jonathan-laptop NetworkManager: <info> eth1: Device is fully-supported using driver 'ipw2200'.
May 11 11:25:53 jonathan-laptop NetworkManager: <info> eth1: driver supports SSID scans (scan_capa 0x21).
May 11 11:25:53 jonathan-laptop NetworkManager: <info> nm_device_init(): waiting for device's worker thread to start
May 11 11:25:53 jonathan-laptop NetworkManager: <info> nm_device_init(): device's worker thread started, continuing.
May 11 11:25:53 jonathan-laptop NetworkManager: <info> Now managing wireless (802.11) device 'eth1'.
May 11 11:25:53 jonathan-laptop NetworkManager: <info> Deactivating device eth1.
May 11 11:25:54 jonathan-laptop NetworkManager: <info> eth0: Device is fully-supported using driver 'sky2'.
May 11 11:25:54 jonathan-laptop NetworkManager: <info> nm_device_init(): waiting for device's worker thread to start
May 11 11:25:54 jonathan-laptop NetworkManager: <info> nm_device_init(): device's worker thread started, continuing.
May 11 11:25:54 jonathan-laptop NetworkManager: <info> Now managing wired Ethernet (802.3) device 'eth0'.
May 11 11:25:54 jonathan-laptop NetworkManager: <info> Deactivating device eth0.
May 11 11:25:54 jonathan-laptop NetworkManager: <info> Will activate wired connection 'eth0' because it now has a link.
May 11 11:25:54 jonathan-laptop NetworkManager: <info> Wireless now enabled by radio killswitch
May 11 11:25:54 jonathan-laptop NetworkManager: <debug> [1210461954.475517] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/platform_bluetooth').
May 11 11:26:29 jonathan-laptop NetworkManager: <info> Updating allowed wireless network lists.
May 11 11:26:30 jonathan-laptop NetworkManager: <info> SWITCH: no current connection, found better connection 'eth1'.
May 11 11:26:30 jonathan-laptop NetworkManager: <info> Will activate connection 'eth1/my_wireless'.
May 11 11:26:30 jonathan-laptop NetworkManager: <info> Device eth1 activation scheduled...
May 11 11:26:30 jonathan-laptop NetworkManager: <info> Activation (eth1) started...
May 11 11:26:30 jonathan-laptop NetworkManager: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) scheduled...
May 11 11:26:30 jonathan-laptop NetworkManager: <info> Activation (eth1) Stage 1 of 5 (Device Prepare) started...
May 11 11:26:30 jonathan-laptop NetworkManager: <info> Activation (eth1) Stage 2...

jojo4u (bugzilla-freedom-x) wrote :

Had the same problem, switched to wicd (http://wicd.sourceforge.net) and happy now. Only after suspend I have to reconnect manually.

Fabio M. Panico (fbugnon) wrote :

I'm having the same problem with a fresh installation of Xubuntu 8.04.

Using ndiswrapper for and USB adaptor (D-link DWA-110), I have no problem connection to a WPA protected wireless network. But after reboot, it does not reconnect automatically (I've notice that the USB adaptor blinks constantly as if it were trying to establish connection), instead I have to manually re-edit the wifi-network-configuration.

As mentioned in some other bug-report (https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/209026), the saved password that appears under the configuration just before I re-edit it looks much longer than the original paraphrase (19 characters long).

I haven't test this computer under a WEP protected network to see if the same problem occurs, but alike bugs-reported have only mentioned WPA problems.

By the way, I'm using a Toshiba Satellite 1000-S157, with an Intel Celeron (TM) of 1066Mhz, 512 Mb of RAM with and up-to-date Xubuntu under kernel 2.6.24-18-generic.

Zaca (zaca98) wrote :

Same problem in a Vaio NR using the intel3945 a/b/g iwlwifi3945 driver. There are no problems when using WICD, so
this is a bug on network manager, clearly, this is the description I gave in the forum:

I have the same problem in Hardy, in a vaio laptop with intel 3945 a/b/g.

I connect to the wireless network (either WEP or WPA). If I get disconnected,
or the next time I try to connect, the conection fails. If I go to the
"Edit wireless networks..." there is a different passphrase (actually a sequence
of letters and number) that does not seem to be related to the original one.

If I go Applications->Passwords and encryption keys, chose the password (which
is there), and see it, it is not the password I put and neither the one
that is visible in the "Edit wireless..."

It does not seem that the password is being forgotten, but actually that
some encription is not being well communicated through the system, in such
a way that the password is changed.

The same network works nice with WICD, but I would like to stay with the
standard distribution if possible.

I think this is a bug. I will try to post it as one.

Fabio M. Panico (fbugnon) wrote :
  • unnamed Edit (1.9 KiB, text/html; charset=ISO-8859-1)

Hi Zaca,
Thank's for your feed-back. I also switch to WICD and it's working fine
now.
Cheers,
Fabio

2008/6/23 Zaca <email address hidden>:

> Same problem in a Vaio NR using the intel3945 a/b/g iwlwifi3945 driver.
> There are no problems when using WICD, so
> this is a bug on network manager, clearly, this is the description I gave
> in the forum:
>
> I have the same problem in Hardy, in a vaio laptop with intel 3945
> a/b/g.
>
> I connect to the wireless network (either WEP or WPA). If I get
> disconnected,
> or the next time I try to connect, the conection fails. If I go to the
> "Edit wireless networks..." there is a different passphrase (actually a
> sequence
> of letters and number) that does not seem to be related to the original
> one.
>
> If I go Applications->Passwords and encryption keys, chose the password
> (which
> is there), and see it, it is not the password I put and neither the one
> that is visible in the "Edit wireless..."
>
> It does not seem that the password is being forgotten, but actually that
> some encription is not being well communicated through the system, in such
> a way that the password is changed.
>
> The same network works nice with WICD, but I would like to stay with the
> standard distribution if possible.
>
> I think this is a bug. I will try to post it as one.
>
> --
> Network Manager does not remember WEP/WPA key
> https://bugs.launchpad.net/bugs/36651
> You received this bug notification because you are a direct subscriber
> of the bug.
>

DJ_Barney (barney-holmes) wrote :

I also have to keep entering the password. Will this be fixed or is there a new way of doing it coming down the line ?

DJ_Barney (barney-holmes) wrote :

WiCD work for me as well :)

Why not make WiCD a default install or at least part of he main packages for the moment ? Then it can always be an alternative to whatever replaces network manager.

hackel (hackel) wrote :

This is a *bug report* about *Network Manager* not a discussion forum! Please stop spamming us all with useless comments about WiCD and "me toos" without specific, relevant information that can be used to help squash this bug. Network Manager works fine for me, it always remembers my keys, and that is why it will remain the default choice for Ubuntu. There is obviously a bug(s) which is causing this problem for you all, which is why it must be solved. But unless you have relevent info to contribute, do not comment, just subscribe to this bug if you want to keep up with its progress. My apologies to you all for spamming you with this message, I just get sick of Ubuntu's inexperienced user base clogging up the BTS. If you would like to continue this discussion, please start a thread on http://ubuntuforums.org/ (if one doesn't already exist). Thank you!

DJ_Barney (barney-holmes) wrote :

Why the attitude ? Please lookup the meaning of the word Ubuntu. I think all these comments are relevant.

xens (r-aviolat) wrote :

Hi, same problem here on my thinkpad T40, running Intrepid Ibex alpha 3. Every boot network managers asks for the key. I checked the key exists in the keyring-manager, you can found the syslog-output attached. Maybe this bug is already corrected with network-manager 7.0, will see :).
cu

hachi-roku (j-bondmi6) wrote :

Hey Hey.

Sis the Hardy upgrade and still got the same problem. VERY annoying, you think by the amount of people having this drama that developers would have came up with something by now???

Anyway, I swapped to Wicd and its been great so far. Props.

J

chickendude (nipunn1313) wrote :

Hello,

I'm using Hardy and have a WEP connection. Every time I boot up the computer, it asks for the WEP passkey. Sometimes it likes it, sometimes it asks for it again. After a 2-3 tries, it gets the connection and things work for a while, but it's a huge pain to keep entering the WEP key every time I boot up.

I think that the 2-3 tries has to do with how many requests to the router it takes before it gets an IP offer.
I know if I just run sudo dhclient -d inside a terminal, it takes 2 or 3 tries before it grabs an IP.

I will try out the WicD option, but I would REALLY like to see this fixed in networkmanager.

Gordon E (geroad) wrote :

Wicd also works for me. Network Manager would not remember network passphrase. Had to remove
encrypted password and re-enter non encrypted one every time to connect to wireless.

Alexander Sack (asac) wrote :

i think this issue doesnt exist anymore. if i am wrong reopen.

Changed in network-manager:
status: Confirmed → Invalid
hachi-roku (j-bondmi6) wrote :

If you change to Wicd. NM still has it.

der_vegi (m-may) wrote :

Similar problem for me using Intrepid Alpha 6 (amd64) with network-manager 0.7~~svn20080908t183521+eni0-0ubuntu3. Everytime I boot, I have to reenter the passphrase (WEP 129 bit, shared key). But only once, then it connects instantly and stays connected.
This does not happen in Fedora 9 using network-manager 0.7 as well.

Any more information I can provide?

Changed in network-manager:
status: Invalid → Confirmed
der_vegi (m-may) wrote :

Ah, reading Freemor's comment, I should add, that I am using a manually configured (over nm-applet) connection with static IP.

I'm also seeing this bug in 8.10.

Yes, I also see this in Intrepid and find it very annoying.

Olivier Cortès (olive) wrote :

Here on latest Intrepid. I've switched from WPA to WEP at home, and i'm hitting this behaviour.
before (when I was using WPA), NM has remembered my WPA key without a problem, and with seahorse I can see my old WPA key sitting in my gnome-keyring… But I can't manually add the WEP one, for NM to find it.
I've always been in "full automatic" mode (dhcp, never touched /etc/network/interfaces).

Xisco Faulí Tarazona (x1sc0) wrote :

Today I updated to 0.7~~svn20080928t225540+eni0-0ubuntu2~nm3~hardy1 and seem this bug is already fixed, at least to me!

Thanks !

fiatguy85 (gtg880w) wrote :

Also having this issue in Intrepid using 128-bit WEP key. Opening the "Edit Connections" dialog shows no key is saved there.

Gavin Graham (gavingraham) wrote :

Where do you D/L 0.7~~svn20080928t225540+eni0-0ubuntu2~nm3~hardy1 ?

Andres Mujica (andres.mujica) wrote :

Hi i've got this behaviour since upgrading to intrepid alpha. never seen it before..

ii network-manager 0.7~~svn20080908t183521+eni0-0ubuntu4

Colin King (colin-king) wrote :

I'm also seeing this bug in 8.10, Alpha 5, and daily ISO image http://cdimage.ubuntu.com/daily-live/20080930.4/intrepid-desktop-amd64.iso

Specifically, NetworkManager Applet 0.7.0 ~~svn20080907t033843-0ubuntu2 will no longer my WPA2 personal password and I have to enter it each time I log on on my Dell or Lenovo laptops. This is a regression from Hardy 8.04.

Andres Mujica (andres.mujica) wrote :

yeap, this is a regression with hardy the problem wasn't there.

Also this seems to be a dup or at least related to bug #131233

description: updated
Horus424 (horus424) wrote :

Finally, it works... Francesc Faulí Tarazona is right. Updating to 0.7~~svn20080928t225540+eni0-0ubuntu2~nm3 solves this bug. The connection between Network-manager and seahorse works now, even the once entered password is now displayed in the nm-applet connection settings panel!

I updated Neetwork-Manager to the version mentioned above by adding

deb http://ppa.launchpad.net/network-manager/ubuntu intrepid main
deb-src http://ppa.launchpad.net/network-manager/ubuntu intrepid main

to the sources.list.

0.7~~svn20080928t225540+eni0-0ubuntu2~nm3
Fixed my problem with WPA/WPA2 passwords.

Scott Wegner (swegner) wrote :

Just like to add that this bug still exists in Intrepid beta. Installed last night; fairly annoying to have to re-enter my password on every connect

CPKS (c-1) wrote :

Confirm what others have said about 0.7~~svn20080928[etc]

Nick B. (futurepilot) wrote :

Confirming 0.7~~svn20080928t225540+eni0-0ubuntu2~nm3 does save the password.

Jonathan Grubbs (jgrubbs) wrote :

Adding those to the sources list fixed the problem for me as well.

Forgive my ignorance for asking this question, but at what point should I remove those lines from the sources list?

Alexander Sack (asac) wrote :

network-manager (0.7~~svn20080928t225540+eni0-0ubuntu2) intrepid; urgency=low

  [ Alexander Sack < <email address hidden>> ]
  * remove patches forwarded/applied upstream
    - delete debian/patches/80_lp259503_access_to_freed_device_struct.patch
    - delete debian/patches/honour_resolvconf_exitcode.patch
    - delete debian/patches/lp269010_keyfile_secrets_crash.patch
    - update debian/patches/series
  * LP: #276253 - NM 0.7 sets hostname to localhost.localdomain instead of
    what is in /etc/hostname - we fallback to hostname configured in
    /etc/hostname even when no distro specific system plugin is enabled; we
    do this for all cases until a proper solution was found.
    - add debian/patches/fix_system_hostname.patch
    - update debian/patches/series

  [ Matt Zimmerman < <email address hidden>> ]
  * (apport hook) Use [].append rather than the += operator, to avoid things
    like: "InterestingModules: b 4 4" (should be b44)
    - update debian/source_network-manager.py

 -- Alexander Sack < <email address hidden>> Thu, 02 Oct 2008 20:37:20 +0200

Changed in network-manager:
status: Confirmed → Fix Released
der_vegi (m-may) wrote :

Well, at least for me this update does not solve the issue. I have an Intrepid Alpha 6 (amd64) installation with all updates applied including the nm svn20080928... above. I installed the update, rebooted, typed in the passphrase and connected, but after the next reboot, the password is again lost.
My configuration is the following: WEP 128 bit, shared key and manual IP set over the "Edit connections" dialogue.
Has anyone still the same problem? Reopen the bug?

I have the same problem using Intrepid Alpha 6 on amd64. Network manager never remembers the WEP key after reboot. Also I have a problem after hibernation where I must restart completely before the wireless interface becomes available again reporting that the 'link is down'. No amount of ifup-ing and if-down will get it back until I restart.

Gavin Graham (gavingraham) wrote :

Updated to NM 0.7~~svn20080928t225540+eni0-0ubuntu2 and rebooted. Upon login it asked for my WEP key again so I entered it. :(
Then I rebooted again and logged back in and hey presto! I was connected without having to re-enter my WEP key. It seems that entering the key one more time after updating, has re-saved the key.
Woohoo! :)
Confirmed as fixed for me.

I can confirm NM 0.7~~svn20080928t225540+eni0-0ubuntu2 fixes problem with WPA but broke down WEP passwords.
Exactly NM does not pass password to wlan interface.
When I type "iwconfig wlan0" while NM tries to connect to network "Key" variable is empty.

der_vegi (m-may) wrote :

Ah, okay. Also works for me, if I delete the manual configuration and then set it up with the new NM installed.

Thomas Schewe (thosch66) wrote :

@reallifedesign.co.uk

Perhaps your problems after hibernation are not caused by nm. I have similar problems after standby. It's seems to be a driver-problem. After resuming I remove and reload the driver-module (sudo modprobe -r <drivermodule>;sudo modprobe <drivermodule>).

I fixed my problems by removing old entry and adding new one. So every
thing works

swdFrog (simon-robert-frogtec) wrote :

I have a related bug. I am using ubuntu-eee, for the eeepc. It has been reported that the eeepc, (I've seen the problem mentioned in relation to a couple ubuntu offshoots fopr the eeepc), running ubuntu cannot get a good connecction to netgear routers with WPA security (eeebuntu and ubuntueee tried). So switched to WPA2 and connects fine.

The problem is that network-manager resets from WPA2 to WPA each time one enters properties and after each reboot. So I guess that network-manager calculates the according to WPA2 rules and then slips the definition back to/or detects WPA2 as WPA, immediately afterwards so on the next time the passphrase is calculated (this calculation process is why the passphrase is much longer when you next look at the display field) it's done according to WPA rules and fails. On some occasions it, network-manager, just blanks the password field.

I've just re-installed ubuntueee and a WPA2 protected router has been detected as WPA. Hope this mail isn't too anecdotal and doesn't enrage "professional" debuggers.

Si

Dan MacDonald (allcoms) wrote :

I was very disappointed to see this highly irritating bug (nm not remembering my WPA password after a reboot) make it all the way to 8.10 RC x86-64, which I did a fresh install and full update of today. The problem persisted after the update so that magical working nm package mustn't have made it into the official repos yet?

I'm not that bothered now as I've already switched back to wicd but it will be a great, great shame if this problem doesn't get fixed for 8.10 final and I've got both fingers crossed for wicd being included as standard in the next ubuntu release as it makes a world of difference to the usability / desktop viability of Ubuntu, easy internet setup & access.

Thomas Perl (thp) wrote :

I have installed Intrepid Ibex (final!) and am experiencing the same bug - it seems like Network Manager saves/decodes the password in a wrong way, because the entry box is pre-filled with a (wrong, much longer) key and when I enter my key, it works. It is annoying that it does not save the WPA key!

hachi-roku (j-bondmi6) wrote :

How good is Wicd!!!! i set it in hardy up and have forgotten all about this bug!

Alexander Sack (asac) wrote :

Thomas your bug is due to bug 292054. dont post in closed bugs.

savantelite (savantelite) wrote :

I am having this problem with my Asus EEE 1000HE under Juanty Alpha 5

I have to reenter the network pass phrase every time I get on my network?

tags: added: iso-testing

I've got the same problem after upgrading to Lucid Alpha2. I have to retype my network key after each reboot. In Karmic everything was working fine. Current installed version of NM is 0.8~rc2-0ubuntu1

Jack Leigh (leighman) wrote :

Having the same problem in Lucid here with WPA/2 Enterprise.
Seems to have been fixed by ticking 'make available to all users' under Preferences -> Network Connections

Same problem here, on a fresh install of Lucid Lynx (final).

Fabio Puddu (fabius) wrote :

This bug is still present in Lucid! Please unmark it being "Fix released"

Xodetaetl (ovocean) on 2010-08-13
Changed in network-manager (Ubuntu):
status: Fix Released → Confirmed
Pedro Villavicencio (pedro) wrote :

Thanks for the report, however can you please open a new one? this was closed on 2008 If you're having a similar issue open a new report with : ubuntu-bug network-manager so we can triage it and then the developers can have a look into it , thanks in advance.

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers