huawei usb-modem (12d1:1003) not detected

Bug #366051 reported by Andreas Moog on 2009-04-24
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: network-manager

1. I had to pass usbserial.vendor and usbserial.device - options via grub to kernel for the modem to be recognized.
2. Excerpt from syslog:

Apr 24 14:03:03 imhotep kernel: [ 130.181297] usbserial_generic 1-2:1.0: generic converter detected
Apr 24 14:03:03 imhotep kernel: [ 130.181602] usb 1-2: generic converter now attached to ttyUSB0
Apr 24 14:03:03 imhotep kernel: [ 130.182379] usbserial_generic 1-2:1.1: generic converter detected
Apr 24 14:03:03 imhotep kernel: [ 130.182645] usb 1-2: generic converter now attached to ttyUSB1
Apr 24 14:03:03 imhotep kernel: [ 130.183257] usbserial_generic 1-2:1.2: generic converter detected
Apr 24 14:03:03 imhotep kernel: [ 130.183776] usb 1-2: generic converter now attached to ttyUSB2
Apr 24 14:03:03 imhotep kernel: [ 130.184513] usbserial_generic 1-2:1.3: generic converter detected
Apr 24 14:03:03 imhotep kernel: [ 130.184778] usb 1-2: generic converter now attached to ttyUSB3
Apr 24 14:03:03 imhotep nm-system-settings: SCPlugin-Ifupdown: device added (udi: /org/freedesktop/Hal/devices/usb_device_12d1_1003_noserial_if0_serial_usb_0, iface: (null)): iface not found
Apr 24 14:03:04 imhotep NetworkManager: <info> (ttyUSB0): found serial port (udev: hal:GSM)
Apr 24 14:03:04 imhotep NetworkManager: <info> (ttyUSB0): ignoring due to lack of probed mobile broadband capabilties
Apr 24 14:03:04 imhotep NetworkManager: <info> (ttyUSB2): ignoring due to lack of mobile broadband capabilties
Apr 24 14:03:04 imhotep NetworkManager: <info> (ttyUSB1): ignoring due to lack of mobile broadband capabilties
Apr 24 14:03:04 imhotep NetworkManager: <info> (ttyUSB3): ignoring due to lack of mobile broadband capabilties

What other information do you need?

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
IfupdownConfig:
 auto lo
 iface lo inet loopback
Package: network-manager 0.7.1~rc4.1.cf199a964-0ubuntu2
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: network-manager
Uname: Linux 2.6.28-11-generic i686

Andreas Moog (ampelbein) wrote :
Andreas Moog (ampelbein) wrote :

Result of udevadm info --query=all --path=/sys/class/tty/ttyUSB1 --attribute-walk attached.

summary: - huawei usb-modem (12d1:1003) not recognized
+ huawei usb-modem (12d1:1003) not detected
sunatomo (naiyu) wrote :

I have the Huawei E220 and it cause the same problem.
If udev can't detect the serial Interfaces, it can't connect ppp via NetworkManager and pppconfig (& pon).
In such timings, I have to send any ATcommand to /dev/ttyUSB1 first, and then it can understand ATcommand via /dev/ttyUSB0.

So, I think udev have to send any ATcommand to this modem's /dev/ttyUSB1 first, then detect the /dev/ttyUSB0.

Fionn (fbe) wrote :

I can confirm this bug. Since I urgently need a working UMTS stick, I'd be very glad if someone could please tell me what I can do now to work around this problem. (Dist-Upgrading hardy is not an option at the moment and the older packages apparently left ppa already so I cant go back).

Fionn (fbe) wrote :

Update: Using the rules file from

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/346835/comments/11

solved the problem for me. Thanks!

sunatomo (naiyu) wrote :

Above udev rules solved this problem too.
But my modem uses HSDPA network and it have to detect the wireress connection using "AT+CGREG?" not for "AT+CREG?" (if you use GSM network ,it can detect wireless connection using "AT+CREG?").

Przemek K. (azrael) wrote :

Andreas:
does this bug still appear in Ubuntu 9.10 or 10.04?

Changed in network-manager (Ubuntu):
status: New → Incomplete
iav (iav) wrote :

Modem detects and work if usb-modeswict package was installed; if not - bug still active for daily-desktop 10.04

Przemek K. (azrael) wrote :

This should be fixed now as usb-modeswitch is included in Ubuntu 10.10

Changed in network-manager (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers