Comment 2 for bug 283233

milasch (jfilho-gmail) wrote :

yes, it is still happening.... Here is what I did:

Created a new connection, gave the manual ipv4 settings, and clicked ok;
A new connection was then available for me to select when right clicking the system tray network-manager icon. The settings didn't work right away;
I tried deleting auto eth0, and then yes, the settings of the new connection took effect.
I tried then to reboot the computer, and found out the settings went back to its prior state, with the DHCP mode.
Then I right clicked the system tray icon to find there was no option to change the settings to my new created connection, I mean, it wasn't showing there, although when I go to Edit Connections, it is shown there.
One thing I noticed, auto eth0 connection came back, and if I change it to manual ipv4 settings and rename it, it doesn't take effect. It also states in the auto eth0 connection a "never" on the second column, and I believe that it means it has never been used. My new created connection states "3 minutes ago" and will take effect only if I delete auto eth0 (since there is no way of changing it to the current connection to be used).

But if I reboot, auto eth0 will come back again.