Comment 11 for bug 283233

That's exactly what I thought. Thanks!! :)

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
photonymous
Sent: 09 November 2008 01:30
To: <email address hidden>
Subject: Re: [Bug 283233] Re: network manager won't save fixed ip settings
onwired connections

Yup, I also experienced similar symptoms. This thing has multiple problems
and un-intuitive behaviours, and needs to be fixed!

On Sat, Nov 8, 2008 at 11:23 AM, Pablos544 <email address hidden> wrote:

> I've just downloaded Ubuntu 8.10 and have experienced a similar problem.
> I'm trying to set-up a static IP address for my PC but the Network
> Settings don't 'stick' as the guy above 'photonymous' says, and when i
> reboot the 'Auto eth0' connection resurfaces.
>
> Further confusingly the Network Control Panel in Ubuntu claims that the
> 'Auto-eth0' connection is 'never' whereas my newly created 'My eth0'
> connection is '3 minutes' but when i delete the auto-connection the
> system tray proudly proclaims that that 'My network is now
> disconnected', and in a few moments the Network Manager announces
> through the System Tray that 'My eth0' connection is now connected. But
> when i restart the computer the 'Auto eth0' connection is again created
> and it is the default connection. My new connection is there but not
> active. I manually then have to convince the system that 'My eth0' is
> the one to use again, but no matter what i do these settings are lost
> next time start Ubuntu which then goes back using 'Auto eth0'.
>
> This didn't use to be no problem in Ubuntu 8.04.
>
> --
> network manager won't save fixed ip settings on wired connections
> https://bugs.launchpad.net/bugs/283233
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
network manager won't save fixed ip settings on wired connections
https://bugs.launchpad.net/bugs/283233
You received this bug notification because you are a direct subscriber
of the bug.

Status in "network-manager" source package in Ubuntu: Triaged

Bug description:
Trying to set a static IP address on Intrepid Ibex Beta's out of the box
network manager (version 0.70), and I do the following:

Right click on the task bar's icon, select "Edit Connections", On wired tab
I click on the only interface shown (auto eth0), then click on Edit, select
IPV4 settings, change the method to manual, write my own settings, for
IP/Mask/Gateway and finally DNS, click OK, but nothing changes when I do
ifconfig. If I reboot the settings I've inserted there will not show.

milasch@milasch-desktop:~$ lsb_release -rd
Description: Ubuntu intrepid (development branch)
Release: 8.10

milasch@milasch-desktop:~$ sudo apt-cache policy network-manager
[sudo] password for milasch:
network-manager:
  Installed: 0.7~~svn20081008t224042-0ubuntu3
  Candidate: 0.7~~svn20081008t224042-0ubuntu3
  Version table:
 *** 0.7~~svn20081008t224042-0ubuntu3 0
        500 http://ca.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
milasch@milasch-desktop:~$