[MASTER] NM 0.7 lacks bluetooth 3g support

Bug #269329 reported by Alexander Sack on 2008-09-12
338
This bug affects 34 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Wishlist
Baltix
Undecided
Unassigned
network-manager (Ubuntu)
Medium
Unassigned
Nominated for Dapper by Jason Alan Graves
Nominated for Gutsy by Jason Alan Graves
Nominated for Hardy by Jason Alan Graves
Nominated for Intrepid by Jason Alan Graves
Nominated for Jaunty by Jason Alan Graves

Bug Description

Binary package hint: network-manager

NetworkManager 0.7 officialy doesnt support bluetooth 3g yet. this bugs serves as the master.

Alexander Sack (asac) wrote :

medium, because most phones should have a usb way of using them as well (which works in general)

Changed in network-manager:
importance: Undecided → Medium
status: New → Triaged
Changed in network-manager:
status: Unknown → New
Tore Anderson (toreanderson) wrote :

This is a regression from Hardy.

With ppp0 set up correctly in /etc/network/interfaces it was quite possible to start a PPP connection over Bluetooth DUN. The feature wasn't too polished, I could for instance not start VPN over this connection (it was grayed out in the menu), and it did not detect any connection failures, but at least it worked. It appears to be impossible to do this with NM 0.7.

Besides, lugging around an USB cable sucks...

Tore

Eric Appleman (erappleman) wrote :

I think it's also problematic that NM 0.7 doesn't even pick up my VX8350 when I connect by USB either.

Craig Ringer (ringerc) wrote :

Note that you can still connect fine with pon/poff if you have the appropriate chat scripts and pppd config ; it's just that NM doesn't offer you any menu entries for it (and online/offline detection won't notice the connection).

diel (djlangton) wrote :

This is a great shame, especially since its touted as a feature in the Intrepid press release:

[quote]
3G Support
For constant connectivity public WiFi has limitations. Improvements to the network manager in Ubuntu 8.10 makes it simple to detect and connect to 3G networks and manage connectivity. This connectivity is delivered through an inbuilt 3G modem, through 'dongle' support, through a mobile phone or through Bluetooth. It is a complex environment that Ubuntu 8.10 simplifies through a single interface and the auto-detection of many of the most popular devices.
[/quote]

Ambricka (petter-ambricka) wrote :

It would be sufficient if nm had built in support for plain ppp over serial interface dialup as it used to have before. Or am I just missing some vital part?

wvdial from shell works, but not integrated with nm.
gnome-ppp has never worked for me...

Jamie Lokier (jamie-shareable) wrote :

I'm under the impression that 3G broadband over Bluetooth can be done over:

    - PAN Bluetooth protocol
    - DUN Bluetooth protocol
    - RFCOMM Bluetooth protocol

PAN does not use PPP. Rather, you activate the PAN link, and that gives you a packet network, like ethernet. Then you can use DHCP etc. and it generally works to give you an internet connection, although sometimes a reduced MTU is required - not always reported correctly over DHCP.

Some phones support more than one of these. I didn't see any options in NetworkManager's Edit Connections window to choose which of the Bluetooth protocols to use.

When I did fill in some dialup settings (for the 3 network in the UK), they looked fine, but I didn't find anywhere to activate the connection having added it! The GUI looked to me like right-clicking on a connection ought to enable/disable it or something, but no such behaviour. The connection did not appear in the main NM list - only my wireless APs, and (bizarrely) "ifupdown (tap0)" (+tap1, tap2) under wired.

It's only on reading this bug report that (doh!) I realise "mobile broadband" doesn't mean mobile broadband the way I've been used to it - it means only via a built-in or USB 3G modem, doesn't it?

RFCOMM should be really easy to support. It's simply dialup with PPP, except you use /dev/rfcomm0 as the serial port. It's possible that it can take up a channel of the phone's mobile link, preventing web browsing and other data access on the phone itself. PAN seems better in this respect.

On Hardy, I tested Bluetooth RFCOMM and USB ACM for broadband, and found Bluetooth slightly slower but it seemed to use less power than USB, so I've used Bluetooth on Hardy ever since.
When I got a new phone, I switched to Bluetooth PAN.

On Hardy I had to kill NM to use 3g broadband. On Intrepid, I was excited to see the "mobile broadband" under Edit Connections, and disappointed to find this doesn't mean via Bluetooth, which surely is the most common way of doing it with a mobile phone? I'm hoping I'll be able to use PAN the same way as I did in Hardy, but haven't had success yet.

Alexander Sack (asac) wrote :

from what i understand the problem with bluetooth is that those devices are not properly registered in hal and current NM infrastructure requires all managable devices to be exposed through hal. However, modemmanager will come right after 0.7 is final and then we will surely tackle bluetooth with high prio.

Changed in network-manager:
status: New → Confirmed

Hello, is there an ETA of when Network Manager 0.7 will support connectivity via bluetooth from a GSM GPRS cell phone? I just switched from Microsoft Vista to Ubuntu 8.10, and I did so based upon reading that this connectivity would be present via the GUI.

I regret that I installed Ubuntu over that Microsoft installation. But, I do, in general, like Ubuntu. This bug was filed with a low priority, and I must be honest, it should be a high priority, this functionality was advertised.

Is there a place where a donation can be made toward this project? I can't contribute via active work on these things, but I can certainly donate some money.

dshosu (dshosu) wrote :

I too am curious as to when this feature will be implemented, as it was originally intended to.

Gary T. Giesen (giesen) wrote :

I too an eagerly awaiting this functionality. I'm currently working around it with gpppon, but doesn't allow me to initiate any VPN connections from NM.

Shinoj (shinojpv) wrote :

i too find it disappointing to know that ubuntu 8.10 NM does not allow net through bluetooth. i have been manually configuring rfcomm over the changing versions of ubuntu to connect net through bluetooh. it seems one has to wait still a long time to get bluetooth integrated into the NM

Daniel Holm (danielholm) wrote :

I also miss this feature. I could use wvdial, but then I would miss out about the D-bus extension in NM 0.7

Daniel Holm (danielholm) wrote :

Among other awsome things in NM 0.7

A pat on the back to the NM devs for the huge additional functionality NM now provides.

While I can connect seamlessly through a USB cable to my Nokia N95 modem, connecting via Bluetooth is way up on my need to have list.

dav2dev (gin18) wrote :

I also miss the old style 56k connection. I think it is the same as bt connection, since they both use a serial port.

Mikel Ward (mikelward) wrote :

So who's actually working on this? How can I help?

marduk (dennis-schwan) wrote :

I also need BT in NM for the VPN functions!

Daniel Holm (danielholm) wrote :

Couldn't you create a symlink from /dev/rfcomm* to a /dev/tty*? Because tty is what the modems is discovered as, right?

On Sat, 2008-12-27 at 00:36 +0000, Daniel Holm wrote:
> Couldn't you create a symlink from /dev/rfcomm* to a /dev/tty*? Because
> tty is what the modems is discovered as, right?
>

No, because NM uses HAL to enumerate serial ports, not an
'ls /dev/tty*'.

--
⎊ Michael Gratton. "Mea navis aëricumbens anguillis abundat."
⎈ <http://web.vee.net/>

Daniel Holm (danielholm) wrote :

Oh, I see. Well then, is there any other way to maybe create a serial port or what ever?

Alexander Sack (asac) wrote :

Daniel Holm wrote:
> Oh, I see. Well then, is there any other way to maybe create a serial
> port or what ever?
>
>
there is currently discussion about this on network manager list ...

marduk (dennis-schwan) wrote :

Do you have a link for that list

Fabián Rodríguez (magicfab) wrote :

It seems using gnome-ppp or kppp directly is the only option in Intrepid.

For gnome-ppp, see:
https://help.ubuntu.com/community/DialupModemHowto/SetUpDialer#For%20Ubuntu,%20alternative%20approach%20(using%20gnome-ppp)

From the upstream's mailing list [1]:

"> 3) Dialup support is gone now? Dialup is so 90's now, but unfortunately
> bluetooth DUN is still alive and kicking. However, I couldn't seem to
> find a way to use this in NM currently, nor could I find any way to
> enable it. Am I missing something here to enable it, or was it just
> simply (finally) removed and to be considered legacy? Seems there'd
> still be a lot of people stuck using traditional dialup to abandon them
> entirely...

The "dialup" support in NM was simply a menu shortcut for the distro
native scripts to ifup / ifdown the connection, and was in no way
integrated into NetworkManager itself. Hence one of *the* most
requested features was for integrated 3G support so that people could
use the NM VPN plugins with mobile broadband."

[1] http://mail.gnome.org/archives/networkmanager-list/2008-December/msg00022.html

Antonio Macchi III (macchi) wrote :

I personally believe that the priority for this bug should be higher.

Many users around me see this as a bug. Presently it seems necessary to deactivate or remove the Network Manager in order to connect to internet through many modems and mobile phones. Without removing or deactivating NM, then Firefox and Evolution start in off-line mode even if ppp connections are active - since NM reports an erroneously condition through dbus.

A transitional solution would be smoother integration with the ppp graphical tools. This is necessary because the demand for mobile connectivity increases all the time and comprises bluetoot, 3G phones, modems and other new services.

Could you give us some hints on how to improve NM to integrate som graphical ppp tweaks?

Valmantas Palikša (walmis) wrote :

Blueman 1.0svn handles bluetooth dialup connections very nicely. It exposes rfcomm interfaces to hal and network manager grabs them automatically.
Here's a demonstration video: http://walmis.balticum.lt/blueman1.0_networking.ogv.tar

Jamie Lokier (jamie-shareable) wrote :

Valmantas Palikša wrote:
> Blueman 1.0svn handles bluetooth dialup connections very nicely. It
> exposes rfcomm interfaces to hal and network manager grabs them
> automatically.
>
> Here's a demonstration video: http://walmis.balticum.lt/blueman1.0_networking.ogv.tar

Valmantas, does it work with bluetooth PANU way of connecting to the
internet too?

Thanks,
-- Jamie

Valmantas Palikša (walmis) wrote :

Jamie, yes it does.

Eric Appleman (erappleman) wrote :

The Blueman team has just finished adding 3G support.

http://blueman.tuxfamily.org/forum/viewtopic.php?f=5&t=113

Misha Koshelev (misha680) wrote :

Does not connect with my phone with blueman:

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/329047

For that matter my phone's not supported USB with entwork manager even though it forms a /dev/ttyACM0 fine
and works with non-nm

Misha

Gavin Hamill (gdh) wrote :

I get my Windows Mobile 6.1 'Internet Sharing' connection to work using PAN by doing this:

sudo pand -r PANU -c 00:22:A5:18:D7:E4 (needs bluez-compat installed)
sudo dhclient bnep0

However, this is still a horrid kludge - it would be sensible if NM could see the PAN profile being advertised by my phone (which has been paired using the GNOME bluez tray applet) and treat it as a possible network adapter just as it does eth0 and wlan0

Robert Navarro (crshman) wrote :

I have been trying to get this to work with my motorola q9h and blueman. Blueman connects to the phone and creates a dialup connection just fine. I can connect to this using gnome-ppp. The latest Blueman also adds HAL support for the mobile broadband device, which shows up in the nm-applet. I configure it for a standard ATT connection however when I try to connect it immediately disconnects.

I have run some diagnostics listed in bug 289690:
#sudo su
#NM_SERIAL_DEBUG=1 NetworkManager --no-daemon 2>&1 | tee /tmp/nm-serial.txt

I have attached the output of this (nm-serial.txt) while trying to connect to my bluetooth phone modem.

I have also applied the patch that was given in bug 290177, with no success.

If anything else is needed to help debug this let me know!

jac0b (jacbrooks) wrote :

I can get blueman to create a rfcomm connection which network-manager detected in intrepid but now since I upgraded to jaunty network-manager does not see the connection if I downgrade to another version of network-manager it sees the connection but with the default version that comes with jaunty does not work.

This is the downgraded version I used:
https://launchpad.net/~network-manager/+archive/ppa

[quote from #345060]
 Valmantas Palikša wrote 1 hour ago: (permalink)

This bug is fixed in blueman svn. Basically linux.sysfs_path = /sys/class/tty/rfcomm* needs to be exported too.
[/quote]

OK, I did not know that it would be so easy.... I used the change in HalManager.py found in SVN to update my laptop and
now it works with the latest network-manager package from jaunty stock repository (0.7.1~rc3.1.git4cf2da146-0ubuntu1).

Is there any chance to get new blueman package created soon, where this change will be integrated?

Richard B. (richie) wrote :

What about the progress?

Will a fixed Blueman package be released or a fixed network-manager? Or both?

It sucks to use Windows while surfing on train...

Valmantas Palikša (walmis) wrote :

Blueman 1.1 is almost complete, It will be released soon, this week probably.

Ambricka (petter-ambricka) wrote :

@Bössen: rfcomm + wvdial is fairly easy to set up, that's what I use.

I cherry-picked Blueman change (linux.sysfs_path setting for rfcomm hal
device) - I presume, this will land into your system with Blueman 1.1
package.

Anyway, there is one more problem with Network-manager itself... now it
needs also udev attribute telling whether the modem is GSM or CDMA. To
workaround this I've created udev rule like this:

$cat /etc/udev/rules.d/33-rfcomm-nm.rules
ACTION=="move", DEVPATH=="*/rfcomm*", ENV{ID_NM_MODEM_GSM}="1"

It might be challenging to get rock solid rule, which will use the
already in Blueman selected correct modem type (GSM/CDMA) and based on
that set the appropriate udev ID_NM_..... The DEVPATH/address file
could be inspected to get the MAC of the device and then check which
type it should be set reading Blueman Config. Unfortunatelly I'm not
familiar with Python to prepare this patch...

The other way might be to patch the network manager itself to rely on
the hal modem properties when the udev ones are not set at all (and if
the modem is connected via rfcomm).

jac0b (jacbrooks) wrote :

Everything is working good with the svn (version 1.1) of blueman I didn't even add that rule from the above comment.

Eetu Huisman (eh) wrote :

Since there seems to be so much confusion and unanswered questions, I guess providing a direct link to a comment made on the upstream bug by one of the NM devs would be useful: http://bugzilla.gnome.org/show_bug.cgi?id=432774#c33.

Mikel Ward (mikelward) wrote :

Looks like it might be coming soon.
http://blogs.gnome.org/dcbw/category/networkmanager/

Fingers crossed!

Gavin Hamill (gdh) wrote :

Soon enough for Karmic?

Mikel Ward (mikelward) wrote :

Apparently Bluetooth personal area network support is included in GNOME 2.28 with GNOME Bluetooth and latest NetworkManager.

Stefan Nuxoll (snuxoll) wrote :

PAN support doesn't cover many bluetooth devices (like my N75) that use the Bluetooth DUN profile instead.

Eero (eero+launchpad) wrote :

https://wiki.ubuntu.com/KarmicKoala/HumanReleaseNotes#Bluetooth

Well, it does not work for me even though the release notes say so. There is no checkbox at the end of pairing my Nokia E71 as opposed to http://blogs.gnome.org/dcbw/files/2009/07/3-bt-pan.png

Gavin Hamill (gdh) wrote :

As per Stefan Nuxoll's comment, I don't believe the Nokia E71 supports the newer 'PAN' profile -only the old 'DUN' one - this will be why you are unable to use your E71 as an Internet access device through Network Manager

Jamie Lokier (jamie-shareable) wrote :

Stefan Nuxoll wrote:
> PAN support doesn't cover many bluetooth devices (like my N75) that use
> the Bluetooth DUN profile instead.

And even those which do support PAN, don't always create an internet
connection if the bluetooth paired network is already being used for
another purpose like local file sharing.

DUN might be a bit more reliable in that case, I'm not sure.

-- Jamie

Oded Arbel (oded-geek) wrote :

I did not manage to get the PAN checkbox at the end of the bluetooth pairing dialog for either of my Nokia E90 (which may not support it) or my Ericsson P1i (which does support PAN).

Its nice that NM support PAN (even though I wasn't able to confirm it), but to use it it should be possible to add PAN to an existing bluetooth pairing. And regardless, a lot of current phones that support bluetooth network connection do not work well or at all with PAN and we still want to use them.

Jamie Lokier (jamie-shareable) wrote :

Oded Arbel wrote:
> I did not manage to get the PAN checkbox at the end of the bluetooth
> pairing dialog for either of my Nokia E90 (which may not support it) or
> my Ericsson P1i (which does support PAN).

I used PAN with a Sony-Ericsson K850i without having to set anything
on the phone.

Just pair the phone and the computer, then after that, PAN worked
using "pand" from the computer. (There was some extra scripting
needed because of possible Bluez bugs, to enable HCI encryption first,
before PAN worked).

I used DUN with a Nokia 6210 Classic without having to set anything on
the phone.

Just pair the phone and the computer, then after that, with the right
settings on the computer, DUN (using RFCOMM) worked using "rfcomm" and
"pppd".

-- Jamie

Oded Arbel (oded-geek) wrote :

I'm not sure what you mean when you say "some extra scripting" and "with the right setting". Even if I connect my phone manually using rfcomm (with sudo), Network Manager has no way to setup a PPP connection, let alone one with all the extra initialization needed for a 3G dialup - this is a regression from 0.6 where it was possible to set up generic PPP connections that worked both with standard modems and with bluetooth phones if you bound them manually.

I got my phones to work with dial-up, using a 20 line script (with several "sudo") that does the rfcomm bind and starts gnome-ppp or wvdial with the correct configuration - I wouldn't call that simple, and it took me quite a while to get it right so I wouldn't call that easy to the point that the average Joe can do it.

I think the current situation where someone with no system administration or programming background CAN NOT get bluetooth based network access, far from ideal and is several years behind the competition - on another operating system I can get both my bluetooth phones to setup dial-up networking in minutes without any need for scripting or running obscure administrator only commands.

What I expect from Canonical and Network Manager developers, is to have "mobile broadband" connections start by attaching to a bluetooth device that supports DUN, instead of only using USB and PCMCIA connected modems.

Changed in network-manager:
status: Confirmed → Fix Released
Changed in network-manager:
importance: Unknown → Wishlist

Since this is closed upstream, closing as Fix Released.

As far as I can tell this would be available in Lucid and later releases.

Changed in network-manager (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.