0.7 Nokia E71 via USB not detected

Bug #257045 reported by Thomas Butter on 2008-08-11
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hal-info (Ubuntu)
Medium
Martin Pitt
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: network-manager

The Nokia E71 phone is not detected via USB if used in 3G Modem mode.

network-manager:
Version: 0.7~~svn20080720t224551+eni1-0ubuntu1~nm5~hardy1

$ lsusb -v -d 0421:00aa

Bus 002 Device 005: ID 0421:00aa Nokia Mobile Phones
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 64
  idVendor 0x0421 Nokia Mobile Phones
  idProduct 0x00aa
  bcdDevice 1.00
  iManufacturer 1 Nokia
  iProduct 2 Nokia E71
  iSerial 3 352924020321167
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 32
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 4 Bulk transfer method configuration
    bmAttributes 0xc0
      Self Powered
    MaxPower 20mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 2
      bInterfaceClass 8 Mass Storage
      bInterfaceSubClass 6 SCSI
      bInterfaceProtocol 80 Bulk (Zip)
      iInterface 6 USB Mass Storage Interface
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x84 EP 4 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x01 EP 1 OUT
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0040 1x 64 bytes
        bInterval 0
Device Status: 0x0001
  Self Powered

Alexander Sack (asac) wrote :

please attach lshal output (at best as a file ending with .txt)

Changed in network-manager:
status: New → Incomplete
Thomas Butter (tbutter) wrote :

lshal output is attached.

Thomas replied with lshal output, so changing status incomplete->confirmed.

Changed in network-manager:
status: Incomplete → Confirmed
Alexander Sack (asac) wrote :

I uploaded a fixed hal-info package to the network-manager PPA. I uploaded to hardy and intrepid.

NetworkManager PPA is: https://edge.launchpad.net/~network-manager/+archive

Please verify that it works out of box now.

Changed in hal-info:
importance: Undecided → Medium
status: New → Fix Committed
Changed in network-manager:
importance: Undecided → Medium
status: Confirmed → Triaged
Thomas Butter (tbutter) wrote :

Hi Alexander,

after upgrading to the hal-info and network manager from your ppa still nothing happens after plugging in the phone via usb. Configuring a GSM connection also does not work.

Alexander Sack (asac) wrote :

please post the output of lsusb

Thomas Butter (tbutter) wrote :

output of lsusb and lsusb -v is attached

Thomas Butter (tbutter) wrote :
Ruben Romero (huayra) wrote :

This is wrong. SImply because you have to choose PC Suite Instead of network connection when the usb canble gets connected to the phone.

the right address for the phone is:

Bus 001 Device 011: ID 0421:00ab Nokia Mobile Phones

(Note the ab instead of the aa). Changing this in the fdi file for hal gives you:

     <!-- Nokia E71 as a GPRS/EDGE modem (CDC ACM) -->
     <match <email address hidden>:usb.product_id" int="0xab">
       <match <email address hidden>:usb.interface.class" int="0x02">
         <match <email address hidden>:usb.interface.subclass" int="0x02">
           <append key="info.capabilities" type="strlist">modem</append>
           <append key="modem.command_sets" type="strlist">V.250</append>
           <append key="modem.command_sets" type="strlist">GSM-07.07</append>
           <append key="modem.command_sets" type="strlist">GSM-07.05</append>
         </match>
       </match>
     </match>

Voilá!

The device is recognized by nm-tool:

- Device: ttyACM1 ----------------------------------------------------------------
  Type: Mobile Broadband (GSM)
  Driver: cdc_acm
  State: disconnected
  Default: no

  Capabilities:
    Supported: yes

Can I get this one on 5-a-day? ;)

R.

Thomas Butter (tbutter) wrote :

Thanks Ruben, you are right.

Changing 0xaa -> 0xab works.

Hendy Irawan (ceefour) wrote :

Please inform update of this bug.

Thomas, does E71 eventually work with Ubuntu 8.04? If so, what tweaks needed to connect to E71's HSDPA using E71-Laptop USB? (i.e. using E71 as USB HSDPA modem)

I'm planning to buy an E71 this afternoon and highly concerned about this issue.

Thank you.

Thomas Butter (tbutter) wrote :

Hendy,

the E71 works on 8.04 using the package in the ppa mentioned above paired with the fix of Ruben above and the Nokia USB Cable.

It also works with bluetooth using some manual ppp configuration. Just mail me if you need help.

Hendy Irawan (ceefour) wrote :

Thanks Thomas! That does make my feeling very warm (both towards Nokia E71 *and* Ubuntu community! Thanks to Ruben and Alexander as well, obviously) :)

I'm also posting this solution to: http://ubuntuforums.org/showthread.php?p=5723469

since one asks if it's possible using E71's HSDPA with USB cable, over Bluetooth seemed to waste a lot of bandwidth. (for those lucky enough to get HSDPA speeds faster than Bluetooth, hix hix...)

Hendy Irawan (ceefour) wrote :

Anyway, will Ruben's fix incorporated in a PPA or future (8.04 update or Intrepid?) Ubuntu?

I'm not exactly sure what "fdi file for hal" stands for (although I'm very comforted knowing that somebody else is owning both Nokia E71 and Ubuntu --if Ubuntu is "ownable", that is).

Hendy Irawan (ceefour) wrote :

By the way, this is out-of-topic, but is it possible/workable to sync Evolution (or maybe Kontact) with E71?

Why I'm asking this is my previous PDAphone was Treo 750 (WM5) and it was quite OK with Evolution. Hoping that E71 interoperates well with Ubuntu.

Thank you.

Hendy Irawan (ceefour) wrote :

By the way this is probably cooler:

http://www.e71fanatics.com/2008/09/e71-freeware-joikuspot-light-turn-your.html

> Have you ever been away from home and wished that your PSP, iPod Touch, or Laptop had a internet connection but couldn't find a WLAN hotspot nearby? Why not tap into your Nokia E71's high speed 3g connection? Meed JoikuSpot Light.

> Nokia Conversations recently covered this creative and useful application. Here's what they said..

Probably better than using as "HSDPA modem" because now it effectively becomes a modem, a gateway, and an access point at once.

Thomas Butter (tbutter) wrote :

Hi Hendy,

please do not post off-topic messages in the bug.

You can find the FDI file here:
/usr/share/hal/fdi/information/10freedesktop/10-modem.fdi

Syncing evolution works with opensync, but has some problems (after a canceld sync some entries may appear twice).

Joikuspot is a cool application, but I doubt that it will achieve full HSDPA Speed.

Ruben Romero (huayra) wrote :

Nokia E71 is working flawlessly with the last branch in nm (I made the build today). It even recognizes the E71 as a device in the beginning of the assistant (mbca?).

Choosing the device does not give you the assistant though, so the APN and other settings have to be set manually.

This could be fixed, but is it a nm-applet issue or a mbca issue?

Anyway the E7 is detected and it works, so maybe we should close this bug?

Alexander Sack (asac) wrote :

are we sure that all E71 that match that fdi snippet are actually GSM modems?

If not, we have now code that should detect whether its GSM or CDMA through probing. Only requirement would be the v.250 command_sets.

Can someone test a reduced fdi. For that please use the fdi posted above and remove the lines:

           <append key="modem.command_sets" type="strlist">GSM-07.07</append>
           <append key="modem.command_sets" type="strlist">GSM-07.05</append>

Then please test with the latest network manager in PPA (http://launchpad.net/~network-manager/+archive).

If it works, please post the verified and reduced .fdi. Thanks.

Richard Harding (rharding) wrote :

I'm new to playing with this.

When I added the block to the fdi file, my phone would be detected, however I could not get it to connect with any of the three AT&T "settings" NM displayed when I added a new Mobile Broadband Connection.

When I removed the two command_sets lines as requested I get this error in syslog upon plugging in the phone:
usb 4-2: new full speed USB device using uhci_hcd and address 3
usb 4-2: configuration #1 chosen from 1 choice
cdc_acm 4-2:1.10: ttyACM0: USB ACM device
usb 4-2: bad CDC descriptors
usb 4-2: bad CDC descriptors
NetworkManager: <debug> [1222367685.559139] probe_modem(): Couldn't get caps

and the phone is not detected

I have a working wvdial.conf for this, but how are people getting NM to make the correct settings and dial?

On Thu, Sep 25, 2008 at 06:40:10PM -0000, Richard Harding wrote:
> I'm new to playing with this.
>
> When I added the block to the fdi file, my phone would be detected,
> however I could not get it to connect with any of the three AT&T
> "settings" NM displayed when I added a new Mobile Broadband Connection.
>
> When I removed the two command_sets lines as requested I get this error in syslog upon plugging in the phone:
> usb 4-2: new full speed USB device using uhci_hcd and address 3
> usb 4-2: configuration #1 chosen from 1 choice
> cdc_acm 4-2:1.10: ttyACM0: USB ACM device
> usb 4-2: bad CDC descriptors
> usb 4-2: bad CDC descriptors
> NetworkManager: <debug> [1222367685.559139] probe_modem(): Couldn't get caps
>
> and the phone is not detected
>
> I have a working wvdial.conf for this, but how are people getting NM to
> make the correct settings and dial?
>

maybe this has to do with the mode your phone is set in? are you using
"PC suite" ... or something? afaik, thats the wrong mode. try a
different mode.

 - Alexander

Richard Harding (rharding) wrote :

From the notes above, PC Suite is the mode that the phone should be put into.

Output during plugging in the phone via PC Suite with the two modem.command_sets params in the fdi file:

Sep 29 07:53:43 raken kernel: [62922.560094] usb 2-1: new full speed USB device using uhci_hcd and address 2
Sep 29 07:53:43 raken kernel: [62922.730262] usb 2-1: configuration #1 chosen from 1 choice
Sep 29 07:53:43 raken kernel: [62923.034671] cdc_acm 2-1:1.10: ttyACM0: USB ACM device
Sep 29 07:53:43 raken kernel: [62923.036964] usbcore: registered new interface driver cdc_acm
Sep 29 07:53:43 raken kernel: [62923.036994] cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters
Sep 29 07:53:43 raken kernel: [62923.083662] usbcore: registered new interface driver cdc_ether
Sep 29 07:53:43 raken kernel: [62923.090867] usb 2-1: bad CDC descriptors
Sep 29 07:53:43 raken kernel: [62923.090892] usbcore: registered new interface driver rndis_host
Sep 29 07:53:43 raken kernel: [62923.104892] usb 2-1: bad CDC descriptors
Sep 29 07:53:43 raken kernel: [62923.104918] usbcore: registered new interface driver rndis_wlan
Sep 29 07:53:44 raken NetworkManager: <debug> [1222689224.271502] probe_modem(): Couldn't get caps

Using the mass storage mode just maps my micro sd card and the "PC to Web" actually seems to have crashed NM.

The wvdial config I have is from here: http://i-nz.net/2008/09/18/nokia-e71-as-a-usb-or-bluetooth-3g-data-modem-on-linux/

The phone numbers that all of the AT&T settings want to use is different and the wvdial seems to have no concept of things like APN so I'm not sure how to map my working wvdial config to NM's dialing config.

Martin Pitt (pitti) on 2008-10-02
Changed in hal-info:
assignee: nobody → pitti
status: Fix Committed → In Progress
Martin Pitt (pitti) wrote :

hal fdi committed upstream.

Changed in hal-info:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hal-info - 20081001-0ubuntu1

---------------
hal-info (20081001-0ubuntu1) intrepid; urgency=low

  * New upstream snapshot with updated hardware data.
    - Add Lyra TH1100A music player. (LP: #213636)
    - Add Sony Walkman NWD-B105. (LP: #231470)
    - Add Samsung Q45 special keys. (LP: #212790)
  * Grabbed a bunch of Nokia/LG mobile modem FDIs contributed in Launchpad,
    cleaned them up, committed them upstream, add them as
    debian/patches/00upstream_mobile_modems.patch for now.
    (LP: #257045, #257725, #258197, #259041, #268482, #274952)
  * Drop 03_latitude_xt_tablet_keys.patch, upstream now.

 -- Martin Pitt <email address hidden> Thu, 02 Oct 2008 20:27:57 +0200

Changed in hal-info:
status: Fix Committed → Fix Released
Alexander Sack (asac) wrote :

not a NM issue.

Changed in network-manager:
status: Triaged → Invalid
Hendy Irawan (ceefour) wrote :

I'm using Ubuntu Hardy 8.04 with the latest network-manager PPA packages and now it works very well with my Nokia E71 connected via USB.

:-)

Major props and thanks!!!

I'm soon upgrading to Intrepid Ibex, I hope the latest updates have been integrated with it...

This seems to have resurfaced in Lucid. When I connect my E71 (Bus 005 Device 020: ID 0421:00ab Nokia Mobile Phones E71 (PC Suite mode)) or (0421:00aa, mass storage mode). NM will not recognize it.

If I modprobe cdc_acm module, then NM recognizes and uses the 3G connection. This works across suspends/hibernates, but not reboots (obviously).

It seems hal-info is dead now, but I don't know which package this should be reported against.

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers