[SRU] network-manager 1.2.0

Bug #1576726 reported by Aron Xu on 2016-04-29
220
This bug affects 84 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
High
Aron Xu
Xenial
High
Aron Xu
network-manager-applet (Ubuntu)
High
Aron Xu
Xenial
High
Unassigned
network-manager-openconnect (Debian)
Fix Released
Unknown
network-manager-openconnect (Ubuntu)
High
Unassigned
Xenial
High
Aron Xu
network-manager-openvpn (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
network-manager-pptp (Ubuntu)
High
Unassigned
network-manager-ssh (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
network-manager-vpnc (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

[Impact]
Xenial was released with upstream beta2 version of network-manager to keep in time for the release schedule, and upstream stable release has been made so it's time to update to it.

[Testcase]
After upgrading the package, user should still be able to connect to networks like Ethernet, Wi-Fi and VPNs.

[Regression Potential]
Potential of causing regression is relatively small because there is not big changes made during beta2 -> stable process.

Aron Xu (happyaron) on 2016-04-29
description: updated
Changed in network-manager (Ubuntu):
importance: Undecided → High
Changed in network-manager (Ubuntu Xenial):
importance: Undecided → High
Changed in network-manager-applet (Ubuntu):
importance: Undecided → High
Changed in network-manager-applet (Ubuntu Xenial):
importance: Undecided → High
Changed in network-manager (Ubuntu Xenial):
status: New → In Progress
assignee: nobody → Aron Xu (happyaron)
Changed in network-manager (Ubuntu):
status: New → Fix Committed
assignee: nobody → Aron Xu (happyaron)
Changed in network-manager-applet (Ubuntu):
assignee: nobody → Aron Xu (happyaron)
Aron Xu (happyaron) on 2016-04-29
Changed in network-manager-openconnect (Ubuntu):
status: New → Fix Released
Changed in network-manager-openconnect (Ubuntu Xenial):
importance: Undecided → High
assignee: nobody → Aron Xu (happyaron)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.2.0-0ubuntu1

---------------
network-manager-applet (1.2.0-0ubuntu1) yakkety; urgency=medium

  * Rebase to upstream stable release (lp: #1576726)

 -- Aron Xu <email address hidden> Fri, 29 Apr 2016 22:53:10 +0800

Changed in network-manager-applet (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu Xenial):
status: New → Confirmed
Changed in network-manager-openconnect (Ubuntu Xenial):
status: New → Confirmed

Hello Aron, or anyone else affected,

Accepted network-manager into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.2.0-0ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in network-manager-applet (Ubuntu Xenial):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Hello Aron, or anyone else affected,

Accepted network-manager-applet into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/1.2.0-0ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager-openconnect (Ubuntu):
importance: Undecided → High

After install network-manager on Ubuntu 16.04 everything is working correctly for me:

$ apt-cache policy network-manager
network-manager:
  Zainstalowana: 1.2.0-0ubuntu0.16.04.1
  Kandydująca: 1.2.0-0ubuntu0.16.04.1
  Tabela wersji:
 *** 1.2.0-0ubuntu0.16.04.1 100
        100 /var/lib/dpkg/status
     1.1.93-0ubuntu4 500
        500 http://pl.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

tags: added: verification-done
removed: verification-needed
Jason Gerard DeRose (jderose) wrote :

With this proposed package, System76 is seeing network-manager crash upon the first resume from suspend. Anyone else experiencing this?

I'll be looking into this more today.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.2.0-0ubuntu1

---------------
network-manager (1.2.0-0ubuntu1) yakkety; urgency=medium

  * Rebase to upstream stable release. (lp: #1576726)

 -- Aron Xu <email address hidden> Fri, 29 Apr 2016 20:41:19 +0800

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

@jderose, there was no other report of that no and no such issues from my local testing, could you get a debug stacktrace of the default? (or a reference to an e.u.c entry)

Jason Gerard DeRose (jderose) wrote :

@seb128... I'll try to get some better debug info soon. Interestingly, it only seem to happen with Intel 7260 WiFi cards (and not, for example, with Intel 8260 WiFi cards).

So I'm not sure whether what we're seeing is actually a problem with network-manager. I'm now kinda thinking it's more likely a kernel issue, especially as other's haven't seen this problem.

Thanks!

Aron Xu (happyaron) on 2016-05-09
Changed in network-manager-openconnect (Ubuntu Xenial):
status: Confirmed → In Progress
Aron Xu (happyaron) on 2016-05-09
Changed in network-manager-openconnect (Ubuntu Xenial):
status: In Progress → New
Joakim Koed (vooze) wrote :

Hey.

I just upgraded to this package, but this bug is this present. Can you please take a look. https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1574020

Amr Ibrahim (amribrahim1987) wrote :

Why are the packages not merged with Debian, instead, they are packaged separately (1.2.0-0ubuntu1 in yakkety)? Merging reducing delta, I suppose!

Aron Xu (happyaron) wrote :

@jderose, is there any update? can't reproduce your problem here...

@joakimkoed, Bug #1574020 could be another issue which isn't addressed in this SRU (but haven't reproduced that yet).

@amribrahim1987, delta is still not a lot since last merge (1.1.93-0ubuntu1), we do merges when delta accumulates but might not do that every time because it will lead to quite some work load. Since this update is also intended for Xenial SRU, minimal changes are expected.

Joakim Koed (vooze) wrote :

@happyaron: Regarding @jderose's problem. I think I have that too. What happens is after resume network manager "turns off" at least it says its disconnected, and then "wakes up" with a ethernet-logo, and I can't see any networks. Internet/network still works, but unable to change(or even see) SSIDs / WiFi networks..
I did fix it with a script to restart network-manager on each resume.. But that problem is still in this version.

About my other bug report. Could you possible test it? Just logout, and press on any wifi and see if that works?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.2.0-0ubuntu0.16.04.1

---------------
network-manager-applet (1.2.0-0ubuntu0.16.04.1) xenial; urgency=medium

  * Rebase to upstream stable release (lp: #1576726)

 -- Aron Xu <email address hidden> Fri, 29 Apr 2016 22:53:10 +0800

Changed in network-manager-applet (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for network-manager-applet has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

The network-manager 1.2 package seems to cause different symbol exposure in networkmanager-qt which caused the broken 15.08.0-0ubuntu1.2 package in bug #1569674
I'm still investigation where that exactly comes from, but building networkmanager-qt against xenial-release works fine.

Aron Xu (happyaron) wrote :

@yofel, I see that you've uploaded a version of networkmanager-qt for xenial SRU, should that fix your problem?

Philip Muškovac (yofel) wrote :

@Aron: No, it doesn't. But now I found out that it's not NM's fault but caused by a strict "1.2.0" version check in nmqt which is supposed to remove some API for 1.2, but ofc. didn't catch 1.1.93. I'm talking to upstream how to resolve that, but this bug can proceed fine.

Brian Murray (brian-murray) wrote :

Bug 1581371 seems to be a regression caused by this SRU. Please investigate the matter before releasing this update.

tags: added: verification-failed
removed: verification-done
Aron Xu (happyaron) wrote :

The problem of Bug #1581371 lies in networkmanager-qt, for which kubuntu people is trying to handle their symbol mismatch problem.

Amr Ibrahim (amribrahim1987) wrote :

Bug 1581371 is not a regression according to comment #19.

tags: added: verification-done
removed: verification-failed
summary: - [SRU]network-manager
+ [SRU] network-manager 1.2.0
tags: added: verification-needed
removed: verification-done
Martin Pitt (pitti) wrote :

The n-m-openconnect SRU drops the versioned NM dependency:

 Depends: adduser,
- network-manager (>= 0.9.4.0-4),

This doesn't look right. The yakkety package now does not depend on NM at all any more, and the version was probably on purpose. The changelog says "Drop unnecessary dependency on network-manager (>= 0.9.4.0-4)" which does not explain anything -- I can see that, but the changelog should give a rationale.

Changed in network-manager-openconnect (Debian):
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

could somebody confirm that the kde regression is fixed with the current proposed versions?

Jan Henke (jhe) wrote :

With the updated NetworkManager in Xenial it is no longer possible to create or edit openconnect VPN connections. Openconnect needs an update to work with this version of NetworkManager, see also http://tomtomtom.org/networkmanager-openconnect/

Aron Xu (happyaron) on 2016-05-27
no longer affects: network-manager-strongswan (Ubuntu)
no longer affects: network-manager-strongswan (Ubuntu Xenial)
Aron Xu (happyaron) on 2016-05-27
Changed in network-manager-vpnc (Ubuntu):
status: New → Fix Released
Aron Xu (happyaron) on 2016-05-27
Changed in network-manager-ssh (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-openconnect (Ubuntu Xenial):
status: New → Confirmed
Changed in network-manager-openvpn (Ubuntu Xenial):
status: New → Confirmed
Changed in network-manager-openvpn (Ubuntu):
status: New → Confirmed
Changed in network-manager-ssh (Ubuntu Xenial):
status: New → Confirmed
Changed in network-manager-vpnc (Ubuntu Xenial):
status: New → Confirmed
Schmirrwurst (schmirrwurst) wrote :

Are there any working workarounds there until it is fixed ?
I've 1.2.0-0ubuntu0.16.04.2 from proposed, as described above, but still cannot connect to my anyconnect vpn, I need a workaround...

Aron Xu (happyaron) wrote :

@schmirrwurst, have you installed the package network-manager-vpnc-gnome? This is needed to have the vpnc plugin show up in available VPN protocol list and being functional.

Martin Pitt (pitti) wrote :

@Jjan: "With the updated NetworkManager in Xenial it is no longer possible to create or edit openconnect VPN connections."

 → Do you mean the -proposed package introduces this regression, or the current Xenial package already has that?

Seydon (seydon) wrote :

@MartinPitt

This was the original behavior of Xenial. See https://bugs.launchpad.net/ubuntu/+source/network-manager-openconnect/+bug/1571300 for more info (this bug number was referenced in that one as well).

Martin Pitt (pitti) wrote :

Copied 1.2.0-0ubuntu0.16.04.2 to xenial-updates, so the update is released.

Changed in network-manager (Ubuntu Xenial):
status: Fix Committed → Fix Released
Ben Whitten (benwhitten) wrote :

Is there a plan to backport network-manager-openconnect and network-manager-openconnect-gnome 1.2 or later into Xenial to match the network-manager upgrade?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-pptp (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

The nm-openconnect update is tracked in bug 1297849.

Changed in network-manager-openconnect (Ubuntu Xenial):
status: Confirmed → Invalid
Changed in network-manager-ssh (Ubuntu Xenial):
status: Confirmed → Fix Committed

Hello Aron, or anyone else affected,

Accepted network-manager-ssh into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-ssh/1.2.0-0ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Aron Xu (happyaron) wrote :

Works for me, marking as verification-done.

tags: added: verification-done
removed: verification-needed
Changed in network-manager-openvpn (Ubuntu):
importance: Undecided → High
Changed in network-manager-openvpn (Ubuntu Xenial):
importance: Undecided → High
Changed in network-manager-ssh (Ubuntu):
importance: Undecided → High
Changed in network-manager-ssh (Ubuntu Xenial):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-ssh - 1.2.0-0ubuntu0.16.04.1

---------------
network-manager-ssh (1.2.0-0ubuntu0.16.04.1) xenial; urgency=medium

  * SRU to 1.2.0 release to match nm update (LP: #1576726)

 -- Aron Xu <email address hidden> Fri, 27 May 2016 18:37:39 +0800

Changed in network-manager-ssh (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in network-manager-openconnect (Ubuntu Xenial):
status: Invalid → Fix Released
Mathew Hodson (mathew-hodson) wrote :

network-manager-pptp (1.2.0-1) unstable; urgency=medium

  * New upstream release.

 -- Michael Biebl <email address hidden> Sat, 23 Apr 2016 00:44:17 +0200

tags: added: upgrade-software-version
no longer affects: freeplane (Ubuntu)
Changed in network-manager-pptp (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
Amr Ibrahim (amribrahim1987) wrote :

network-manager-vpnc, network-manager-pptp & network-manager-openvpn are still left behind in Xenial.

Changed in network-manager-vpnc (Ubuntu):
importance: Undecided → High
Changed in network-manager-vpnc (Ubuntu Xenial):
importance: Undecided → High
Jeremy Bicha (jbicha) wrote :

Ubuntu 16.10 has network-manager-openvpn 1.2.6-2ubuntu1

Changed in network-manager-openvpn (Ubuntu):
status: Confirmed → Fix Released
no longer affects: network-manager-pptp (Ubuntu)
Changed in network-manager-pptp (Ubuntu):
importance: Undecided → High
status: New → Fix Released
Theresa (theresa) wrote :

Don't know if this is the right place, but I'm on Xenial and I'm struggeling to connect with Network-Manager to an IPsec VPN tunnel through the strongswan plugin.

I have installed the following versions:

network-manager 1.2.2-0ubuntu0.16.04.3
network-manager-gnome 1.2.0-0ubuntu0.16.04.4
network-manager-openvpn 1.1.93-1ubuntu1
network-manager-pptp 1.1.93-1ubuntu1
network-manager-pptp-gnome 1.1.93-1ubuntu1
network-manager-strongswan 1.3.1-1ubuntu1

as well as:
libstrongswan 5.3.5-1ubuntu3
libstrongswan-standard-plugins 5.3.5-1ubuntu3

I get prompted for the password (EAP) although I have configured it in the Network-Manager editor already. Syslog only says this:

Dec 28 17:35:10 herex NetworkManager[942]: <info> [1482942910.9457] vpn-connection[0x1e9c3d0,8d0c94c6-bbf1-4cfb-8bd6-668b930537a8,"vpn",0]: Saw the service appear; activating connection
Dec 28 17:35:17 herex NetworkManager[942]: <error> [1482942917.2729] vpn-connection[0x1e9c3d0,8d0c94c6-bbf1-4cfb-8bd6-668b930537a8,"vpn",0]: final secrets request failed to provide sufficient secrets

Is there any other way to troubleshoot this? Is someone else experiencing this problem?
Again I'm on Ubuntu 16.04.1 LTS

I'd appreciate any help on this!

thanks,
theresa

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.