Gusty not shutting down (Deactivating device eth1)

Bug #156490 reported by zeddock on 2007-10-24
20
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

As Gusty is shutting down I see the DOS lines of information going by until it gets to something like:
Deactivating device eth1

It just sits there. This is happening every time.

What other information can I give that would help?

zeddock

zeddock (zeddock) wrote :

Fresh 7.10 release installed with a bcm4309 wireless card in a Dell D800.

zeddock

Stephen Gornick (sgornick) wrote :

I get about the same thing.

After clicking Shut Down, a few seconds pass, then this is displayed on the console:

NetworkManager: <info> Caught termination signal

NetworkManager: <debug> [1193029284.958940] nm_print_open_socks(): Open Sockets List

NetworkManager: <debug> [1193029284.959004] nm_print_open_socks(): Open Sockets List Done

NetworkManager: <info> Deactivating device eth0

NetworkManager: <info> Deactivating device eth1

Then nothing. I've waited as long as 10 minutes, with no additional message. The only way to proceed from there is to power off (hold power button for 5 seconds).

This is on my HP Pavilion ZX5000 ( zx5078cl ) which has a Broadcom 43xx.

02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
        Subsystem: Hewlett-Packard Company NX9500 Built-in Wireless
        Flags: bus master, fast devsel, latency 64, IRQ 19
        Memory at e8204000 (32-bit, non-prefetchable) [size=8K]

02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
        Subsystem: Hewlett-Packard Company Unknown device 006b
        Flags: bus master, medium devsel, latency 128, IRQ 18
        I/O ports at a000 [size=256]
        Memory at e8208800 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>

Clean install Ubuntu Gutsy i386 7.10 release.

I've seen other bug reports listing shutdown issues (Bug #138691 [gutsy], 137663 [feisty], 121658 [feisty] ) but I cannot tell if any are related to this issue.

Stephen Gornick (sgornick) wrote :
Stephen Gornick (sgornick) wrote :

I have waited 12+ hours... just sits there.
On some occasions though, it shuts down without issue. Perhaps when I turn
off my wireless?

zeddock

On 10/25/07, Stephen Gornick <email address hidden> wrote:
>
>
> ** Attachment added: "daemon.log"
> http://launchpadlibrarian.net/10170708/daemon.log.txt
>
> --
> Gusty not shutting down (Deactivating device eth1)
> https://bugs.launchpad.net/bugs/156490
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Huri (huri) wrote :

I have very similar messages from Network Manager, as do a bunch of people on the forums:

http://ubuntuforums.org/showthread.php?t=584652

In this particular case I'm not using a wireless card, I'm on a wired network using the pcnet32 driver.

00:11.0 Ethernet controller: Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE] (rev 10)

This is actually a VM running in VMware Server 1.0.4

I have not had this problem on two other (real) machines.

Yeah, I have waited 12+ hours as well and it just sits there. There are many more users experiencing the same problem:

http://ubuntuforums.org/showthread.php?p=3637351

This is becoming pretty major and very widespread.

sirianni (eric-sirianni) wrote :

Same problem here.

Using "BCM4306 802.11 b/g Wireless LAN Controller"

This is a major pain point.

TimMadden (timmadden) wrote :

I am having similar problems with shutdown. I have a toshiba system (a135). The message is not always the same though and does not happen everytime I shut down.

Screenshots from my mobile attached. Let me know if you need more info.

Loïc Dardant (loic-dardant) wrote :

Same problem on a Imac with Gutsy.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in network-manager.

Brian Murray (brian-murray) wrote :

Reviewing this bug report and its comments it seems that multiple people are experiencing this problem. Subsequently, I am confirming this bug report. For future reference you can manage the status of bug reports by clicking on the current status in the yellow line and then choosing a new status in the drop down box. You can learn more about bug statuses at http://wiki.ubuntu.com/Bugs/Status .

Changed in network-manager:
importance: Undecided → Medium
status: New → Confirmed
Martin Fuzzey (mfuzzey) wrote :

I have a work around and the beginning of an analysis at bug https://bugs.launchpad.net/bugs/183568
I've also marked that bug as a duplicate of this one (since its confirmed)

Leszek (bigl-aff) wrote :

I had no such problem with Gutsy but now I've migrated to Hardy RC and it appeared. But I've found simple woraround which works for me - I swich my wired connection from roaming mode to DHCP. With such configuration I've no delays on shutdown/reboot. Maybe it helps to nail down the problem.

Alexander Sack (asac) wrote :

in intrepid we dont stop NM during shutdown. If you need a reliably network during shutdown you are supposed to use system-settings/connections in network-manager 0.7 (intrepid).

Changed in network-manager:
status: Confirmed → Fix Released

I have since switched to Hardy Heron, and the problem disappeared. Please
remove my email address from this distribution list.

Thank you.

2008/10/28 Alexander Sack <email address hidden>

> in intrepid we dont stop NM during shutdown. If you need a reliably
> network during shutdown you are supposed to use system-
> settings/connections in network-manager 0.7 (intrepid).
>
> ** Changed in: network-manager (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> Gusty not shutting down (Deactivating device eth1)
> https://bugs.launchpad.net/bugs/156490
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
-----------------------------------------------------------------------------------------------------------------------------

All that is necessary for evil to triumph is for good men to do nothing. --
Edmund Burke
A nation of sheep will beget a government of wolves. -- Edward R. Murrow

http://youtube.com/ItsTime4ARevolution - JOIN THE REVOLUTION!!!

(If you feel the content of this email was educational, please pass it on to
someone!)

http://www.MartelloSolutions.ws - Manifesting Dreams One Goal at a Time

ελληνικά - <email address hidden>
español - <email address hidden> / <email address hidden>
italiano - <email address hidden>
日本語 - <email address hidden>

Alexander Sack (asac) wrote :

this bug is closed. not much traffic will get through here anymore. if you dont want any mail anymore you need to unsubscribe from here on your own.

Lhorz (hilarionl) wrote :

OK. I've unsubscribed myself. Thanks for the heads up.

On Thu, Dec 4, 2008 at 2:42 AM, Alexander Sack <email address hidden> wrote:
> this bug is closed. not much traffic will get through here anymore. if
> you dont want any mail anymore you need to unsubscribe from here on your
> own.
>
> --
> Gusty not shutting down (Deactivating device eth1)
> https://bugs.launchpad.net/bugs/156490
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers