Comment 10 for bug 1408963

Gone back to 14.04 due multiple reasons, as Helio wrote: same here:

 uname -a
Linux sitronen-T500 3.13.0-45-generic #74-Ubuntu SMP Tue Jan 13 19:36:28 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

dmesg | frep wlan[ 10.789417] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 10.789706] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 25.134956] wlan0: authenticate with 08:96:d7:9d:f6:a1
[ 25.140117] wlan0: send auth to 08:96:d7:9d:f6:a1 (try 1/3)
[ 25.344117] wlan0: send auth to 08:96:d7:9d:f6:a1 (try 2/3)
[ 25.548054] wlan0: send auth to 08:96:d7:9d:f6:a1 (try 3/3)
[ 25.752042] wlan0: authentication with 08:96:d7:9d:f6:a1 timed out
[ 25.788271] wlan0: authenticate with 08:96:d7:9d:f6:a1
[ 25.788350] wlan0: direct probe to 08:96:d7:9d:f6:a1 (try 1/3)
[ 25.992035] wlan0: direct probe to 08:96:d7:9d:f6:a1 (try 2/3)
[ 26.196113] wlan0: send auth to 08:96:d7:9d:f6:a1 (try 3/3)
[ 26.206550] wlan0: authenticated
[ 26.208048] wlan0: associate with 08:96:d7:9d:f6:a1 (try 1/3)
[ 26.233139] wlan0: RX AssocResp from 08:96:d7:9d:f6:a1 (capab=0x431 status=0 aid=11)
[ 26.242102] wlan0: associated
[ 26.242180] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 30.274822] wlan0: disassociated from 08:96:d7:9d:f6:a1 (Reason: 2)
[ 30.328236] wlan0: deauthenticating from 08:96:d7:9d:f6:a1 by local choice (reason=3)
[ 72.204524] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3035.874583] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3042.166018] wlan0: authenticate with 08:96:d7:9d:f6:a1
[ 3042.176186] wlan0: send auth to 08:96:d7:9d:f6:a1 (try 1/3)
[ 3042.181177] wlan0: authenticated
[ 3042.184129] wlan0: associate with 08:96:d7:9d:f6:a1 (try 1/3)
[ 3042.207339] wlan0: RX AssocResp from 08:96:d7:9d:f6:a1 (capab=0x431 status=0 aid=12)
[ 3042.209730] wlan0: associated
[ 3042.209761] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 3042.229302] wlan0: deauthenticating from 08:96:d7:9d:f6:a1 by local choice (reason=2)
[ 3042.278931] wlan0: authenticate with 08:96:d7:9d:f6:a1
[ 3042.279005] wlan0: send auth to 08:96:d7:9d:f6:a1 (try 1/3)
[ 3042.285993] wlan0: authenticated
[ 3042.288104] wlan0: associate with 08:96:d7:9d:f6:a1 (try 1/3)
[ 3042.308969] wlan0: RX AssocResp from 08:96:d7:9d:f6:a1 (capab=0x431 status=0 aid=12)
[ 3042.310585] wlan0: associated
[ 3074.316071] ieee80211 phy0: wlan0: No probe response from AP 08:96:d7:9d:f6:a1 after 500ms, disconnecting.
[ 3077.546352] wlan0: authenticate with 08:96:d7:9d:f6:a1
[ 3077.552140] wlan0: send auth to 08:96:d7:9d:f6:a1 (try 1/3)
[ 3077.571165] wlan0: authenticated
[ 3077.572104] wlan0: associate with 08:96:d7:9d:f6:a1 (try 1/3)
[ 3077.762850] wlan0: RX AssocResp from 08:96:d7:9d:f6:a1 (capab=0x431 status=0 aid=12)
[ 3077.781197] wlan0: associated