[precise] network manager set incorrect /64 prefix from dhcpv6 client

Bug #1254028 reported by Pali on 2013-11-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
network-manager (Debian)
Fix Released
Unknown
network-manager (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]

 * dhcpv6 sets an incorrect netmask on ipv6 networks, leading to probable communication failures in certain networks

[Test Case]

 * You need an ipv6 network using dhcpv6 statefull configuration with prefix which is not equal to /64

[Regression Potential]

 * None, this patch has been accepted upstream and is available since quantal

network-manager in ubuntu precise use incorrect /64 prefix from dhcpv6 client which cause that internet connection not working on some ipv6 networks. this problem was fixed in upstream network-manager version 0.9.6 which is already available in ubuntu quantal and newer - but not in ubuntu precise. because this is critical problem (non working network/internet) new version of network manager (e.g 0.9.6) or at least patch which fixing this problem should be included in ubuntu precise which is LTS.

upstream commit which fixing this problem:
http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=eb460b70dad82d366d35fa5703c0e79a1389e4d1

more info about it:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=661885
http://bugzilla.gnome.org/show_bug.cgi?id=656610

This is the patch against the 0.9.4.0-0ubuntu4.4 version

I prepared the patch.

I pushed the updated package in my ppa [1]

can you please test it?

thanks

[1] https://launchpad.net/~costamagnagianfranco/+archive/firefox

Pali (pali) wrote :

I tested network-manager from your PPA on precise it it working correctly.

Changed in network-manager (Debian):
status: Unknown → Confirmed
Changed in network-manager:
importance: Unknown → Medium
status: Unknown → Fix Released
Pali (pali) wrote :

@LocutusOfBorg: can you include this patch to precise-proposed or precise-updates repository?

I have no upload privileges at this moment, you need to find a sponsor

Pali (pali) wrote :

who can do that?

ask on ubuntu devel mail list!

Robie Basak (racb) wrote :

Quick process review (I've not looked at the contents of the patch itself).

The patch looks good (it's an appropriate debdiff, etc), except please add dep3 headers (http://dep.debian.net/deps/dep3/) for links to bugs, commits and status if you can.

For a fix to Precise, please see follow https://wiki.ubuntu.com/StableReleaseUpdates#Procedure. In particular, Trusty needs to be fixed first, and the description needs updating with an SRU justification.

Once done, subscribe ~ubuntu-sponsors to the bug, and it'll enter the sponsorship queue. You can see progress there at http://reports.qa.ubuntu.com/reports/sponsoring/index.html

Hope that helps.

Pali (pali) wrote :

@Robie Basak: See description. Patch is already part of upstream 0.9.6 version of network-manager which is in quantal and new ubuntu versions (so it is in trusty too).

description: updated
Pali (pali) on 2014-01-09
description: updated
Marc Deslauriers (mdeslaur) wrote :

The updated debdiff looks good. Unfortunately, there is already a package in precise-proposed to fix 1186273, so I can't upload this right away.

Changed in network-manager (Ubuntu Precise):
status: New → Confirmed
Changed in network-manager (Ubuntu Quantal):
status: New → Fix Released
Changed in network-manager (Ubuntu Raring):
status: New → Fix Released
Changed in network-manager (Ubuntu Saucy):
status: New → Fix Released
Changed in network-manager (Ubuntu Trusty):
status: New → Fix Released

Yes Marc, the package anyway is still in proposed for a really improbable spotted regression.
I think the package should go on updates, the regression in bug https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1255592 is not related to the proposed package.

Pali (pali) wrote :

Any news about fixing this bug in precise?

Jackson Doak (noskcaj) wrote :

0.9.6.0-0ubuntu7.1 has been -proposed for precise for three months. Can we upload this yet?

I think yes.

Adam Conrad (adconrad) wrote :

0.9.4.0-0ubuntu4.4 has been removed from precise-proposed. Feel free to upload for this bug instead, though *not* including the changes from 4.4, unless you're prepared to verify that SRU along with this one.

this is the updated debdiff against 4.3

Brian Murray (brian-murray) wrote :

Somebody uploaded this but forget to unsubscribe sponsors.

Changed in network-manager (Ubuntu Precise):
status: Confirmed → In Progress

Hi Brian, sorry but I cannot see the upload anywhere in proposed or updates... Do you have a link for it?
thanks

Sorry brian for subscribing sponsors again.

Hello Pali, or anyone else affected,

Accepted network-manager into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/network-manager/0.9.4.0-0ubuntu4.4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Pali (pali) wrote :

Hello Brian. I cannot test new version of NM, because I do not have precise box now. But I already tested version from comment #3 and it worked fine and this problem was fixed in that version.

Is it impossible to test this in a dedicated environment... Such as a VM?
(just asking, maybe it is feasible and worth a try)

Pali (pali) wrote :

Now I do not have machine for testing...

But of course it is possible to test in VM too and it should be easy. Just create tun/tap interface for connection between VM and host. On host side start dnsmasq (which has support for RA & DHCPv6) and configure some non /64 prefix (e.g fd00::/100) [1]. And then check if NetworkManager in VM set correct /100 route (ip -6 route) and not some /64. Thats all.

[1] - example dnsmasq configuration (do not know if work, I just write what I remember):
$ dnsmasq --enable-ra --dhcp-range=fd00::2,fd00::10,100,12h --interface=tun0 --except-interface=lo --listen-address=fd00::1 --bind-interfaces
(host must have tun0 interface with ipv6 address fd00::1)

Hi Pali, unfortunately lacks of support of VT-x in my pc gives me many troubles in running VMs... Do you have a chance of testing it?

thanks

Pali (pali) wrote :

Now I tested NetworkManager (from precise-proposed) with dhcpv6 support against dnsmasq on localhost. It work correctly. Months ago I tested also version from comment #3 on real dhcpv6 netowork and it worked fine too.

So I think this problem is fixed in precise-proposed.

tags: added: verification-done
removed: verification-needed

wonderful! Thanks a ton!

Pali (pali) wrote :

Tested also on real DHCPv6 network and network-manager from precise-proposed working fine.

Can you promote new version to precise-updates now?

The verification of the Stable Release Update for network-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.4.0-0ubuntu4.4.1

---------------
network-manager (0.9.4.0-0ubuntu4.4.1) precise; urgency=low

  * debian/patches/fix-incorrect-ipv6-netmask.patch (LP: #1254028)
 -- Gianfranco Costamagna <email address hidden> Mon, 10 Feb 2014 21:20:15 +0100

Changed in network-manager (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in network-manager (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.