IPv6 "Automatic, only DHCP" configuration results in no default route

Bug #1255592 reported by AZ on 2013-11-27
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

The local network uses SLAAC configuration (with the OtherConfig-Bit in the RA set) as default configuration for devices. Some devices however should use a different IPv6 address assigned by statefull dhcp. Obviously, the ManagedConfiguration bit in the RA is not set, as this would break the SLAAC clients. When choosing "Automatic, only DHCP" for IPv6 configuration in the network manager (which translates into method=dhcp or NM_SETTING_IP6_CONFIG_METHOD_DHCP), the IPv6 address and the IPv6 DNS Servers are successfully assigned, but there is no ipv6 default route.

This is because NM_SETTING_IP6_CONFIG_METHOD_DHCP reconfigures sysctl to drop all RAs (accept_ra=0), but DHCPv6 still has no option to set the gateway IPv6 address (neither its link-local or globally valid address). So I currently cannot have only some clients use statefull DHCPv6, which is what I want.

Solution:
either

a) add an option to set sysctl accept_ra=1, autoconf=0 ; so the client will not use a SLAAC address but still add a default route based on RA

or

b) add a gateway option to DHCPv6.

This bug is to change network manager so the solution a) gets implemented, as this can be implemented in NetworkManager. Solution b) would need to be implemented in isc-dhcp-client and might need an updated RFC, but would allow for different use cases (i.e. http://www.ietf.org/mail-archive/web/ipv6/current/msg08684.html).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: network-manager 0.9.4.0-0ubuntu4.4
ProcVersionSignature: Ubuntu 3.2.0-56.86-generic 3.2.51
Uname: Linux 3.2.0-56-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Date: Wed Nov 27 17:25:05 2013
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
IpRoute:
 default via 141.24.40.126 dev eth0 proto static
 141.24.40.64/26 dev eth0 proto kernel scope link src 141.24.40.77 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MarkForUpload: True
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
RfKill:

SourcePackage: network-manager
UpgradeStatus: Upgraded to precise on 2012-09-19 (434 days ago)
nmcli-con:
 NAME UUID TYPE TIMESTAMP TIMESTAMP-REAL AUTOCONNECT READONLY DBUS-PATH
 Kabelnetzwerkverbindung 1 a32a6fb7-ed99-432f-acc8-c97cc3834e76 802-3-ethernet 1385569506 Mi 27 Nov 2013 17:25:06 CET yes no /org/freedesktop/NetworkManager/Settings/1
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 eth0 802-3-ethernet connected /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.4.0 connected enabled enabled enabled enabled disabled

AZ (m-dev) wrote :
description: updated

Hi AZ, does your bug happen also without network manager from proposed?

We need to know if this is a regression between 0.9.4.0-0ubuntu4.3 and 0.9.4.0-0ubuntu4.4.

Can you please try network manager from updates?

thanks

Hi AZ (Michael?), please can you reply on this bug?

tags: added: bot-stop-nagging
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed

Setting as Triaged, Wishlist. This is development work that would need to happen in NetworkManager upstream.

Changed in network-manager (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers