PPTP VPN Service failed to start after upgrade to 13.04

Bug #1175897 reported by Mino on 2013-05-03
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Hi!
I just upgrade ubuntu to 13.04 (from 12.10) and the VPN PPTP stop working with the message:

The VPN Connection 'VPN Connection 1' failed because the VPN service failed to start

I uninstall and reinstall all network-pptp package.
I deleted the keyrin in .gnome2/keyrings/

The syslog:

Code:
May 2 17:09:26 xxxxxxxxxxx NetworkManager[14753]: <info> Starting VPN service 'pptp'...
May 2 17:09:26 xxxxxxxxxxx NetworkManager[14753]: <info> VPN service 'pptp' started (org.freedesktop.NetworkManager.pptp), PID 17282
May 2 17:09:26 xxxxxxxxxxx NetworkManager[14753]: <info> VPN service 'pptp' appeared; activating connections
May 2 17:09:26 xxxxxxxxxxx NetworkManager[14753]: <info> VPN plugin state changed: init (1)
May 2 17:09:26 xxxxxxxxxxx NetworkManager[14753]: <info> VPN plugin state changed: starting (3)
May 2 17:09:26 xxxxxxxxxxx NetworkManager[14753]: <info> VPN connection 'VPN Connection 1' (Connect) reply received.
May 2 17:09:26 xxxxxxxxxxx NetworkManager[14753]: <warn> VPN connection 'VPN Connection 1' failed to connect: 'Could not find the pppd binary.'.
May 2 17:09:26 xxxxxxxxxxx NetworkManager[14753]: <info> Policy set 'Auto WIRELESS' (wlan0) as default for IPv4 routing and DNS.
May 2 17:09:26 xxxxxxxxxxx NetworkManager[14753]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
May 2 17:09:31 xxxxxxxxxxx NetworkManager[14753]: <info> VPN service 'pptp' disappeared

Mino (raccuia) wrote :

Screenshot configuration

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1175897/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
tags: added: raring
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Mino (raccuia) wrote :

In the meanwhile.. Can I start the service manually?? I need to connect with VPN PPTP...

M. Q. (michaelq87) wrote :

Please find out a solution that this bug is blocking my work.

Mikkel Hagen (hagenmt) wrote :

I just got this working on my system. I have ubuntu 13.04 in a vm running on a windows host using virtualbox. I randomly changed the networking this morning from a NATed interface to a bridged interface and I changed the emulated network device from the Intel PRO/1000 MT Desktop to the PCnet-FAST III adapter. And tonight I connected with my pptp vpn in the ubuntu vm no problem. I am not sure if one or both of the changes fixed it, but it seems to be working away just fine for the last severl hours and I have even been able to disconnect and reconnect several times.

Mino (raccuia) wrote :

My is a physical machine and I upgraded from 12.10 Ubuntu. Your vm is a fresh install or upgrade from previous version?

Mikkel Hagen (hagenmt) wrote :

It was a fresh install

M. Q. (michaelq87) wrote :

Someone has found any solution?

M. Q. (michaelq87) on 2013-05-20
affects: ubuntu → network-manager (Ubuntu)
Andreas (mr-pink37) wrote :

Had the same issue with 13.04. I found this thread where someone got it working by compiling pppd-2.4.3. manually:

http://www.plugout.net/viewtopic.php?f=4&t=377&start=20#p3522

I downloaded 2.4.5 from http://linux.softpedia.com/get/Communications/Telephony/ppp-14015.shtml

Works fine!

Mino (raccuia) wrote :

Thanks!! Works fine!!

Tim Fountain (tfountain) wrote :

Same issue for me when I try and connect to my PPTP VPN. The error in syslog is "Could not find the pppd binary.". Tried reinstalling the pptp packages but no difference. Worked fine in 12.10.

RJ Hsiao (rjhsiao) wrote :

It work fine after I purge the following package and re-install them:
network-manager-pptp network-manager-pptp-gnome ppp pppconfig pppoeconf pptp-linux

RJ Hsiao (rjhsiao) wrote :

Oh, I forgot to say that my Ubuntu version is 13.04 x64

WRF (wrfrancis) wrote :

Same problem here, fresh install of network manager and ppp fixed it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers