NetworkManager VPN configuration export does not work

Bug #264144 reported by Alexey Balmashnov on 2008-09-02
304
This bug affects 67 people
Affects Status Importance Assigned to Milestone
NetworkManager
Invalid
Wishlist
NetworkManager-OpenVPN
Fix Released
Wishlist
network-manager (Ubuntu)
Undecided
Unassigned
network-manager-openvpn (Ubuntu)
Medium
Unassigned
network-manager-pptp (Ubuntu)
Medium
Unassigned

Bug Description

Intrepid,
network-manager: 0.7~~svn20080818t061112+eni0-0ubuntu1

Subject says it. To reproduce:
1. Configure VPN connection
2. Try to Export it to a file

As a result I got cryptic error message dialog:
===
Cannot export VPN connection

The VPN connection 'vpn_test' could not be exported to vpn_test (pptp).conf.

Error: unknown error.
===

Expected behavior:
Configuration saved to a file.

=============
WORKAROUND
The configuration is saved in a file in /etc/NetworkManager/system-connections/
that has the same name as the connection.
This file can be examined with a text editor and/or copied around to other machines.
source: https://bugs.launchpad.net/ubuntu/+source/network-manager-openvpn/+bug/264144/comments/27
WORKAROUND
=============

Related branches

Alexander Sack (asac) wrote :

0.7 vpn support was quite new when i last uploaded it. There have been substantial improvements in the meantime. Please test when the next upload when i make the next snapshot available and comment her whether that helped. Thanks!

Changed in network-manager:
status: New → Incomplete

No improvements in NM 0.7~~svn20080908t183521+eni0-0ubuntu2

On Fri, Sep 12, 2008 at 07:28:31AM -0000, Alexey Balmashnov wrote:
> No improvements in NM 0.7~~svn20080908t183521+eni0-0ubuntu2
>

could you please file this bug in bugzilla.gnome.org against NM? and
let us know about the gnome bug id?

 - Alexander

Alexander Sack (asac) on 2008-09-12
Changed in network-manager:
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in network-manager:
status: Unknown → New
Sergei Orlov (sergei-orlov) wrote :

I have the same bug...

Dmitry Korzhevin (korg) wrote :

I can confirm this bug in network-manager Version: 0.7~~svn20081018t105859-0ubuntu1

Daniel Knittl-Frank (knittl) wrote :

confirmed here

using ubuntu intrepid with latest updates and trying to export a microsoft pptp configuration

Kjell Braden (afflux) wrote :

Looking at their code, both network-manager-openvpn and network-manager-pptp don't seem to support exporting configs yet. However, they should at least set a sensible error message.

Changed in network-manager-pptp:
importance: Undecided → Medium
status: New → Triaged
Robert (robrwo) wrote :

If they don't support exporting configuration, then please disable the export button.

Phoenix (phoenix-dominion) wrote :

Still the same here on up-to-date jaunty

Changed in network-manager:
status: New → Invalid
davee (davee-sungate) wrote :

The correct upstream bug is http://bugzilla.gnome.org/show_bug.cgi?id=573987 not 551939 - the Gnome bugs were re-organised. The new bug is to "implement import/export", i.e. it's just not implemented at all right now.

yyy (yyyy) wrote :

This bug is present also in version 0.7.0.100 (default for ubuntu 9.4)

Reassigning to another GNOME bugzilla number, since there is a more specific entry -- also added the tracker for the same bug for the openvpn plugin

Changed in network-manager:
status: Invalid → Unknown
Changed in network-manager-openvpn:
status: Unknown → In Progress
Marc Poulhiès (marc-poulhies) wrote :

Applying this patch to the source package of karmic works. The export produces a nearly correct file (it uses bad uid/gid).

Targetting this for karmic-updates, since we should be releasing the fix shortly.

Changed in network-manager-openvpn (Ubuntu):
milestone: none → karmic-updates
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-openvpn - 0.8~rc1-0ubuntu1

---------------
network-manager-openvpn (0.8~rc1-0ubuntu1) lucid; urgency=low

  * upstream release tagged 0.7.997 (NM 0.8~rc1)
    + 0.7.997
    - export: implement export and fix a few import/export bugs (LP: #264144)
    - tls: handle PEM files without an ending newline (rh #507315)
    - export: implement export for static-key configurations (bgo #573986)
  * Add logic to map ~rc1 to 0.7.997 tag, as per the main NM branch.
  * Bump build-deps to require NM 0.8~rc1.
  * Update Standards-Version to 3.8.3.
 -- Mathieu Trudel <email address hidden> Tue, 22 Dec 2009 13:55:04 -0500

Changed in network-manager-openvpn (Ubuntu):
status: Triaged → Fix Released

I'm marking this bug against network-manager as invalid, since it instead affects the various VPN plugins directly.

For the time being, network-manager-pptp still does not seem to export configs properly.

Changed in network-manager (Ubuntu):
status: New → Invalid

I had this Issue too, but now im under Lucid Beta1 and it works like charm.

Export and also Import ... thx for this importent work

Michael Doube (michael-doube) wrote :

Export is still failing for me on today's Lucid ISO. Connecting to Imperial College's VPN, following these instructions:
http://www3.imperial.ac.uk/ict/services/securitynetworkdatacentreandtelephonyservices/collegenetwork/networkconnections/vpnconnection/linux

Still not working in network-manager-pptp-gnome / network-manager-pptp

Changed in network-manager:
status: Unknown → In Progress
papukaija (papukaija) on 2010-08-15
tags: added: patch
tags: added: patch-needswork
tags: removed: patch
Elvis Dominguez (elvisd79) wrote :

the problem still here in nm-applet 0.8 (ubuntu 10.04)

Changed in network-manager:
importance: Unknown → Wishlist
Changed in network-manager-openvpn:
importance: Unknown → Wishlist
status: In Progress → Fix Released
Alan Lord (theopensourcerer) wrote :

Am seeing this problem on 10.10 64bit

I have the same problem in 11.04.

Nathan Salwen (salwen-1) wrote :

I am running 12.04 and am unable to do

VPN Connections->Configure VPN... then selext VPN and then Export for a pptp vpn connection. I get the error:

"The VPN connection 'myvpn' could not be exported to myvpn.conf.

Error: unknown error"

Exeleration-G (exeleration-g) wrote :

The error also appears in Ubuntu 13.04, using a PPTP VPN connection.

Exeleration-G (exeleration-g) wrote :

Possible workaround:

On the first machine:

cd /etc/NetworkManager/system-connections/
sudo cp NameOfConnection ~
cd ~
sudo chown yourusername.yourusername NameOfConnection
[copy file to second machine's home directory]
sudo chown root.root NameOfConnection
sudo chmod 600 NameOfConnection
sudo cp NameOfConnection /etc/NetworkManager/system-connections/
cd /etc/NetworkManager/system-connections/
ls -hl

Make sure that NameOfConnection is there, and make sure its permissions are set like this:
-rw------- 1 root root

Can anyone confirm that this works?

I get this error on 13.04 while trying to export a PPTP VPN Connection.

Michael Nagel (nailor) wrote :

I am on Ubuntu 12.04 LTS where this is an issue.
I can confirm that the file-based workaround outlined in comment #27 by exeleration-g works.

description: updated
Changed in network-manager:
status: In Progress → Invalid
senya (senya) wrote :

Confirming the issue on Ubuntu 14.04.

citizendelta (dghallau) wrote :

Confirming the issue on Ubuntu 15.04.

公输目 (yue937) wrote :

confirming the issue on Ubuntu 14.04 amd64.
 https://clbin.com/7OgauO.png

Jorge Valhondo (jrg-valhondo) wrote :

I confirm this issue in 14.04 LTS x64

Esel (glumpad) wrote :

I confirm this issue in 16.04 x64

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.