Network-manager icon displayed twice in panel

Bug #938380 reported by Sam_
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

After recent updates a second network-manager icon appeared in panel (screenshot). (similar with battery few days ago)
Attach the related extract from term.log.
Reported against gtk-3 because in term.log it says:
Leaving 'diversion of /usr/sbin/update-icon-caches to /usr/sbin/update-icon-caches.gtk2 by libgtk-3-bin'

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libgtk-3-bin 3.3.16-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
Date: Wed Feb 22 04:37:45 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: gtk+3.0
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Sam_ (and-sam) wrote :
Revision history for this message
Sam_ (and-sam) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtk+3.0 (Ubuntu):
status: New → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

it's likely yesterday's nm-applet updates ... mathieu, those users do whitelist all systray icons in unity so they get fallback icons showing if they are not probably hidden

affects: gtk+3.0 (Ubuntu) → ubuntu
affects: ubuntu → network-manager-applet (Ubuntu)
Changed in network-manager-applet (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Revision history for this message
Sebastien Bacher (seb128) wrote :

probably -> properly

Revision history for this message
Sam_ (and-sam) wrote :

There is no dupe nm-applet symbol on pc, which is connected with lan, but also has systray whitelist 'all'.
Updates are the same as on laptop.

Revision history for this message
Elfy (elfy) wrote :

Not just Unity - seeing the same thing in Xubuntu.

Revision history for this message
Sam_ (and-sam) wrote :

#6 was a fluke. Yesterday I could observe the moment I've activated suspend on pc a second network icon appeared before the screen turned off.

Revision history for this message
Sutram (sutram) wrote :

This bug affects me on Xubuntu 12.04 i386

Revision history for this message
Tom Pino (metalsmith-rangeweb) wrote :

Xubuntu 12.04-testing amd64

Revision history for this message
Sam_ (and-sam) wrote :

Odd.
On pc after several reboots and logouts (due to some other testings) it displays only the orig. network icon.
On laptop it still displays network icon twice after several reboots and logouts. Update status is the same on both computers.

Revision history for this message
Elfy (elfy) wrote :

Bunch of updates later and now I have no network notifications at all.

Xubuntu 12.04 i386

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

And that's for Xubuntu in all these cases? It seems rather weird because the GtkStatusIcon should never show unless the indicator is in fallback mode... in fallback, it's shown, every other moment it should be hidden; though I may have screwed up one case in the last nm-applet upload.

Changed in network-manager-applet (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Sam_ (and-sam)
tags: added: unity
Revision history for this message
Sam_ (and-sam) wrote :

Report was made from Unity, added the tag. On pc it definitely adds a second icon when going to suspend. When I reboot the pc it displays one icon. On laptop the second wl icon is always there.
Among the first lines of .xsession-errors it says:
....
** Message: applet now removed from the notification area
Initializing nautilus-gdu extension
** Message: using fallback from indicator to GtkStatusIcon
....
Initializing unityshell options...done
** Message: applet now embedded in the notification area
....
Starting gtk-window-decorator
** Message: moving back from GtkStatusIcon to indicator
** Message: applet now removed from the notification area
....
** Message: using fallback from indicator to GtkStatusIcon
** Message: applet now embedded in the notification area
....
** Message: moving back from GtkStatusIcon to indicator
** Message: applet now removed from the notification area

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Yeah, I know what went wrong. There's one oversight in the code to handle disabling the icon -- one of the gtk_status_icon_set_visible() calls were not wrapped properly with a test to see if the widget should be shown. I've corrected that, and I'll upload the fix soon.

Changed in network-manager-applet (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Elfy (elfy) wrote :

Thanks Mathieu.

I assume that will fix it for all and not just Ubuntu/Unity - if not report here or create a new bug for Xubuntu?

Revision history for this message
Sam_ (and-sam) wrote :

Thanks Mathieu, that would be one of a kind of turbo fix!

Revision history for this message
Tom Pino (metalsmith-rangeweb) wrote :

Well as for today there is no applet at all under Xubuntu.

I am pretty sure my connection is up and running well. Would have been hard to get this page up if not.

Should we file another bug or is this good enough?

Revision history for this message
TK (tkrishan) wrote :

I also have no indicators in either the indicator or notification areas of the panel with Xubuntu 12.04 using 0.9.2.0+git.20120126t000800.5151959-0ubuntu3. Networking is functional but have no desktop control.

I've downgraded to a previous release where the icon is only displayed in the notification area of the panel.

Revision history for this message
Sam_ (and-sam) wrote :

This bug was reported while running Unity and having two icons displayed, the commit isn't yet uploaded.
Regarding Xubuntu and having no applet at all displayed imho is a different story.
That said the last release obviously has different outcomes on different environments.
https://launchpad.net/ubuntu/+source/network-manager-applet/0.9.2.0+git.20120126t000800.5151959-0ubuntu3

Revision history for this message
Elfy (elfy) wrote :

Totally agree Sam_ - as soon as the fix is released etc I will look - if it needs re-reporting I'll do so - but no point in duplicates until sure :)

Revision history for this message
Bowmore (bowmore) wrote :

The solution here is to add Unity to NotShowIn in the .desktop-file:
/etc/xdg/autostart/nm-applet.desktop

and probably also to:
/usr/share/applications/nm-applet.desktop

Not sure about app-install-data:
/usr/share/app-install/desktop/network-manager-gnome:nm-applet.desktop

Revision history for this message
Bowmore (bowmore) wrote :

Sorry, just noticed that both network icons disappeared :(

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

With the 0.9.2.0+git.20120126t000800.5151959-0ubuntu3 nm-applet upload, a GConf key was introduced to show/hide the applet in the systray: '/apps/nm-applet/show-applet' and its description is: 'Show the applet in notification area'. and 'Set to FALSE to disable displaying the applet in the notification area.'.

That's why I set this key to FALSE in xubuntu-default-settings 12.04.7...

And obviously the documentation is wrong, because this key will hide it from everywhere (both the systray and the indicators).

So if you use Xubuntu 12.04, you can set back this key to TRUE with gconf-editor to let the nm-applet reappear. (Until I revert my change in the next upload).

@Mathieu Trudel-Lapierre (mathieu-tl): See above, please fix the gconf description of the key. Thanks!

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Lionel, the description isn't really wrong -- the expectation is that the gconf key hides both the indicator and the GtkStatusIcon, because they are never supposed to show at the same time -- one being the fallback of the other. The fact that they did is the symptom of this bug.

Fixing the underlying bug will cover the issue.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.2.0+git.20120126t000800.5151959-0ubuntu4

---------------
network-manager-applet (0.9.2.0+git.20120126t000800.5151959-0ubuntu4) precise; urgency=low

  * debian/patches/lp829673_gconf_hide_applet.patch: only set the applet
    GtkStatusIcon to be visible when the icon is updated if the indicator is
    in fallback mode. (LP: #938380)
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 27 Feb 2012 12:41:59 -0500

Changed in network-manager-applet (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Sutram (sutram) wrote :

Thanks for fixing the bug. I still needed to set the nm-applet value to TRUE through gconf-editor to make it show up. I am assuming that this is because it had been set to FALSE as Lionel described above.

Thanks.

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Correct, that change will also need to be reverted.

Revision history for this message
Elfy (elfy) wrote :

While I have it setup now here and it works correctly - I wonder if a bug for xubuntu needs to be raised as to show it there you need to install gconf-editor to allow the applet to show.

Or is there something else in the pipeline that would negate this?

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

Gconf-editor isn't really needed, you can do it with: "gconftool-2 -s /apps/nm-applet/show-applet -t bool true" too.
Anyway, Micah has just uploaded xubuntu-default-settings 12.04.8 reverting the change, so nm-applet should be visible again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers