Ubuntu

after resume the "Disconnected - you are now offline" notification doesn't disappear

Reported by Bazon on 2011-08-28
206
This bug affects 41 people
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Undecided
Unassigned
xfce4-notifyd (Ubuntu)
Low
Unassigned

Bug Description

Observed behaviour:
When I resume from standby, the "Disconnected - you are now offline" notification (which probably appeared when standby was started) stays on the screen and doesn't go away until I close it manually.
Network (LAN - eth0) works, so in fact I'm online and the notification is false.
Notifications are set to disappear after 4 seconds, which they do, except this naughty one.

Expected behaviour:
The "Disconnected - you are now offline" notification should not appear or disappear after the selected amount of time.
The best thing would be to display a "Connected - you are now online" notification.

used version:
0.2.1-1 on Xubuntu Natty
(all updates up to date)

Bazon (bazonbloch) on 2011-08-28
description: updated
Steven Keys (steevven1) wrote :

I am seeing this exact same bug. I'm running Xubuntu 11.10 64-bit and Xubuntu 11.04 64-bit. Both show the bug. The "Network disconnected" notification just doesn't obey the "disappear" setting.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-notifyd (Ubuntu):
status: New → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

Im' not sure whether it's xfce4-notifyd fault, or network-manager, or a weird interaction between both.

Changed in xfce4-notifyd (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
da_coynul (xtragb) wrote :

This problem is related to the bug discussed here:

https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/445872

da_coynul (xtragb) wrote :

Just to clarify my above comment, I meant that this patch:

lp341684_device_sensitive_disconnect_notify.patch

is probably also the cause of bug 835972.

da_coynul (xtragb) wrote :

OK, I built and tested network-manager-gnome (nm-applet) with these patches reverted:

lp341684_device_sensitive_disconnect_notify.patch
lp358526_generic_disconnected_notification_icon.pa tch

This prevents the notification from staying on the screen until manually closed. You can also use this command:

gconftool-2 -s /apps/nm-applet/disable-disconnected-notifications true --type bool

to disable disconnected notifications (or set it to false to re-enable them).

I am not really sure why the patches are being included in the current package anyway. They do no seem to be necessary. Can someone from the network-manager team please explain?

Bazon (bazonbloch) wrote :

Sorry, I can't test it anymore, doesn't happen in 11.10 anymore for me.

Dmitriy Kodanev (dkodanev) wrote :

I'm using Xubuntu 11.10 and confirm that the bug still exists. All notifications disappear but notifications from network-manager after resume. I am not such a big professional in building packages and I think I'm not the only one. So can someone build network-manager with patches lp341684 and lp358526 and publish it in ppa just to let us check the problem is solved?

Jeroen Meijer (jjgmeijer) wrote :

At the moment I am having the same problem running Gnome 3 on ubuntu 11.10.

Will there be a patch released?

Hi!

I can confirm the existence of this bug in the Ubuntu 11.10 based
distribution Mint 12 (Lisa) under Gnome 3.2 (with the Mint Gnome Shell
Extensions), even with all the latest updates installed.

I read something about a patch some time ago, there it was about Ubuntu
11.04 I think.
Does someone know where to find this?

2012/1/6 Jeroen Meijer <email address hidden>

> At the moment I am having the same problem running Gnome 3 on ubuntu
> 11.10.
>
> Will there be a patch released?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (879015).
> https://bugs.launchpad.net/bugs/835972
>
> Title:
> after resume the "Disconnected - you are now offline" notification
> doesn't disappear
>
> Status in “network-manager-applet” package in Ubuntu:
> Confirmed
> Status in “xfce4-notifyd” package in Ubuntu:
> Confirmed
>
> Bug description:
> Observed behaviour:
> When I resume from standby, the "Disconnected - you are now offline"
> notification (which probably appeared when standby was started) stays on
> the screen and doesn't go away until I close it manually.
> Network (LAN - eth0) works, so in fact I'm online and the notification is
> false.
> Notifications are set to disappear after 4 seconds, which they do, except
> this naughty one.
>
> Expected behaviour:
> The "Disconnected - you are now offline" notification should not appear
> or disappear after the selected amount of time.
> The best thing would be to display a "Connected - you are now online"
> notification.
>
> used version:
> 0.2.1-1 on Xubuntu Natty
> (all updates up to date)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/835972/+subscriptions
>

I am also seeing this in Ubuntu 11.10 and Gnome 3.2, so surely it's Network Manager that's causing the problem if it's affecting different desktop environments.

da_coynul (xtragb), any chance you could upload that build somewhere so we can test? I'm seeing the bug on Xubuntu 11.10 (the notification stays until you click, the gconf setting is ignored), just updated everything today.

Note: for those who just want a quick fix, it might help to put something like this

#!/bin/sh
case "${1}" in
    resume|thaw)
 ( sleep 2 ; /usr/bin/killall /usr/lib/xfce4/notifyd/xfce4-notifyd ) &
 ( sleep 4 ; /usr/bin/killall /usr/lib/xfce4/notifyd/xfce4-notifyd ) &
     ;;
esac

in /etc/pm/sleep.d/49_killall_notify, remember to chmod +x.

(this is for Xubuntu; on regular Ubuntu it might be "killall notify-osd" instead of xfce4-notifyd, you might also need to tweak the sleep times)

Jake Tolbert (crazybilly) wrote :

As a workaround in Gnome 3, you can install/run gnconf-editor and navigate to apps/nm-applet and turn off disconnected notifications.

It's a bit of a kludge, as you won't get useful notifications (ie. when your network drops), but it's better than having to click the thing every time you open your laptop lid.

Luke Scharf (lukescharf) wrote :

I see this one, too. It's actually the biggest source of UI confusion when I hand my snazzy Ubuntu laptop to someone who's only used Windows or Mac OS X, and it really is confusing.

I would expect this particular message to disappear (or be replaced with "you are now connected") when network connectivity has been restored. That's usually 5-10 seconds after I open my laptop at at the office or at home.

Steven Keys (steevven1) wrote :

Maybe the importance of this should be medium rather than low? It is one of the first things Xubuntu users notice with a fresh installation, and although it is just an annoyance, it is one that every user, new or old, beginner or advanced, has to deal with.

Jeroen Meijer (jjgmeijer) wrote :

I agree to increase its importance, but it does not happen only to Xubuntu users, I am using gnome 3.2 and seeing the exact same thing. I often make my laptop go in standby, so I am experiencing this at least once a day. An annoyance is an understatement.

Grant Likely (glikely) wrote :

Using Unity on 12.04 here. I can confirm it is still a problem. I've used to the gconftool-2 workaround suggested by xtragb.

I think this is fixed now in Precise with the upload of network-manager-applet 0.9.4.1-0ubuntu1 (to fix bug 883443).

Please confirm whether this covers it for you. Note that this is a package that landed *after* Beta2, may not be available in your local mirror yet.

Grant Likely (glikely) wrote :

I apt-get upgraded just now and the issue is indeed solved now for me
with network-manager-gnome 0.9.4.1-0ubuntu1 installed. Thanks!

On Thu, Mar 29, 2012 at 4:17 PM, Mathieu Trudel-Lapierre
<email address hidden> wrote:
> I think this is fixed now in Precise with the upload of network-manager-
> applet 0.9.4.1-0ubuntu1 (to fix bug 883443).
>
> Please confirm whether this covers it for you. Note that this is a
> package that landed *after*  Beta2, may not be available in your local
> mirror yet.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/835972
>
> Title:
>  after resume the "Disconnected - you are now offline" notification
>  doesn't disappear
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/835972/+subscriptions

--
Grant Likely, B.Sc., P.Eng.
Secret Lab Technologies Ltd.

James M. Jensen II (badocelot) wrote :

Running Xubuntu 11.10. xtragb's fix does not work.

I agree with increasing the importance to Medium. The notification doesn't hurt anything, but it is *highly* annoying and happens every single time you suspend and resume.

Lionel Le Folgoc (mrpouit) wrote :

So, I guess it's fixed in precise as per comments #20 and #21.

Changed in xfce4-notifyd (Ubuntu):
status: Confirmed → Invalid
Changed in network-manager-applet (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers