Ubuntu

disable-disconnect-notification option ignored

Reported by Nicolò Chieffo on 2009-10-07
108
This bug affects 21 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
James M. Leddy
Precise
High
James M. Leddy
Quantal
Medium
James M. Leddy
network-manager-applet (Ubuntu)
Medium
Mathieu Trudel-Lapierre
Nominated for Lucid by Abhishek Dasgupta
Precise
Medium
Mathieu Trudel-Lapierre
Quantal
Medium
Mathieu Trudel-Lapierre

Bug Description

[Impact]

For OEM's, we offer a video that runs on first boot kick things off. Invariably, nm-applet winds up printing a disconnect notification, which detracts from the quality feeling of the video. We would like to get this working in Ubuntu so for 12.04.2 we can use disable-disconnect-notification instead of our hard-coded workaround.

[Test Case]

The popups can be disabled by either running the following commands and then restarting or logging off / on:

gconftool -s /apps/nm-applet/disable-disconnected-notifications --type=bool true
gconftool -s /apps/nm-applet/disable-connected-notifications --type=bool true
gconftool -s /apps/nm-applet/suppress-wireless-networks-available = true

OR

The following can be hard-coded into /var/lib/gconf/debian.mandatory/%gconf.xml

<?xml version="1.0"?>
<gconf>
<dir name="apps">
<dir name="nm-applet">
<entry name="suppress-wireless-networks-available" mtime="1334087625" type="bool" value="true"/>
<entry name="disable-connected-notifications" mtime="1334087553" type="bool" value="true"/>
<entry name="disable-disconnected-notifications" mtime="1334087516" type="bool" value="true"/>
</dir>
</dir>
</gconf>

[Regression Potential]

Minimal. This change is only 2 changed lines, and we've already released in 12.10 without problems.

[Original Description]

the gconf key /apps/nm-applet/disable-disconnected-notifications does not disable disconnect notifications, while the other works for connected notifications.

ProblemType: Bug
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory
Date: Thu Oct 8 00:50:27 2009
DistroRelease: Ubuntu 9.10
Gconf:

IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 192.168.5.0/24 dev wlan0 proto kernel scope link src 192.168.5.2 metric 2
 169.254.0.0/16 dev wlan0 scope link metric 1000
 default via 192.168.5.1 dev wlan0 proto static
Package: network-manager-gnome 0.8~a~git.20091002t194214.8515a07-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.31-12.40-generic
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager-applet
Uname: Linux 2.6.31-12-generic x86_64

Nicolò Chieffo (yelo3) wrote :
Alexander Sack (asac) wrote :

yes, this is a bug and should be relatively easy to fix. unfortuantely all those patches are not yet upstream so it would again be only ubuntu work.... willl think about it.

Changed in network-manager-applet (Ubuntu):
assignee: nobody → Alexander Sack (asac)
importance: Undecided → Medium
status: New → Triaged

If you decide to wait for upstream to fix, at least reconsider to
enable connected notifications

Alexander Sack (asac) wrote :

enabling/disabling notifications in gconf by default is a different bug.

Alexander Sack (asac) wrote :

the other bug is bug 444561

Alexander Sack (asac) wrote :

On Thu, Oct 08, 2009 at 07:13:11AM -0000, Nicolò Chieffo wrote:
> If you decide to wait for upstream to fix, at least reconsider to
> enable connected notifications

yes, thats involved in bug 444561 ... which is about that regression.

 - Alexander

Tony Houghton (h-realh) wrote :

Unlike the OP I'm still also getting notifications when connected despite setting the option, but the notifications are incorrect: they tell me I'm disconnected when really I'm connected.

Using network-manager-gnome 0.8~a~git.20091014t134532.4033e62-0ubuntu1 on Karmic UNR.

Tony Houghton (h-realh) wrote :

Surely you need to debug the patches before they'll be accepted upstream, not wait until they accept broken patches and then fix them.

SteveLoughran (steve-loughran) wrote :

+1 to fixing this rather than try and push a broken patch upstream. The OSS projects I'm involved in would veto a patch with known failings and say "fix it first"

Martin Pitt (pitti) on 2011-01-07
Changed in network-manager-applet (Ubuntu):
assignee: Alexander Sack (asac) → nobody
da_coynul (xtragb) wrote :

Can someone explain why this patch:

lp341684_device_sensitive_disconnect_notify.patch

does not use the function applet_do_notify_with_pref () to display disconnected notifications? You can see where it was removed by the patch:

- applet_do_notify_with_pref (applet, _("Disconnected"),
- _("The network connection has been disconnected."),
- "nm-no-connection",
- PREF_DISABLE_DISCONNECTED_NOTIFICATIONS);

The above function checks the value of /apps/nm-applet/disable-disconnected-notifications before displaying the notification.
The code from the patch does not:

...
info->text = _("Disconnected - you are now offline");
...

SteveLoughran (steve-loughran) wrote :

@Kevin: I'm not sure. Issue 835972 is about the dialog coming up on suspend/resume and not going away automatically.

This one is about the dialog appearing in the first place -even when you've told it not to appear.

Changed in network-manager-applet (Ubuntu):
status: Triaged → Confirmed

Proposed fix in lp:~matvey-marinin/network-manager-applet/lp445872, can anyone review?

tags: added: rls-q-incoming
Changed in network-manager-applet (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Medium
Changed in network-manager-applet (Ubuntu Quantal):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.6.0~git201207161252.13c6db8-0ubuntu2

---------------
network-manager-applet (0.9.6.0~git201207161252.13c6db8-0ubuntu2) quantal; urgency=low

  * debian/patches/lp341684_device_sensitive_disconnect_notify.patch: updated
    to respect the "disable-disconnected-notifications" settings. (LP: #445872)
 -- Matvey Marinin <email address hidden> Thu, 02 Aug 2012 16:21:04 -0400

Changed in network-manager-applet (Ubuntu Quantal):
status: In Progress → Fix Released
Kent Baxley (kentb) wrote :

Can we please see about getting this into an SRU for precise as well? Thanks.

James M. Leddy (jm-leddy) wrote :

Hi Kent,

I've uploaded a test package at https://launchpad.net/~jm-leddy/+archive/enable-disable-disconnect-notification-2 . The other archive didn't work due to a binary difference between 12.04 and 12.10. Please let me know if this version works, and I'll ask for a merge request.

Changed in network-manager-applet (Ubuntu Precise):
status: Confirmed → In Progress
Kent Baxley (kentb) wrote :

Hi James,

I seem to be locked out of that archive. Trying to access it gives me a "Not allowed here" page.

description: updated
Changed in network-manager-applet (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in network-manager-applet (Ubuntu Precise):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in network-manager-applet (Ubuntu Quantal):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
tags: added: rls-r-incoming
James M. Leddy (jm-leddy) wrote :

This hasn't been promoted to proposed because we're waiting on another SRU.

Iain Lane (laney) wrote :

Right, then I'm removing the sponsors team so that people don't keep looking at this bug. Please readd it when you're ready for the package to be sponsored.

Steve Magoun (smagoun) wrote :

@James: What is the other SRU that we're waiting on? Can you provide a link to the bug(s) for the other SRU?

James M. Leddy (jm-leddy) wrote :

Hi Steve,

This is blocked by bug 780602. Since that bug is verification-failed, we have to pull the nm-applet package from precise before we fix this bug in precise.

Steve Magoun (smagoun) wrote :

@James: Who is responsible for pulling the nm-applet package from precise and when will that happen?

James M. Leddy (jm-leddy) wrote :

We have decided to upload the new package after all. I'm working with ~ubuntu-sru to get this into the updates archives.

Hello Nicolò, or anyone else affected,

Accepted network-manager-applet into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/network-manager-applet/0.9.4.1-0ubuntu2.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager-applet (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Kent Baxley (kentb) wrote :

oops...didn't see this go out for precise. I'll test it and provide feedback.

Kent Baxley (kentb) wrote :

Proposed packages appear to finally fix this. I can tell gconftool to suppress the OSD messages for disconnect and they are now obeyed. Thanks for your work!

Kent Baxley (kentb) on 2013-05-03
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.4.1-0ubuntu2.3

---------------
network-manager-applet (0.9.4.1-0ubuntu2.3) precise-proposed; urgency=low

  [ Matvey Marinin ]
  * debian/patches/lp341684_device_sensitive_disconnect_notify.patch: updated
    to respect the "disable-disconnected-notifications" settings. (LP: #445872)
 -- James M Leddy <email address hidden> Mon, 15 Apr 2013 16:15:22 -0400

Changed in network-manager-applet (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers