Comment 50 for bug 684599

Ok there is just no point in keeping this bug open any longer : the issue is resolved in Natty, the remaining issues appear to be caused by users of some PPA which uses an outdated copy of nm-applet (elementaryart's elementary-desktop PPA, from what I can tell).

Marking Fix Released for Natty.

In Maverick, you can downgrade to the official package from the archive (sudo apt-get install network-manager-gnome/maverick).