nm-applet loaded, but icon not visible (karmic)

Bug #446093 reported by ignasi on 2009-10-08
200
This bug affects 40 people
Affects Status Importance Assigned to Milestone
NetworkManager
Expired
High
network-manager-applet (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by jaduret
Nominated for Maverick by e.m.fields

Bug Description

Binary package hint: network-manager

I'm testing karmic amd64 with latest updates. For the past weeks I've noticed that when I first log in after turning on the computer nm-applet icon will not appear at all in the notification area applet, and most of the times a repeated icon with no function at all (sometimes it will be a blank space) will appear instead (see attached image for details). However, as you can see in the image, network is active and running. When I say "repeated icon with no function at all" I mean that, as in the attached image, a repeated icon for the battery (sometimes it will be the bluetooth icon) appears. However, if I click on the repeated icons, one will normally present its pop-up menu, the other will do nothing. So this is not nm-applet working with the wrong icon since I cannot see the nm-applet menu.

If I kill and restart nm-applet the repeated, dumb icon will dissapear and the nm-applet icon will show and work fine.

ignasi (igp-oenus) wrote :
description: updated
Philip Peitsch (philip-peitsch) wrote :

If you remove and re-add the notification area this makes the icon display as well. I've got this happening on two PC's that have been running Ubuntu since Karmic 5. It did previously display properly until Beta releases started happening I believe.

I'm using karmic and the same problem occurs here. The solution that I found was log off and after, log in again.

emilio (emiliomaggio) wrote :

Same problem here, in my case the icon does not reappear if I restart network manager. Also some times there is no icon other times a duplicate of another icon appear. I guess we can move this bug to confirmed.

Changed in network-manager (Ubuntu):
status: New → Confirmed
emilio (emiliomaggio) wrote :

This problem affects Ubuntu 9.10 32bit as well

Philip Peitsch (philip-peitsch) wrote :

emilio... I found that exiting nm-applet (not network manager) and restarting that helped. Can you check your ~/.config/autostart folder and see if there is a link to nm-applet or network manager in there?

To me the problem almost seemed to be caused by nm-applet attempting to start up multiple times on start up...

Ramaddan (ramaddan) wrote :

same problem here on two machines, and I need to end nm-applet task and reload it for it to work properly.

emilio (emiliomaggio) wrote :

@philip
No I do not have any link to nm-applet in ~/.config/autostart . However in my case the easiest way to get the icon working is to remove the notification area from the top panel and then add it back.

Scaler (balaton22) wrote :

Same problem (blank space in the place of network manager icon in notification aera) here at almost every boot and login with Ubuntu amd64.

Removing then adding back notification aera or killing then reload nm-appplet works until next reboot or relogin.

No link to nm-applet in ~/.config/autostart.

Ramaddan (ramaddan) wrote :

This problem suddenly disappeared with me, and I have no idea how.

I have no idea if it was from updates or so on.

However, just in case it is relevant, I currently use the following kernels:
linux-image-2.6.31-14-generic-pae
linux-image-2.6.31-15-generic-pae

If my memory serves me right, I used to have some network errors in 2.6.31-15,
and the nm-applet icon would not show up when it logged in until I restarted it.

However, things were never smooth with me with image-2.6.31-15, and in the end, it just stopped booting up the system altogether and would hang on boot up.

So I went back to 2.6.31-14 and since then did not have the nm-applet problem anymore.

The issue is, since 2.6.31-15 hangs with me, I cannot confirm that the nm-applet issue is related to this kernel.

Can others whose 2.6.31-15 kernel is working try to go back to 2.6.31-14 and see if it makes a difference with the nm-applet issue?

As a side note, can anyone point me if there is a bug report for the 2.6.31-15 kernel issue I have?

Thanks

ElGatoNegro (sergio-iborra) wrote :

Karmic, 32 bits, wired connection. Same problem.
Problem disappeared 3 days ago, maybe after updates, maybe after that :
- DO NOT rename your connection ('Auto eth0')
- DO NOT remove the 'Available to all users'
Can you try and confirm?

jaduret (jaduret) wrote :

Still have the issue with 2.6.31-16 and doesn't seem to improve at all

ElGatoNegro (sergio-iborra) wrote :

[can't edit old comments?]
Karmic 32, Kernel 2.6.31-16, Gnome 2.28.1, NM Applet 0.7.996

Problem was back after 'cairo-dock' update... and has disappeared again after kernel update today.

Of course, comment #11 seems not to be a solution

Thiago Teixeira (tvst) wrote :

i have this problem on one of my laptops. this was a clean install of karmic (i even formated the home folder).

Quoting tvst <email address hidden>:Now I have reverted to 9.04 the system is
working fine.It is obviously a software fault with karmic.I shall run the CD
live when I eventually receive it and if the same problem arises, I will stick
with 9.04.

> i have this problem on one of my laptops. this was a clean install of
> karmic (i even formated the home folder).
>
> --
> nm-applet loaded, but icon not visible (karmic)
> https://bugs.launchpad.net/bugs/446093
> You received this bug notification because you are subscribed to
> NetworkManager.
>
> Status in NetworkManager: Unknown
> Status in ?network-manager? package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: network-manager
>
> I'm testing karmic amd64 with latest updates. For the past weeks I've
> noticed that when I first log in after turning on the computer
> nm-applet icon will not appear at all in the notification area
> applet, and most of the times a repeated icon with no function at
> all (sometimes it will be a blank space) will appear instead (see
> attached image for details). However, as you can see in the image,
> network is active and running. When I say "repeated icon with no
> function at all" I mean that, as in the attached image, a repeated
> icon for the battery (sometimes it will be the bluetooth icon)
> appears. However, if I click on the repeated icons, one will normally
> present its pop-up menu, the other will do nothing. So this is not
> nm-applet working with the wrong icon since I cannot see the
> nm-applet menu.
>
> If I kill and restart nm-applet the repeated, dumb icon will
> dissapear and the nm-applet icon will show and work fine.
>
>
>
>
>

Cruncher (ubuntu-wkresse) wrote :

Duplicate of bug #444333?

Scaler (balaton22) wrote :

@ Cruncher: seems similar to me.

On my laptop, the bug is fixed since the beginning of the year approximately (before that, the bug appears at nearly every start).

Ubuntu 9.10 (Karmic) amd64
Linux Kernel 2.6.31-17 (but the bug seems to be fixed with the Linux Kernel 2.6.31-16 too, before the update)
NetworkManager 0.7.996
Notification Area 2.28.0

fralk (fmonte) wrote :

following comment #11 I checked the 'Available to all users' checkbox in the default connection (for some reason it wasn't), and the problem is now fixed.

I found workaround on forums:
Alt+F2 and type
nm-applet --sm-disable

It is the same command as for item Network Manager in gnome-session-properties window.

But it is NOT the solution!

Chenf (chenlao-hotmail) wrote :

Try this workaround:
add delay to startup command like:
sh -c "sleep 5; exec nm-applet --sm-disable"

Ramaddan (ramaddan) wrote :

Hi,

I actually just deleted the "nm-applet" folder under /"homefolder"/.gconf/apps, and everything started to work fine.

I did this on two systems so far, and it worked.

Hope this also works with others.

Changed in network-manager:
status: Unknown → Invalid
ctrl (dario-dariocorti) wrote :

As a fast workaround, I add moving the notification area to the bottom panel and to the top again, without releasing it (or vice-versa if you already have it on the bottom panel).

Changed in network-manager:
importance: Unknown → High
status: Invalid → Expired
tariwan (tariwan) wrote :

for me this bug appears for multi-user ubuntu usage. If there is only one user in ubuntu nm-applet works fine.
Little bug that makes impossible usage of ubuntu with two user accounts. I simply cant connect to internet

Ubuntu 10.10 64-bit.

How come this hasn't been worked out? It's stil happening on Natty, and maybe it'll be on Oneiric :/

Marius B. Kotsbak (mariusko) wrote :

Is this still happening? With Unity or Gnome interface?

Thomas Hood (jdthood) on 2012-06-26
Changed in network-manager (Ubuntu):
status: Confirmed → Incomplete
Thomas Hood (jdthood) on 2012-07-22
affects: network-manager (Ubuntu) → network-manager-applet (Ubuntu)
Nikolay Shopik (shopik) wrote :

still seeing problem in 14.04, nm-applet only appers if I run it from root `sudo nm-applet`, tried every solution I could find, none of them helped

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.