The network indicator shows the wrong status

Bug #1641889 reported by Cyrus Lien on 2016-11-15
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Network Manager Applet
Unknown
Unknown
OEM Priority Project
Critical
Cyrus Lien
Xenial
High
Unassigned
network-manager-applet (Ubuntu)
High
Ken VanDine
Xenial
High
Ken VanDine

Bug Description

[Summary] The network indicator shows the wrong status

[Reproduce Steps]
1.Boot into Ubuntu OS , disconnect wireless connection
Note : the issue can't be reproduced with wifi connected
2.Enable/disable wifi function by pressing hotkey then check network manager status

[Results]
Expected: "Enable Wi-Fi" option should be OFF
Actual:"Enable Wi-Fi" option is ON

[Additional Information]
Product Name:Inspiron-7460
BIOS Version:1.0.0

Cyrus Lien (cyruslien) on 2016-11-15
Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Cyrus Lien (cyruslien) wrote :

The issue already fixed, please help to pull the patch into ubuntu network-manager-applet package.
Thanks!

Upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=770218.

Kent Lin (kent-jclin) on 2016-11-15
Changed in oem-priority:
importance: Undecided → Critical
importance: Critical → High
Ara Pulido (ara) wrote :

What version of Ubuntu? What version of network manager? Has this been tested in Zesty)

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Incomplete
Cyrus Lien (cyruslien) wrote :

The fix already landed lp:network-manager-applet. (revno: 3503)

Changed in network-manager-applet:
importance: Undecided → Unknown
status: New → Unknown
Kent Lin (kent-jclin) wrote :

This issue can be reproduced on Yakkety live image, which uses, network-manager 1.2.2-0ubuntu6
network-manager-gnome 1.2.2-0ubuntu1

Kent Lin (kent-jclin) wrote :

Tested Zesty daily build 2016-12-02 the issue still could be reproduced.
The "Enable Wifi" in pull downlist will not reflect the wifi status time to time if use hotkey to enable and disable wifi.

Network manager version:

network-manager 1.2.4-0ubuntu1
network-manager-gnome 1.2.4-0ubuntu2
network-manager-openvpn 1.2.6-2ubuntu1
network-manager-pptp 1.2.4-1
network-manager-pptp-gnome 1.2.4-1

Kent Lin (kent-jclin) wrote :

The original issue is reported against Xenial.

Ara Pulido (ara) on 2016-12-02
Changed in network-manager-applet (Ubuntu):
status: Incomplete → Confirmed
Aron Xu (happyaron) on 2016-12-03
Changed in network-manager-applet (Ubuntu):
status: Confirmed → Triaged
Aron Xu (happyaron) on 2016-12-16
Changed in network-manager-applet (Ubuntu):
importance: Undecided → High
assignee: nobody → Aron Xu (happyaron)
Changed in oem-priority:
importance: High → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu Xenial):
status: New → Confirmed
Aron Xu (happyaron) on 2017-04-29
Changed in network-manager-applet (Ubuntu):
assignee: Aron Xu (happyaron) → nobody
Changed in oem-priority:
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)
Cyrus Lien (cyruslien) wrote :

The fix landed in network-manager-applet-1.4.2, still need porting to 1.2.6 for xenial.

Yuan-Chen Cheng (ycheng-twn) wrote :

per comment from PM, we still want this to be fixed.

Changed in oem-priority:
assignee: Yuan-Chen Cheng (ycheng-twn) → Shih-Yuan Lee (fourdollars)
Will Cooke (willcooke) on 2017-05-09
Changed in network-manager-applet (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in network-manager-applet (Ubuntu Xenial):
assignee: nobody → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.4.2-1ubuntu5

---------------
network-manager-applet (1.4.2-1ubuntu5) artful; urgency=medium

  * debian/patches/git_fix_wrong_status_for_wireless_toggle.patch
    * Fix wrong status for wireless toggle (LP: #1641889)

 -- Ken VanDine <email address hidden> Tue, 09 May 2017 09:39:33 -0400

Changed in network-manager-applet (Ubuntu):
status: Triaged → Fix Released
Changed in network-manager-applet (Ubuntu Xenial):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

I'll let this into the xenial-proposed queue but it looks like it should also be fixed in Yakkety and Zesty.

Changed in network-manager-applet (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed

Hello Cyrus, or anyone else affected,

Accepted network-manager-applet into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/1.2.6-0ubuntu0.16.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Cyrus Lien (cyruslien) on 2017-05-12
Changed in oem-priority:
assignee: Shih-Yuan Lee (fourdollars) → Cyrus Lien (cyruslien)
Cyrus Lien (cyruslien) on 2017-05-12
description: updated
Cyrus Lien (cyruslien) wrote :

Hello Brian,

Network-manager-applet (1.2.6-0ubuntu0.16.04.3) works like a charm.

Test case:
1.Boot into Ubuntu OS , disconnect wireless connection
2.Enable/disable wifi function by pressing hotkey then check wifi manager status

Result: "Enable Wi-Fi" option is OFF

Cyrus Lien (cyruslien) on 2017-05-12
description: updated
tags: added: verification-done-xenial
Cyrus Lien (cyruslien) on 2017-05-15
Changed in oem-priority:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.2.6-0ubuntu0.16.04.3

---------------
network-manager-applet (1.2.6-0ubuntu0.16.04.3) xenial-proposed; urgency=medium

  * debian/patches/git_fix_wrong_status_for_wireless_toggle.patch
    * Fix wrong status for wireless toggle (LP: #1641889)

 -- Ken VanDine <email address hidden> Tue, 09 May 2017 09:52:11 -0400

Changed in network-manager-applet (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.