Ubuntu

can't remove nm-applet

Reported by John Levin on 2007-05-16
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Network Manager Applet
Expired
Wishlist
network-manager-applet (Ubuntu)
Wishlist
Unassigned

Bug Description

Nether the left nor right-click menus offer an option to move or close the nm-applet

Sero (sero4linux) wrote :

I second the request for a dedicated "remove from panel" option in the context menu of nm-applet. All the other applets in my panel have this option! On a related note, the "double" context menu of nm-applet (one dialogue for left-klick, on for right-click) is very confusing IMHO and doesn't make any sense at all. Maybe a discussing with upstream about a little UI redesign could improve this?

What I consider a "normal" behaviour of the applet is:
left click -> show information: available networks (incl. possibility to choose one as current nm-applet does - but without the options below the seperater); show the connections infos here, too.
right click -> all the configure options go here + "remove from panel"

Alexander Sack (asac) wrote :

nm-applet has now its own source package ... reassigning accordingly.

 - Alexander

Pedro Villavicencio (pedro) wrote :

Thanks for your report, well it's on the notification area so if you want to move it you have to move the notification area instead. Setting this as wishlist (remove part) to be evaluated later by the developers, thanks.

Changed in network-manager-applet:
importance: Undecided → Wishlist
status: New → Confirmed
Travis Raphael Miller (raphtee) wrote :

Given that the nm-applet is very much broken (see the numerous bugs regarding this point), it is sonewhat important that one be able to remove it from the panel.

kaydub (kevwilliams) wrote :

Has this option been added yet? I can't seem to find anywhere to remove this applet from my notification area and the icon is always there and I don't even use it.

Maarten (maarten-faddegon) wrote :

Today nm-applet was started twice on startup. I was unable to remove one of the applets using the gui. To solve the probem I did the following:

killall nm-applet
nm-applet &

Forwarded upstream.

Changed in network-manager-applet:
status: Confirmed → Triaged

Upstream needs info, please answer them upstream since you are interested in the feature (http://bugzilla.gnome.org/show_bug.cgi?id=572447):

>>>
nm-applet is started with XDG autolaunching; as such there should never be more
than one present at any given time. What version of NetworkManager is this?
If nm-applet isn't wanted, it can also be uninstalled.
<<<

>>>
Besides; if nm-applet isn't running, there's no ability to control the network
or get IP configuration or status.
<<<

Thanks.

Alexander Sack (asac) wrote :

there is no need to close nm-applet. Really.

Changed in network-manager-applet:
status: Triaged → Won't Fix
Changed in network-manager-applet:
status: Unknown → Incomplete
PhilippeDePass (depassp) wrote :

FYI: To remove nm-applet, disable it from the list of startup programs:
System->Preferences->Startup Applications
Remove "Network Manager", which originally should run the command "nm-applet --sm-disable"

Simon Butler (mardytam) wrote :

@Alexander Sack
>> there is no need to close nm-applet. Really.

To close, perhaps, but there is certainly a need to hide it. On systems with wireless network connections, the icon displays useful, time varying, information (signal strength) and useful functionality (the ability to switch network). Neither is useful to those with a wired connection, in which case the icon displays relatively unuseful, often constant, information (a plug-socket and cable) and the need to switch network is very, very rarely used. Even a wired user does wish to change configuration, this corner case is better served by the user going to System->Preferences->Network than using valuable panel space.

Furthermore, superfluous icons reduce the usability of the panel by making important ones harder to find due to clutter. Also, the option to hide an icon in the notification area is not unheard of, see mail-notification and gnome-do, for example. If necessary, for ease of implementation, this option need not necessarily be exposed in the UI and might merely be available in gconf, since it serves to address a corner case.

As such, I propose a change in status to "Confirmed" since this is demonstrably a valid wishlist bug request.

Changed in network-manager-applet (Ubuntu):
status: Won't Fix → Confirmed
Changed in network-manager-applet:
status: Incomplete → Invalid
Changed in network-manager-applet:
importance: Unknown → Wishlist
status: Invalid → Expired

Removing the applet from the panel won't be possible unless by killing nm-applet.

To stop it from being loaded at the start of a session, you can go in Startup Applications and uncheck or delete the entry for nm-applet.

Furthermore, in recent versions of Ubuntu the applet should disappear by itself when NetworkManager isn't running.

I think that the three above methods will cater to most use cases. Marking as Won't Fix. Even as a wishlist bug, this would be better handled directly upstream in the linked bug.

Changed in network-manager-applet (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.