No wifi adapter present in Gnome after upgrade to 0.96-0ubuntu0.18.10.2

Bug #1825206 reported by Marc Cornellà on 2019-04-17
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
netcfg (Ubuntu)
Medium
Unassigned
netplan.io (Ubuntu)
High
Mathieu Trudel-Lapierre
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

[Impact]
Ubuntu users installing from the d-i installer (mini.iso) to set up a desktop, as well as users with complex setups for netplan, managed by both networkd and NetworkManager in multiple files.

[Test case]
1) Install ubuntu from mini.iso.
2) Configure the system normally through the installer up to package selection.
3) Add GNOME Desktop to package selection and continue install.
4) After reboot and logging in, check whether the network device configured (wired or wifi) is showing in the GNOME Shell network drop-down at the top of the screen.

Without the patch, networkd manages the interface and thus it is ignored by NM, and doesn't show in GNOME Shell.

With the fix, NetworkManager manages the interface, it is brought up correctly and shows in GNOME Shell.

[Regression potential]
This fixes a regression in updates for bionic & cosmic, and a regression that was present in Disco at release time. Since the default renderer effectively changes in this case if there are multiple configuration files listing a different global renderer (the last one configured will be the global default); care should be taken to make sure the interfaces are correctly brought up at boot time.

This really only affects very specific desktop installs, since they may have both NetworkManager and systemd installed from the beginning. The default global renderer is always networkd, so the impact of this is limited to systems where both: multiple YAML configuration files are used with netplan; and both NetworkManager and networkd are used as renderer for different network devices. This tends to only happen if people have installed from the mini.iso image or if they have made the conscious decision to write multiple YAML files and use different renderers for different devices.

---

Ubuntu release: 18.10 (cosmic)

I verified this is the culprit after a downgrade to 0.42.2. When I go to the Wifi settings of gnome-control-center I get a 'wifi adapter not found' message, despite my card appearing in `lspci` and the wifi interface appearing in ifconfig.

My wifi adapter is an Intel Advanced-N 6200, if that is of any help. I can provide more details if needed.

EDIT: I've verified that I can add my wifi credentials to /etc/netplan/01-netcfg.yml and after a reboot the wifi connects successfully. The only thing not working is the Gnome integration.

EDIT 2: More details:
gnome-shell version: 3.30.2-0ubuntu1.18.10.1
gnome-control-center version: 1:3.30.2-1ubuntu0.18.10.2
---
ProblemType: Bug
ApportVersion: 2.20.10-0ubuntu13.2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.10
Package: netplan.io 0.96-0ubuntu0.18.10.2 [origin: unknown]
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.18.0-17.18-generic 4.18.20
Tags: third-party-packages cosmic
Uname: Linux 4.18.0-17-generic x86_64
UnreportableReason: Este no es un paquete oficial de Ubuntu. Desinstale cualquier paquete de terceros e inténtelo de nuevo.
UpgradeStatus: Upgraded to cosmic on 2019-03-03 (46 days ago)
UserGroups: adm cdrom dialout dip docker lpadmin plugdev sambashare sudo
_MarkForUpload: True

description: updated
description: updated
Changed in netplan.io (Ubuntu):
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
tags: added: regression-update
Sebastien Bacher (seb128) wrote :

Could you add your journalctl log from a boot with the old and one with the new version?

Steve Langasek (vorlon) wrote :

> EDIT: I've verified that I can add my wifi credentials
> to /etc/netplan/01-netcfg.yml and after a reboot the wifi
> connects successfully. The only thing not working is the
> Gnome integration.

Prior to this edit, what were the contents of /etc/netplan?

Steve Langasek (vorlon) wrote :

You also specifically mention /etc/netplan/01-netcfg.yaml, which is only meant to be created by netcfg when using the di-based server install ISO. How did you install this system?

Please run apport-collect 1825206, which will update this bug with a variety of information about your system.

Changed in netplan.io (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected cosmic third-party-packages
description: updated

apport information

apport information

Marc Cornellà (mcornella) wrote :

> Prior to this edit, what were the contents of /etc/netplan?

These were the files in /etc/netplan:

- /etc/netplan/01-network-manager-all.yaml:
# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager

- /etc/netplan/01-netcfg.yaml:
# This file describes the network interfaces available on your system
# For more information, see netplan(5).
network:
  version: 2
  renderer: networkd
  wifis:
    wlp2s0:
      dhcp4: yes
      access-points:
        WIFI_AP:
          password: WIFI_PASSWORD

There was already a WiFi AP in netcfg.yaml, I only added another one.

> You also specifically mention /etc/netplan/01-netcfg.yaml, which is only meant to be created by netcfg when using the di-based server install ISO. How did you install this system?

I installed Ubuntu cosmic via the netboot ISO. It's possible that the installer set up this file since the AP in it was the one I used for the installation, and a `dpkg -S 01-netcfg.yaml` doesn't come up with any responsible packages.

Marc Cornellà (mcornella) wrote :

I also cloned the gnome-control-center project and built it with debugging statements, and found that the found wifi device isn't chosen because it appears as unmanaged:

it returns here because `nm_device_get_managed(device)` returns false:
https://gitlab.gnome.org/GNOME/gnome-control-center/blob/3.30.2/panels/network/cc-wifi-panel.c#L156-157

the output of `nmcli` also shows the device is unmanaged. Perhaps it is so because netplan has taken over?

PS. I can't install netplan 0.96 anymore, was it pulled?

Marc Cornellà (mcornella) wrote :
Marc Cornellà (mcornella) wrote :

> You also specifically mention /etc/netplan/01-netcfg.yaml, which is only meant to be created by netcfg when using the di-based server install ISO.

Ah, this solved it. I removed the netcfg file and the thing works again with the newer version (I downloaded it from Launchpad). Thanks for your help!

Brian Murray (brian-murray) wrote :

This is independent of the the netplan.io issue but I'm curious to know if you have '/var/log/installer/media-info' on your installed system. If you do could you please provide the contents of it? Thanks!

Marc Cornellà (mcornella) wrote :

I don't havae that particular file no, here's the tree of that directory:

/var/log/installer/
├── cdebconf
│   ├── questions.dat
│   └── templates.dat
├── hardware-summary
├── initial-status.gz
├── lsb-release
├── partman
├── status
└── syslog

1 directory, 8 files

Steve Langasek (vorlon) wrote :
Download full text (4.4 KiB)

> I installed Ubuntu cosmic via the netboot ISO.

That explains, thanks. The netboot ISO uses d-i, so will create this file at install time.

And I see that netcfg/finish-install.d/55netcfg-copy-config also has handling for
/etc/netplan/01-network-manager-all.yaml; so BOTH files are created with netcfg, which I don't think is the expected behavior. At least, if we are creating a global file declaring that the network should be managed by NM, the generated /etc/netplan/01-netcfg.yaml should ALSO direct that the configured interface is managed by NM, NOT by networkd.

So with a VM installed using cosmic d-i mini ISO, I get:

# cat /etc/netplan/01-network-manager-all.yaml
# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager
# cat /etc/netplan/01-netcfg.yaml
# This file describes the network interfaces available on your system
# For more information, see netplan(5).
network:
  version: 2
  renderer: networkd
  ethernets:
    ens3:
      dhcp4: yes
# nmcli d
DEVICE TYPE STATE CONNECTION
ens3 ethernet connected Wired connection 1
lo loopback unmanaged --
$ networkctl list
WARNING: systemd-networkd is not running, output will be incomplete.

IDX LINK TYPE OPERATIONAL SETUP
  1 lo loopback n/a unmanaged
  2 ens3 ether n/a unmanaged

2 links listed.
#

With netplan 0.40.2.2, if I rename /etc/netplan/01-netcfg.yaml to /etc/netplan/02-netcfg.yaml, now I see:

# mv /etc/netplan/01-netcfg.yaml /etc/netplan/02-netcfg.yaml
# netplan --debug apply
** (generate:2203): DEBUG: 13:13:12.964: Processing input file /etc/netplan/01-network-manager-all.yaml..
** (generate:2203): DEBUG: 13:13:12.964: starting new processing pass
** (generate:2203): DEBUG: 13:13:12.964: Processing input file /etc/netplan/02-netcfg.yaml..
** (generate:2203): DEBUG: 13:13:12.964: starting new processing pass
** (generate:2203): DEBUG: 13:13:12.964: ens3: setting default backend to 1
** (generate:2203): DEBUG: 13:13:12.964: Generating output files..
** (generate:2203): DEBUG: 13:13:12.964: NetworkManager: definition ens3 is not for us (backend 1)
(generate:2003): GLib-DEBUG: 13:13:12.964: posix_spawn avoided (fd close requested)
DEBUG: netplan generated networkd configuration exists, restarting networkd
DEBUG: no netplan generated NM configuration exists
DEBUG:ens3 not found in {}
DEBUG:Merged config:
network:
  bonds: {}
  bridges: {}
  ethernets:
    ens3:
      dhcp4: true
  vlans: {}
  wifis: {}

DEBUG:Skipping non-physical interface: lo
DEBUG:device ens3 operstate is up, not changing
DEBUG:{}
DEBUG:netplan triggering .link rules for lo
DEBUG:netplan triggering .link rules for ens3
# service NetworkManager restart # (done in order to force NM to see the config changes, since netplan did not restart it on netplan apply)
# nmcli d
DEVICE TYPE STATE CONNECTION
ens3 ethernet unmanaged --
lo loopback unmanaged --
$ networkctl list
IDX LINK TYPE OPERATIONAL SETUP
  1 lo loopback n/a unmanaged
  2 ens3 ether routable co...

Read more...

Changed in netplan.io (Ubuntu):
status: Incomplete → Triaged
Changed in netcfg (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: id-5cba599f9455ed5eaa1d6601
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netplan.io - 0.96-0ubuntu5

---------------
netplan.io (0.96-0ubuntu5) eoan; urgency=medium

  * debian/patches/git_revert_explicit_renderer_def_ebc212a.patch: revert
    commit ebc212a: make renderer values explicit at the end of each parsing
    pass; it breaks "default" renderer behavior when multiple files may set
    a global renderer and expect the last to take effect globally.
    (LP: #1825206)
  * debian/patches/git_reorg_netdef_validation_181b583.patch: correct the
    fallout from the above change: validate netdefs in a single pass at the
    very end of parsing, once we know which is the applicable renderer. This
    makes sure tunnels get validated correctly.

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 26 Apr 2019 15:18:13 -0400

Changed in netplan.io (Ubuntu):
status: Triaged → Fix Released

Hello Marc, or anyone else affected,

Accepted netplan.io into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.96-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in netplan.io (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed verification-needed-disco
Brian Murray (brian-murray) wrote :

Hello Marc, or anyone else affected,

Accepted netplan.io into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.96-0ubuntu0.18.10.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in netplan.io (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed-cosmic
Brian Murray (brian-murray) wrote :

Hello Marc, or anyone else affected,

Accepted netplan.io into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.96-0ubuntu0.18.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in netplan.io (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Marc Cornellà (mcornella) wrote :

I can confirm that Gnome now displays the device even if 01-netcfg.yaml exists.

I attach a screenshot of the GNOME Settings screen, which now shows the wifi adapter and the available networks. The other surprising thing is that a new network appears with the name
netplan-wlp2s0-WIFIAP, due to the fact that it is still set up in 01-netcfg.yaml. If I remove
the settings of this wifi from the netcfg file this network disappears.

All in all, the patch does its job successfully, and I can say that I'm a happy customer.
Thanks!

PS. If it's of any relevance, I tested the update from disco.

Marc;

Thanks for the quick turnaround testing this. We don't always have bug reporters going back to test the changes once we upload changes to -proposed. It's much appreciated.

I'll take care of testing this on bionic and cosmic.

Marking verification-done-disco since the original bug reporter verfied that the bug is now fixed.

tags: added: verification-done-disco
removed: verification-needed-disco

Verification-done for cosmic:

I've installed from mini.iso to get an Ubuntu Desktop; both 01-netcfg.yaml and 01-network-manager-all.yaml are present on disk as expected. After installing netplan.io 0.96-0ubuntu0.18.10.3 I can see the netplan-* connection from the installer in the Gnome Shell dropdown for the network, and in gnome-system-settings.

tags: added: verification-done-cosmic
removed: verification-needed-cosmic

Verification-done for bionic:

After installing netplan 0.96-0ubuntu0.18.04.4 the wireless network on my Thinkpad X230 is again available in Gnome-Shell's network drop-down (you see the wifi icon); and 'nmcli dev' correctly reports wlp3s0 being connected to a netplan-XXXXX connection.

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :
Download full text (4.5 KiB)

This bug was fixed in the package netplan.io - 0.96-0ubuntu0.18.04.4

---------------
netplan.io (0.96-0ubuntu0.18.04.4) bionic; urgency=medium

  * debian/patches/git_revert_explicit_renderer_def_ebc212a.patch: revert
    commit ebc212a: make renderer values explicit at the end of each parsing
    pass; it breaks "default" renderer behavior when multiple files may set
    a global renderer and expect the last to take effect globally.
    (LP: #1825206)
  * debian/patches/git_reorg_netdef_validation_181b583.patch: correct the
    fallout from the above change: validate netdefs in a single pass at the
    very end of parsing, once we know which is the applicable renderer. This
    makes sure tunnels get validated correctly.

netplan.io (0.96-0ubuntu0.18.04.3) bionic; urgency=medium

  * debian/patches/disable-networkd-tunnels-ipip-gre.patch: disable IPIP and
    GRE tunnel tests; those appear to be broken because neither the kernel nor
    networkd bring up the device automatically as in other releases.

netplan.io (0.96-0ubuntu0.18.04.2) bionic; urgency=medium

  * d/p/0001-Partially-revert-the-change-for-enabling-systemd-net.patch:
    Partially revert changes to networkd jobs ordering: leave systemd-networkd
    enabled in multi-user.target instead of network-online.target, as in some
    minimal setups there might be no job requiring network-online.target,
    whereas the natural target to reach for booting is multi-user.target.
    (LP: #1821867)

netplan.io (0.96-0ubuntu0.18.04.1) bionic; urgency=medium

  * Backport netplan.io 0.96 to 18.04.
  * debian/patches/glib_changes.patch: Patch tests to work again on older GLib.
  * debian/control: adjust Depends for bionic / re-add nplan package.

netplan.io (0.96-0ubuntu1) disco; urgency=medium

  * New upstream release 0.96.
    - Moved netplan-wpa@ services to earlier at boot (LP: #1819014)
    - Restart services when unconfiguring (LP: #1811868)
    - Use the .nmconnection extension for NM keyfiles (LP: #1817655)
    - Fixed integration tests runner to correctly report failures
    - Enforce integrity for use-routes in networkd backend.
    - Ensure terminal state at end of test (LP: #1817660)
    - Various small test fixes.
    - Fix typos in documentation.
  * debian/control: Update Maintainer for ubuntu upload.

netplan.io (0.95-2) unstable; urgency=medium

  * Set Priority to optional (Closes: #920327).

netplan.io (0.95-1) unstable; urgency=medium

  * New upstream release.
  * Update autopkgtests from the upstream.
  * Add debian/watch following GitHub releases.
  * Add Homepage (Closes: #917233).

netplan.io (0.95) disco; urgency=medium

  * New upstream release:
    - Added support for WPA Enterprise / 802.1x authentication (LP: #1739578)
    - Added support for setting up IP tunnels; supporting the types: ipip,
      gretap, VTI, ISATAP (NetworkManager only), sit, gre, ipip6 and ip6ip6.
      + Fixes sit (ipv6) tunnels using Hurricane Electric (LP: #1799487)
    - Add support to override networkd UseMTU setting (LP: #1807273)
    - Generate output files in dependency order
    - Refactored unit and integration tests, along with various cleanups.
    - Add DHCP overrides to control ...

Read more...

Changed in netplan.io (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for netplan.io has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :
Download full text (4.0 KiB)

This bug was fixed in the package netplan.io - 0.96-0ubuntu0.18.10.3

---------------
netplan.io (0.96-0ubuntu0.18.10.3) cosmic; urgency=medium

  * debian/patches/git_revert_explicit_renderer_def_ebc212a.patch: revert
    commit ebc212a: make renderer values explicit at the end of each parsing
    pass; it breaks "default" renderer behavior when multiple files may set
    a global renderer and expect the last to take effect globally.
    (LP: #1825206)
  * debian/patches/git_reorg_netdef_validation_181b583.patch: correct the
    fallout from the above change: validate netdefs in a single pass at the
    very end of parsing, once we know which is the applicable renderer. This
    makes sure tunnels get validated correctly.

netplan.io (0.96-0ubuntu0.18.10.2) cosmic; urgency=medium

  * d/p/0001-Partially-revert-the-change-for-enabling-systemd-net.patch:
    Partially revert changes to networkd jobs ordering: leave systemd-networkd
    enabled in multi-user.target instead of network-online.target, as in some
    minimal setups there might be no job requiring network-online.target,
    whereas the natural target to reach for booting is multi-user.target.
    (LP: #1821867)

netplan.io (0.96-0ubuntu0.18.10.1) cosmic; urgency=medium

  * Backport netplan.io 0.96 to 18.10.
  * debian/patches/glib_changes.patch: Patch tests to work again on older GLib.
  * debian/control: adjust Depends for cosmic / re-add nplan package.

netplan.io (0.96-0ubuntu1) disco; urgency=medium

  * New upstream release 0.96.
    - Moved netplan-wpa@ services to earlier at boot (LP: #1819014)
    - Restart services when unconfiguring (LP: #1811868)
    - Use the .nmconnection extension for NM keyfiles (LP: #1817655)
    - Fixed integration tests runner to correctly report failures
    - Enforce integrity for use-routes in networkd backend.
    - Ensure terminal state at end of test (LP: #1817660)
    - Various small test fixes.
    - Fix typos in documentation.
  * debian/control: Update Maintainer for ubuntu upload.

netplan.io (0.95-2) unstable; urgency=medium

  * Set Priority to optional (Closes: #920327).

netplan.io (0.95-1) unstable; urgency=medium

  * New upstream release.
  * Update autopkgtests from the upstream.
  * Add debian/watch following GitHub releases.
  * Add Homepage (Closes: #917233).

netplan.io (0.95) disco; urgency=medium

  * New upstream release:
    - Added support for WPA Enterprise / 802.1x authentication (LP: #1739578)
    - Added support for setting up IP tunnels; supporting the types: ipip,
      gretap, VTI, ISATAP (NetworkManager only), sit, gre, ipip6 and ip6ip6.
      + Fixes sit (ipv6) tunnels using Hurricane Electric (LP: #1799487)
    - Add support to override networkd UseMTU setting (LP: #1807273)
    - Generate output files in dependency order
    - Refactored unit and integration tests, along with various cleanups.
    - Add DHCP overrides to control route usage and default metric for DHCP
      routes. (LP: #1776228)
    - Mitigate against bad matching on devices behind bonds then they share
      the same MAC from a physical interface. (LP: #1804861)
    - Added snapcraft.yaml.

netplan.io (0.90.1) disco; urgency=medium

  * Do ...

Read more...

Changed in netplan.io (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netplan.io - 0.96-0ubuntu4.1

---------------
netplan.io (0.96-0ubuntu4.1) disco; urgency=medium

  * debian/patches/git_revert_explicit_renderer_def_ebc212a.patch: revert
    commit ebc212a: make renderer values explicit at the end of each parsing
    pass; it breaks "default" renderer behavior when multiple files may set
    a global renderer and expect the last to take effect globally.
    (LP: #1825206)
  * debian/patches/git_reorg_netdef_validation_181b583.patch: correct the
    fallout from the above change: validate netdefs in a single pass at the
    very end of parsing, once we know which is the applicable renderer. This
    makes sure tunnels get validated correctly.

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 26 Apr 2019 15:18:46 -0400

Changed in netplan.io (Ubuntu Disco):
status: Fix Committed → Fix Released

Hello Marc, or anyone else affected,

Accepted netplan.io into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.97-0ubuntu1~19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in netplan.io (Ubuntu Disco):
status: Fix Released → Fix Committed
tags: added: verification-needed verification-needed-disco
removed: verification-done-disco
Changed in netplan.io (Ubuntu Cosmic):
status: Fix Released → Fix Committed
tags: added: verification-needed-cosmic
removed: verification-done-cosmic
Adam Conrad (adconrad) wrote :

Hello Marc, or anyone else affected,

Accepted netplan.io into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.97-0ubuntu1~18.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in netplan.io (Ubuntu Bionic):
status: Fix Released → Fix Committed
tags: added: verification-needed-bionic
removed: verification-done-bionic
Adam Conrad (adconrad) wrote :

Hello Marc, or anyone else affected,

Accepted netplan.io into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/netplan.io/0.97-0ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

This is still verification-done; has not changed in releases: this SRU is a backport that includes the same upstream patch as what was previously cherry-picked in the previous round of SRUs; hence it appearing again in changelog.

tags: added: verification-done-bionic verification-done-cosmic verification-done-disco
removed: verification-needed verification-needed-bionic verification-needed-cosmic verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netplan.io - 0.97-0ubuntu1~19.04.1

---------------
netplan.io (0.97-0ubuntu1~19.04.1) disco; urgency=medium

  * Backport netplan.io 0.97 to 19.04. (LP: #1828299)

netplan.io (0.97-0ubuntu1) eoan; urgency=medium

  * New upstream release: 0.97
    - networkd: force bringing up devices with no IP addresses (LP: #1763608)
    - Reworked renderer choosing to avoid regression in default renderer when
      multiple files specify it globally (LP: #1825206)
    - Fixed networkd activation. (LP: #1821867)
  * Drop all patches; they are included in the upstream release.

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 09 May 2019 10:19:13 -0400

Changed in netplan.io (Ubuntu Disco):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netplan.io - 0.97-0ubuntu1~18.10.1

---------------
netplan.io (0.97-0ubuntu1~18.10.1) cosmic; urgency=medium

  * Backport netplan.io 0.97 to 18.10. (LP: #1828299)
  * Keep debian/patches/glib_changes.patch: Make sure tests work on older GLib.

netplan.io (0.97-0ubuntu1) eoan; urgency=medium

  * New upstream release: 0.97
    - networkd: force bringing up devices with no IP addresses (LP: #1763608)
    - Reworked renderer choosing to avoid regression in default renderer when
      multiple files specify it globally (LP: #1825206)
    - Fixed networkd activation. (LP: #1821867)
  * Drop all patches; they are included in the upstream release.

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 09 May 2019 11:29:56 -0400

Changed in netplan.io (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netplan.io - 0.97-0ubuntu1~18.04.1

---------------
netplan.io (0.97-0ubuntu1~18.04.1) bionic; urgency=medium

  * Backport netplan.io 0.97 to 18.04. (LP: #1828299)
  * Keep patches specific to 18.04 support:
    - glib_changes.patch: fixes for older GLib version
    - disable-networkd-tunnels-ipip-gre.patch: disable tests for unsupported
      tunnel types (ipip and gre) in the 18.04 version of systemd-networkd.

netplan.io (0.97-0ubuntu1) eoan; urgency=medium

  * New upstream release: 0.97
    - networkd: force bringing up devices with no IP addresses (LP: #1763608)
    - Reworked renderer choosing to avoid regression in default renderer when
      multiple files specify it globally (LP: #1825206)
    - Fixed networkd activation. (LP: #1821867)
  * Drop all patches; they are included in the upstream release.

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 09 May 2019 13:11:53 -0400

Changed in netplan.io (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers