maximus does not give default focus to newly started apps in combination with efl launcher

Bug #528887 reported by Oliver Grawert on 2010-02-27
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Netbook Launcher EFL
Medium
Unassigned
netbook-launcher-efl (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: maximus

on ARM boards using the efl launcher maximus doesnt give the focus to newly popping apps by defalt so that one has to click the new fullscreen window before being able to do anything in the app.

Oliver Grawert (ogra) on 2010-02-27
tags: added: armel
Changed in maximus (Ubuntu Lucid):
importance: Undecided → Medium
milestone: none → ubuntu-10.04-beta-2
Paul Larson (pwlars) wrote :

I'm also seeing this just about every time on the most recent images. Earlier on, I was seeing stuff more like was in bug #522858. However, I didn't yet have a consistent way to reproduce it. Have you experienced that (possibly related?) one as well?

Changed in maximus (Ubuntu Lucid):
status: New → Triaged
Tobin Davis (gruemaster) wrote :

Still reliably reproducible on Beta 1. Just launch a terminal window. You need to click on the console once it is running for it to gain focus.

tags: added: iso-testing
Dave Martin (dave-martin-arm) wrote :

My experience of this one is that it may not be 100% reproducible (but I nonetheless often see it when opening a terminal). It feels like a possible race condition or similar.

Dave Martin (dave-martin-arm) wrote :

@Paul should we suggest to iso-testers that they retry opening the terminal a few times, including a reboot, before certifying that the problem is not there?

Paul Larson (pwlars) wrote :

yes, both problems are most certainly still present but don't necessarily present every time an app is opened. I've also observed this one with other things, such as apport

Tobin Davis (gruemaster) wrote :

I am able to reproduce the issue where opening a terminal window doesn't get focus 100% of the time, and also able to recreate the issue where launching a terminal doesn't always go full screen about 30% of the time.

Tom Verdaat (tom-verdaat) wrote :

I think I have the same problem in Lucid Beta1:

Sometimes windows open maximized and on top, but do not seem to have focus. This means the "title bar" part in the UNE top bar does not display the name of the newly raised window, but of the one previously having focus. If you click the close button (e.g. the X on the right), the wrong windown gets closed (the one below having focus, not the one on top that you're looking at). Clicking no the application window after it was raised then does give it focus after all, and consequently behaves as expected.

I had this issue a couple of days ago when double-clicking on images in Nautilus. It raises a maximized Eye Of Gnome window but the title bar keeps saying Nautilus. If I push the close button I close the Nautilus window, not EOG. Unfortunately I seem to be unable to reproduce this issue right now.

Another one I do still have and am able to reproduce consistently right now is with "Getting Things Gnome". I have enabled its tray icon. If the application is minimized to tray, I click on the tray icon and click on "Display main window" (roughly translated from Dutch) it opens a new GTG window, maximized, on top, but not focussed. The title bar still refers to the window that had focus before opening the GTG window.

This issue is quite confusing, especially for novice users. Before you know it they start complaining about "disappearing windows" and turn their back on Ubuntu. Also, let me know if this is not the same bug as reported earliers so I can repost this as a seperate bug.

Tobin Davis (gruemaster) wrote :

Example screenshot of terminal window not maximizing. Text entry not available in this terminal window, but menu's work.

Tom Verdaat (tom-verdaat) wrote :

This screenshot shows what happens in my case. I was using Evolution and then opened Getting Things GNOME through its tray icon. The screen pops up, but the title bar retains its focus on Evolution.

Martin Pitt (pitti) on 2010-04-09
Changed in maximus (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
Steve Langasek (vorlon) on 2010-04-16
Changed in maximus (Ubuntu Lucid):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

After having a look. This issue doesn't seems to be related to maximus but netbook-launcher-efl.

You can try that:
- create a session without maximus started (the 2D session doesn't by default)
- try to launch some apps in netbook-launcher-efl

-> you obtain some applications that aren't focused everytime.

Retargetting the bug to the right persons.

Changed in maximus (Ubuntu Lucid):
assignee: Didier Roche (didrocks) → Jamie Bennett (jamiebennett)
affects: maximus (Ubuntu Lucid) → netbook-launcher-efl (Ubuntu Lucid)
Changed in netbook-launcher-efl (Ubuntu Lucid):
assignee: Jamie Bennett (jamiebennett) → Didier Roche (didrocks)
assignee: Didier Roche (didrocks) → Jamie Bennett (jamiebennett)
affects: maximus → launch-lite-proj
Didier Roche (didrocks) wrote :

Stupid ajax ^^
I guess Jamie will have a better overview in the n-l-efl code than I, but it's quite clear looking at the maximus code that maximus isn't triggered by a new focused app.

Jamie Bennett (jamiebennett) wrote :

Re assigning to mterry as he is looking after the n-l-efl code now.

Changed in netbook-launcher-efl (Ubuntu Lucid):
assignee: Jamie Bennett (jamiebennett) → Michael Terry (mterry)
Tobin Davis (gruemaster) wrote :

Another issue that we (Paul Larson and I) see is that occasionally after launching gnome-terminal, the current working directory will be /usr/share/icons/Humanity/apps/48 as opposed to ~/. This happens ~ 20% of the time for me.

Paul Larson (pwlars) wrote :

The bug mentioned in comment #13 has been split off into bug #568630

Dave Martin (dave-martin-arm) wrote :

I just got a terminal starting up in /usr/share/icons/hicolor/scalable/apps

That's probably similar to or the same as Tobin's issue from post #13

Michael Terry (mterry) wrote :

Fixed in trunk by letting the window manager know of the timestamps for user events (bridging the EFL->GDK gap). Will shortly provide a debdiff for lucid.

Changed in launch-lite-proj:
importance: Undecided → Medium
status: New → Fix Committed
Michael Terry (mterry) wrote :

Here's a patch for lucid. Applied it directly to source, because package doesn't use a patch system.

Changed in netbook-launcher-efl (Ubuntu Lucid):
assignee: Michael Terry (mterry) → nobody
Alexander Sack (asac) wrote :

uploaded package with fix to my armel1 ppa: https://edge.launchpad.net/~asac/+archive/armel1/+packages

Changed in netbook-launcher-efl (Ubuntu Lucid):
status: Triaged → Fix Committed
Oliver Grawert (ogra) wrote :

confirming the fix works with asac's PPA packge from above

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netbook-launcher-efl - 0.2.6-0ubuntu2

---------------
netbook-launcher-efl (0.2.6-0ubuntu2) lucid; urgency=low

  [ Michael Terry <email address hidden> ]
  * src/launcher/win.c:
    - Backported patch from trunk to fix focus for newly launched apps.
      LP: #528887

  [ Alexander Sack <email address hidden> ]
  * src/launcher/places_storage.c:
    - fix LP: #558648 - netbook-launcher-efl occasionally displays cryptic
      error messages; we display proper error message rather than error uuid
 -- Alexander Sack <email address hidden> Mon, 26 Apr 2010 11:39:05 +0200

Changed in netbook-launcher-efl (Ubuntu Lucid):
status: Fix Committed → Fix Released
Paul Larson (pwlars) wrote :

This seems to be working very well for me. I've been unable to reproduce this bug since installing it.

Michael Terry (mterry) on 2010-07-01
Changed in launch-lite-proj:
status: Fix Committed → Fix Released
Praetor77 (geramses) wrote :

I have this issue in Lucid 10.04 LTS UNR edition. I am running on an Asus 1005HA.
Every time I open a PNG file by double click (invokes Eye of Gnome), the window is not activated, so the title bar keeps saying Nautilus. If I push the close button I close the Nautilus window, just like in commentary #7. However, in my case, this happens EVERY time.

Secondly, the Eye Of Gnome window will not automatically maximize about 30% of times.

netbook-launcher-efl -V
Version: 0.2.6

Praetor77 (geramses) wrote :

Oh, yeah, I only see this behaviour with Eye Of Gnome windows...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers