Delay on boot with wireless network

Bug #105414 reported by stefanokan on 2007-04-11
6
Affects Status Importance Assigned to Milestone
ndiswrapper (Ubuntu)
Medium
Unassigned

Bug Description

I have installed Feisty Beta and all last updates.
The hardware is a laptop HP nx6310 with Broadcom 4311 wireless device.
I have installed ndiswrapper version 1.41 and extracted windows driver for my card.
Data is WPA2 encripted. All is working correct.
The problem is at boot.
It is delaying roughly 30-40 seconds.
If i cut the wlan0 in /etc/network/interfaces then the boot is fast.
Here is my /etc/network/interfaces:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

I want to specify that in previous edgy eft version i did't experienced this problem.

max69 (maxime-bely) wrote :

Exactly the same here

Hi, did you have same problem with Feisty Fawn final version?
I loaded all the last updates so i think should be the same version as the
final but the problem is still the same. No answers by launchpad.
Bye.

2007/4/25, max69 <email address hidden>:
>
> Exactly the same here
>
> --
> Delay on boot with wireless network
> https://bugs.launchpad.net/bugs/105414
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Yes feisty final version. I am also using ndiswrapper for broadcom 4306
chipset. This problem is very annoying because I cannot fix it through
/etc/network/interfaces as I need to automount network folders on startup.

Albert Bicchi (bicchi) wrote :

I confirm this bug on Feisty. I am using ndiswrapper on a Broadcom BCM4309 rev 02 If i uncomment my wireless section in this case (wlan0) from /etc/network/interfaces the machine boots fast but my wireless card is not detected. I guess the question is, how do I force it not to try obtaining an IP address from my wireless during boot time? The problem is that it just times out then continues booting without a network detected on it.

I think this bug is not related to ndiswrapper but to the script found here: /etc/rcS.d/S40networking
Look at the TIMEOUT section been established around line 20. Is there a way to "blacklist" the card so that it skips this step? The key is to only blacklist it from this step alone.

Here is my /etc/network/interfaces:
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp

stefanokan (paoli-stefano) wrote :

I found a solution that appears as a workaround.
I red this post by Tormod Volden :
https://bugs.launchpad.net/ubuntu/+source/netbase/+bug/102675
and tried this:
sudo update-rc.d -f networking remove
Than rename the script networking inside /etc/init.d/ (e.g /etc/init.d/networking.bak)
Than reboot.
Than i had no more delay but the wireless networks did not work.
Make a backup of etc/network/interfaces (e.g. copying as etc/network/interfaces.bak)
Than rename /etc/init.d/networking.bak in /etc/init.d/networking
Give command: sudo update-rc.d networking multiuser
Rename etc/network/interfaces.bak in etc/network/interfaces
Reboot.
Now you should have no delay on boot and the wireless network on.
I did not understand why, but it works.
Good Luck.

I've seen the same behaviour on Hardy. Not only on wireless interfaces. If I start my laptop without any network connection at all the boot time is significantly higher.

Willem Ligtenberg (wligtenberg) wrote :

Other people have confirmed this bug.
A possible workaround has been posted.

Shimi Chen (shimi-chen) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect 105414 and any other logs that are relevant for this particular issue.

affects: ubuntu → ndiswrapper (Ubuntu)
Changed in ndiswrapper (Ubuntu):
status: Confirmed → Incomplete
Changed in ndiswrapper (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

[Expired for ndiswrapper (Ubuntu) because there has been no activity for 60 days.]

Changed in ndiswrapper (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers