cpu race between nautilus, hud- and unity-service

Bug #965493 reported by Sam_ on 2012-03-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Invalid
High
Unassigned
Nautilus
Fix Released
High
Unity
Invalid
High
Unassigned
indicator-appmenu (Ubuntu)
High
desrt
nautilus (Ubuntu)
High
Unassigned

Bug Description

Reproducable on guest and -user account. (on pc and laptop)
Seen on user account first.
Initial report from guest account (attached .xession-errors and screenshot of terminal output).
Open a terminal and run 'top' to view processes.
Open Nautilus, right click only on bookmarked folders and open properties.
Result: nautilus, unity-panel and -hud service race cpu.
Fan speed increases from ~1100 to ~2000 rpm (viewed on user account with conky).

Viewing properties of folders which aren't bookmarked doesn't result in cpu race.
The behaviour has been introduced since recent unity updates.

compiz-core:
  Installed: 1:0.9.7.2-0ubuntu1
  Candidate: 1:0.9.7.2-0ubuntu1
  Version table:
 *** 1:0.9.7.2-0ubuntu1 0

~$ lspci -nnk | grep -i VGA -A2
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI RV710 [Radeon HD 4350] [1002:954f]
 Subsystem: PC Partner Limited Device [174b:174b]
 Kernel driver in use: radeon

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Mon Mar 26 18:33:32 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120204)
ProcEnviron:
 TERM=xterm
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :
description: updated
Sam_ (and-sam) wrote :
Bilal Akhtar (bilalakhtar) wrote :

That's really weird, and I managed to reproduce it too. Can't understand how this is related to Unity, but I guess it's related to the appmenu exported by the properties dialog. Not sure though.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
status: Confirmed → Triaged
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in nautilus (Ubuntu):
status: New → Triaged
importance: Undecided → High
Sam_ (and-sam) on 2012-03-27
description: updated
affects: nautilus (Ubuntu) → indicator-appmenu (Ubuntu)
Sam_ (and-sam) wrote :

Still reproducable with latest updates.
unity:
  Installed: 5.8.0-0ubuntu2
  Candidate: 5.8.0-0ubuntu2
  Version table:
 *** 5.8.0-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

compiz-core:
  Installed: 1:0.9.7.2-0ubuntu4
  Candidate: 1:0.9.7.2-0ubuntu4
  Version table:
 *** 1:0.9.7.2-0ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

indicator-appmenu:
  Installed: 0.3.95-0ubuntu2
  Candidate: 0.3.95-0ubuntu2
  Version table:
 *** 0.3.95-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Changed in indicator-appmenu (Ubuntu):
assignee: nobody → Ryan Lortie (desrt)
Changed in indicator-appmenu:
status: New → Triaged
importance: Undecided → High
Sam_ (and-sam) wrote :

Race still exists but decreased significant with latest update compared to #3.
indicator-appmenu:
  Installed: 0.3.96-0ubuntu2
  Candidate: 0.3.96-0ubuntu2
  Version table:
 *** 0.3.96-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Sam_ (and-sam) wrote :

No decrease on laptop with latest update. Leaving properties open for a while results in cpu fan running forever.
indicator-appmenu:
  Installed: 0.3.96-0ubuntu2
  Candidate: 0.3.96-0ubuntu2
  Version table:
 *** 0.3.96-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

desrt (desrt) wrote :

I finally managed to reproduce this on my i386 VM. killall hud-service results in the race just happening between nautilus and unity-panel-service (with contributions from dbus and X). I think that tells us two things:

 1) hud-service was an innocent bystander
 2) the trouble is related to the menus because otherwise why would hud-service be interested?

desrt (desrt) wrote :

So the involvement of menus is secondary to the main problem -- nautilus gets itself stuck in a silly loop reading and re-reading the free space on the drive. If a bookmarked directory is also involved then this results in the bookmarks menu also being updated, thus causing the issue we see here.

Changed in indicator-appmenu:
status: Triaged → Invalid
Changed in unity:
status: Triaged → Invalid
Changed in indicator-appmenu (Ubuntu):
status: Triaged → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in nautilus:
importance: Unknown → High
status: Unknown → New
Sam_ (and-sam) wrote :

Ryan, thanks a lot for the investigation and upstream report.

affects: unity (Ubuntu) → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: Invalid → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.0-0ubuntu2

---------------
nautilus (1:3.4.0-0ubuntu2) precise; urgency=low

  * debian/patches/git_copy_off_by_one.patch:
    - "Off-by-one error in count of copied files" (lp: #930944)
  * debian/patches/git_no_freespace_cpu_look.patch:
    - correct free space calculation and avoid cpu loops (lp: #965493)
 -- Sebastien Bacher <email address hidden> Thu, 05 Apr 2012 17:26:23 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
desrt (desrt) wrote :

Fix is committed upstream now too.

Changed in nautilus:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.