Ubuntu

Can't drag/drop files onto bookmarked folders

Reported by CaptSaltyJack on 2011-10-14
136
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

Impact: it should be easy to copy something to a bookmarked location and it's not

Test Case: try to dnd a file or folder to a bookmarked directory in the left sidepanel

Regression potential: the sidepanel could behave in a buggy weird on drag and drops events

Note that before it was possible to add a bookmark by dnding a folder to the sidepanel, that has several limitations:
- it's only working with folders
- it was not working on a fresh install before you had something bookmarked
- the "feature" behaviour was confusing
- there is already an ui to add bookmark, users use the sidepanel rather to access those than for adding new ones

The change is a slight behaviour change but the new one is the logical one and replace a buggy confusing one

CaptSaltyJack (csjubuntu) wrote :
Changed in nautilus (Ubuntu):
importance: Undecided → Wishlist
tags: added: likely-dup
Pedro Villavicencio (pedro) wrote :
Changed in nautilus (Ubuntu):
importance: Wishlist → Low
status: New → Triaged
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Traumflug (mah-jump-ing) wrote :

 -- This shouldn't be "wishlist", as it's actually a regression from Ubuntu 11.04. Dragging to bookmarks worked with the older Nautilus just fine.

 -- At least for me, this applies to self-made bookmarks only. Dragging to the predefined bookmarks (Desktop, Pictures, Music, ...) works just fine. Too bad these predefined ones are rarely useful on a productivity PC.

Traumflug (mah-jump-ing) wrote :

There's another Gnome bug tracking this: https://bugzilla.gnome.org/show_bug.cgi?id=645353

Diagnosis: instead of making a working feature dummy-proof, they removed the feature because it's not dummy-proof.

OUCH!

Changed in nautilus:
status: New → Invalid

Why has this been marked Invalid? It's regression, no? You could always drop files into bookmarked folders before and now you can't, which is pretty frustrating.

Sebastien Bacher (seb128) wrote :

You could read the GNOME bug to know the reply to your question...

Changed in nautilus:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in nautilus:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.1-0ubuntu6

---------------
nautilus (1:3.5.1-0ubuntu6) quantal; urgency=low

  * debian/patches/git_no_assert_on_double_mount.patch: lp: #1007593
    "sidebar: don't forget to NULL slot pointer after volume is mounted"
  * debian/patches/git_bookmark_place_dnd.patch: lp: #874386, #920691
    "places-sidebar: allow dropping of files to bookmarks"
  * debian/patches/git_no_menubars_segfault.patch: lp: #1003771
    "window-menus: disconnect from GtkSettings notifications on finalize"
 -- Sebastien Bacher <email address hidden> Tue, 12 Jun 2012 21:28:08 +0200

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
Jan Nekvasil (jan-nekvasil) wrote :

Is there any chance that this will be backported to 12.04 Precise? (I mean that SRU thing or what mechanism is used for fixes like that.)

Changed in nautilus (Ubuntu Precise):
importance: Undecided → Low
status: New → In Progress
description: updated
Sebastien Bacher (seb128) wrote :

@Jan: yes, that's being worked on

Changed in nautilus (Ubuntu Precise):
status: In Progress → Fix Committed

Hello CaptSaltyJack, or anyone else affected,

Accepted nautilus into precise-proposed. The package will build now and be available in a few hours. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: precise
tags: added: verification-needed
CaptSaltyJack (csjubuntu) wrote :

This is great! I'd like to thank the developers who worked on this to make it happen. Your efforts are hugely appreciated!

I'll enable the proposed source and watch for this.

Sebastien Bacher (seb128) wrote :

You're welcome, the source should be available in proposed for testing if you want to verify if it's working for you

CaptSaltyJack (csjubuntu) wrote :

Tested, works great! Not too sure how to change the bug to reflect that though.

Sebastien Bacher (seb128) wrote :

> Tested, works great!

Thanks for testing

> Not too sure how to change the bug to reflect that though.

the list of tags is at the bottom of the description, a working fix is reflected with: verification-needed -> verification-done, I did that update

tags: added: verification-done
removed: verification-needed

It works fine for me. I have local bookmarks and two SSH bookmarks. The hand icon reflects that the file will be either moved or copied over appropriately. No prob.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.2-0ubuntu3

---------------
nautilus (1:3.4.2-0ubuntu3) precise-proposed; urgency=low

  * debian/patches/git_bookmark_place_dnd.patch:
    - "places-sidebar: allow dropping of files to bookmarks" (lp: #874386)
  * debian/patches/git_image_properties_wrapping.patch:
    - "image-properties: set the description label to wrap" (lp: #396279)
 -- Sebastien Bacher <email address hidden> Wed, 13 Jun 2012 18:52:04 +0200

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
Frank Bicknell (fbicknel) wrote :

Not working for 1:3.4.2-0ubuntu4 - can't add a bookmark by dragging a file folder to the side bar.

True, but that's a different issue. Moving files by dragging onto bookmarks works now, which is what this bug is about.

No. Moving files by dragging onto bookmarks does NOT work now :-)

Version info:
* Ubuntu 12.04
* Nautilus 3.4.2

I'm not sure why some people are saying it is fixed. Maybe it IS in some versions?

Dario Bertini (berdario) wrote :

It's fixed at least in version "3.5.90.really.3.4.2-0ubuntu4.1" (in the about dialog it's 3.4.2)
apparently it's not in the 12.04 repositories... I don't know if it's worth it for you to ask/wait for someone to backport it, you might be better off upgrading

Maxiwell (maxiwell) wrote :

Same problem here too.

Version info:
 - ubuntu 12.10
 - nautilus 3.4.2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.