File selection by typing is buggy sometimes

Bug #857710 reported by Andrew on 2011-09-23
300
This bug affects 62 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Low
nautilus (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Test case:
1. install the new nautilus from -proposed and logout/login
2. ensure that the testcase below doesn't trigger the bug anymore

When I type in Nautilus to select files by name, often the wrong file is selected, as if my typing had been cut short or re-evaluated partway through. A screencast is attached.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.1.92-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Fri Sep 23 12:50:09 2011
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
SourcePackage: nautilus
UpgradeStatus: Upgraded to oneiric on 2011-09-23 (0 days ago)

(from duplicate bug #872090)-------------------
To reproduce:
On a previous version of ubuntu (Natty, Maverick) open nautilus.
Click in the file and folder area.
Press backspace until you are in the root of the file system.
Type 'e'. 'etc' should be selected. Press enter to open /etc/
Notice the search box disappears and /etc opens.
Type 'uf' 'ufw' should be selected. Notice you did not have to clear out the 'e' you typed into the search last time. Press backspace to clear the character 'f' from the current search, 'uf'. Notice the character 'f' is deleted and that you are still in /etc/.
Type 'd' and press enter to open /etc/udev.

Now, try the same test on Oneiric:
On a Oneiric, open nautilus.
Click in the file and folder area.
Press backspace until you are in the root of the file system.
Type 'et'. Notice that the search box disappears after typing the second letter (Not expected, a bug).
Press enter to open the currently selected /etc.
Type 'ud' and notice that no search comes up (this is a bug).
Close nautilus and reopen.
Type 'docu' to select documents, press backspace to delete 'u' and press enter. Notice the search works as expected.
Press backspace to navigate up (this is working normal)
Type 'Public'. Notice search still works as expected. Press enter.
Press backspace until you are in the root of the filesystem.

Apparently, search works properly in the home folder, but not in other folders!
On my machine, I'm using btrfs with (the installer set up) subvolumes for / and /home. However, this bug is still the same for root's home folder, which is only on the / subvolume!
-----------------------------------------

Andrew (andrewkvalheim) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
summary: - File selection by typing is inconsistent
+ File selection by typing is buggy sometimes
Sebastien Bacher (seb128) wrote :

I can't confirm that there, I get a box in the bottom right corner while I type there and no yellow status tooltips as you do when selecting a folder

Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
 https://bugzilla.gnome.org/show_bug.cgi?id=660807

Changed in nautilus (Ubuntu):
status: New → Triaged
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus:
importance: Unknown → Low
status: Unknown → New
Erik B. Andersen (azendale) wrote :

I reported a duplicate of this bug (bug 872090), with some steps to reproduce it. I think I'll add to this bug's description with more ways to cause it.

description: updated
Saurabh Gupta (bhaismachine) wrote :

I have reported a duplicate bug too. (Bug #873678 ). I have confirmed on the bugzilla that it affects me too.

Aigars Gedroics (gedrox) wrote :

For me the search doesn't work normally inside my home folder as well.

This will seriously worsen my everyday routines.

RobinJ (robinj) wrote :

Same here, frankly it's becoming VERY annoying.

Zach (a-zach-n) wrote :

Indeed RobinJ, this is incredibly irritating. Nice to see it's of 'low' importance.

Saurabh Gupta (bhaismachine) wrote :

Everybody please also comment here https://bugzilla.gnome.org/show_bug.cgi?id=660807 .

Ben Gamari (bgamari) wrote :

Please refrain from commenting unless you have something constructive to add that might help fix the issue. If you feel the issue should be fixed, express this by confirming that it affects you at the top of the page. "Me too" comments only make it harder for those trying to fix the bug.

Changed in nautilus (Ubuntu Oneiric):
importance: Undecided → High
Changed in nautilus (Ubuntu):
importance: Low → High
Changed in nautilus (Ubuntu Oneiric):
status: New → Triaged
Sebastien Bacher (seb128) wrote :

The bug got fixed upstream and will be fixed in an Oneiric update soon

Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-10-18
description: updated
Changed in nautilus:
status: New → Fix Released

Hello Andrew, or anyone else affected,

Accepted nautilus into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nautilus (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Zach (a-zach-n) wrote :

The Oneiric-proposed update partly patches the issue, but a number of issues that have been complained about still remain.

The good:

The search box no longer disappears after the second character is entered.

The bad:

The search box still remains (for 5 seconds) after hitting enter and entering the directory searched for. To reproduce this, go to home folder and type 'Doc', then hit enter to enter the Documents directory. The search box still remains for around 5 seconds. This is particularly annoying if you want to enter a string of directories, having to wait 5 seconds after entering each one, before being able to use typeahead.

The ugly:

How does one clear an error typed in the search box? The usual method was to use the backspace key, but this now takes us to the parent directory. Reproduce by going to home folder, typing 'Dox' and trying to correct the 'x' type by hitting backspace.

The search box doesn't always clear its contents upon disappearing/reappearing. I haven't found a way to specifically reproduce this yet, but it's happening almost randomly (or so it would appear). The box has disappeared and, upon reappearing, there's sometimes the contents of the last search remaining in there - and you can't use backspace to clear it because of the above problem.

Timo Tomasini (kanocx) wrote :

which package was updated? The bug is always present after apt-get upgrade.

Sebastien Bacher (seb128) wrote :

did you restart your session after updating?

Andrew Fenn (andrewfenn) wrote :

Zach are you sure you restarted after testing. I too have been experiencing these problems however they all disappeared after applying the updates. I also can not reproduce your examples.

Miklos Juhasz (mjuhasz) wrote :

I updated Nautilus from proposed and the restarted my laptop. The situation has improved but there are remaining issues.

I am experiencing similar ones to Zach, that is:

- The search box still remains (for 5 seconds) after hitting enter and entering the directory searched for. Better than before, at least I can search.
- No way to clear the search box: backspace key takes us to the parent directory. In the previous version the searchbox (when it remained open...) sometimes had the focus and I was able to remove characters, but sometimes the backspace took me to the parent dir.
- The search box doesn't always clear its contents upon disappearing/reappearing. If I press Esc or let it disappear the content is sometimes still there as soon as I start typing.

Victor Passapera (vpassapera) wrote :

I am experiencing this bug in Ubuntu 11.10 after i enabled the proposed updates and updated all the nautilus packages (nautilus, nautilus-data...etc). Nothing is fixed. I re-started my computer (A few times) and the bug still there.

I cannot search (At all) using typeahead in nautilus. Terminal output and ~/.xsession-errors report nothing.

Please fix ASAP (This bug is extremely detrimental to how i navigate in my OS).

Thank you.

Victor Passapera (vpassapera) wrote :

I should add (I am using Gnome 3 / Gnome-Shell).

Victor Passapera (vpassapera) wrote :

One last thing:

I had this bug since i upgraded to 11.10 and Gnome 3 / Gnome shell. Tried all the fixes in the internet. Nothing seems to work (including this one).

I made 3 posts in a row because there is no edit function in here. (Sorry)

Victor Passapera (vpassapera) wrote :

Fix does not work.

Andrew Fenn (andrewfenn) wrote :

I can also confirm the fix doesn't work for my other computer. The differences between this one and the one which has no issues is that the one which works is in a VM and was a fresh install. The computer with issues with the patch is not in a vm and was upgraded from an install of 10.04. Both computers are using the AMD64 release.

Martin Pitt (pitti) on 2011-10-19
tags: added: verification-failed
removed: verification-needed
Moppers (moppers) wrote :

This actually now works for me and fixed typeahead search so long as the statusbar is up. It's a bit dodgy without the status bar.

1448412 (uli-rgbg) wrote :

I did:

- sudo apt-get install -t oneiric-proposed nautilus
- logout/login

I tried starting in ~ and navigated to ~/Desktop/data/projects

I can now do so by typing "De<CR>...Pause ca.3-4 seconds...da<CR>.... Pause ca.3-4 seconds....pro<CR>" which was not possible before the fix.

But the need to pause is very annoying. Before the bug appeared, I could execute the full procedure in far less than 1 second.

During the pause the search-box is still visible with the old content. It does not close and it does not clear after the directory change. After the pause the searchbox will vanish, and after a keystroke it will reappear containing only the key from the keystroke.

I do not experience that enabling/disabling the statusbar influences things.

I'm using a x64 machine that has been upgraded from 10.04, btw.

Sebastien Bacher (seb128) wrote :

Ok, if it's not perfect could you open a new bug about the new issue?

Victor Passapera (vpassapera) wrote :

This bug specifically does not seem to be fixed for anyone using 64bit version of ubuntu 11.10 that have upgraded from 10.04 or 10.10 to 11.04 and then 11.10

So are you requesting that we open a new bug anyways?

Sebastien Bacher (seb128) wrote :

The fix there is a code fix which is neither upgrade or architecture specific, you might have a different issue so yes open a new bug

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-0ubuntu1

---------------
nautilus (1:3.2.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release:
    - Consolidate typeahead find entry for icon view (LP: #857710)
    - Fix a crasher when middle-clicking empty space in the places sidebar
    - Fix a crasher when trying to delete files from the tree sidebar
      (LP: #830185, #845408)
    - Fix a crasher when ejecting a removable device under some circumstances
    - Fix a crasher when trying to activate the previewer in a list view
      with no selection
    - Fix a crasher when symbolic icon theme is not available
    - Plug some memory leaks
    - Fix the build when Tracker FTS is enabled
  * Remove some cherry-picked patches:
    - git_handle_missing_icon.patch, git_gsettings_signals.patch,
      git_no_typeahead_timeout_segfault.patch,
      git_dont_preview_empty_selection.patch, git_correct_signal_handling.patch
      git_no_signal_order_assert.patch, git_slot_closing.patch,
      git_close_pane_cleaning.patch
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 09:52:20 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Victor Passapera (vpassapera) wrote :

To those that are still experiencing this bug (as I am), I filed a new bug:

https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/879456

Martin Pitt (pitti) wrote :

It's an improvement, not a regression, so I move the current SRU to -updates, but reopen the bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-0ubuntu1

---------------
nautilus (1:3.2.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release:
    - Consolidate typeahead find entry for icon view (LP: #857710)
    - Fix a crasher when middle-clicking empty space in the places sidebar
    - Fix a crasher when trying to delete files from the tree sidebar
      (LP: #830185, #845408)
    - Fix a crasher when ejecting a removable device under some circumstances
    - Fix a crasher when trying to activate the previewer in a list view
      with no selection
    - Fix a crasher when symbolic icon theme is not available
    - Plug some memory leaks
    - Fix the build when Tracker FTS is enabled
  * Remove some cherry-picked patches:
    - git_handle_missing_icon.patch, git_gsettings_signals.patch,
      git_no_typeahead_timeout_segfault.patch,
      git_dont_preview_empty_selection.patch, git_correct_signal_handling.patch
      git_no_signal_order_assert.patch, git_slot_closing.patch,
      git_close_pane_cleaning.patch
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 09:52:20 +0200

Changed in nautilus (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2011-10-25
Changed in nautilus (Ubuntu):
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

there is already bug #879456 about the new issues, no need to reopen this one

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.