SRU: Status Bar Covers File Name at Bottom

Bug #797485 reported by willm.wade on 2011-06-15
390
This bug affects 85 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Medium
Unassigned
Xenial
Medium
Martin Wimpress

Bug Description

[Impact]

If using Nautilus without a status bar the selected item title 'floats' at the bottom of the file listing.

If you choose the last file item in a list this 'floating' title prevents you seeing the actual title making editing difficult/impossible. This issue is also present in icon view if you have an even number of files on the bottom row it becomes difficult to rename the last file as the status bar covers the text area.

[Test Case]

Using Ubuntu 16.04.1 open the file manager, click "Home", enable list view and resize the file manager window so that the contents of the home directory just fit vertically and horizontally. Select the last item in the file listing and then move the mouse slowly from left to right and back again several time. You will see the floating status bar will jump from left to right, obscuring details of the selected item.

After the patched nautilus package is installed, performing the same test will result on the floating status bar being hidden when the mouse hovers over it.

[Regression Potential]

None. This patch has been adapted from the following upstream commit:

* https://git.gnome.org/browse/nautilus/commit/?id=e66d3ca

Packages have been built in a PPA and tested for regressions.

[ Other Info ]

Binary package hint: nautilus

The following possible solutions were considered:

* Give the file list a bottom margin of the height of the status bar.
* Move status bar to the left side when working with files in that corner.
* Do not show status bar while renaming.
* Hide the floating bars when hovering over part of the selection.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
willm.wade (willm-wade) wrote :

I found someone else posted it over there so I added my information to theirs.

https://bugzilla.gnome.org/show_bug.cgi?id=651293

Robert Roth (evfool) on 2011-10-27
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
doken (doken) wrote :

This IMHO is not a low priority, it's not just renaming files! It's even selecting them that is a problem.
I use "List" view a lot and either when the window is half-screen width or more often when using the "Extra Pane" (where each pane is thus narrower), the 'status' bar pops up over the last entry almost every time.
I know the 'status' tries to hop to the other side of the pane to allow this kind of thing, but that is seldom triggered or fixes the problem. If anything is selected, the only way to select the last file is to unselect all files with Ctrl-click then the 'status' is out of the way so the last file can be selected. And if you're selecting multiples, you have so resize the window really because losing all your selections to start again with the last one is ridiculous.

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus:
status: New → Confirmed
Lisa Schmidt (boxnotify) wrote :

Yes, it is very annoying when you want to select a file. It stands in your way and you can't click the file name.

Adolfo Jayme (fitojb) on 2013-05-08
Changed in nautilus (Ubuntu):
importance: Low → Medium
linux.girl (girllinux26) wrote :

Any solutions to this problem? I agree with doken, this is not a minor problem - will this be addressed any time soon?

Thanks!

Ron Adams (tohuw) wrote :

linux.girl, It's been reported upstream, I'd say badger them about it. That's what I'm doing!

florin (florin-arjocu) wrote :

And this is not the only bug (EOG not working with large images, Gnome is messing up the desktop icons, etc.).

Allen Talbot (myesol) wrote :

I ditched Windoze years ago and always promote Ubuntu to my students. This is so fustrating when working with lots of files/documents, I'm even tempted to start creating an x.txt in every folder I use to avoid editing/removing the wrong file by mistake. Please escalate

This is what I do. I have an empty file named 'zzz' (or 'ZZZ', I
forget) to take up the bottom line.

Michael

On 09/16/2013 04:11 PM, Allen Talbot wrote:
> I ditched Windoze years ago and always promote Ubuntu to my students.
> This is so fustrating when working with lots of files/documents, I'm
> even tempted to start creating an x.txt in every folder I use to avoid
> editing/removing the wrong file by mistake. Please escalate
>

Sorry, but I cannot accept the user interface can have this kind of bugs. It means no one tested it before. And just try to use the desktop as a place to keep very often used icons/programs/files. You will see they can pe placed on top of other icons. Not acceptable, I got tired to fight on Gnome bugzilla for this kind of interaction bugs, from their point of view it is a normal UI.

dancing (dancingmusic) wrote :

Please fix this! It has been disturbing me for many many months and I've searched forums numerous times for a fix.

Stanislav (stanislav-schmidt) wrote :

Affects me in the same way as the previous speakers. I have the list view set as default and so I have to deal with this bug on a daily basis. Since at least one file is selected alsmot all the time, its information pop-up covers the last file in the list completely so I cannot see it nor open the file. Very frustrating. The only way to access the last file in the list is the one suggested by doken -- Ctrl+click deselect the currently selected file.

Eric Maeker (eric-maeker) wrote :

yes this popup is **really** annoying and useless, please remove it and/or add an option in applicaiton preferences

Eric Maeker (eric-maeker) wrote :

still affects 14.04

X-BASS (ideasgeniales) wrote :

Ubuntu 14.04 updated to november '14 still shows this behaviour.

Please, add a fixed user enabled/disabled bottom status bar, not the floating one.

Thanks.

frado (frado65) wrote :

Please remove it!

Misaki (myjunkmail311006) wrote :

I don't feel like commenting on the Bugzilla bug report, which states that . . .
<blockquote>We will remove the floating bar after releasing 3.16, so probably this won't be need at all.</blockquote>

. . . but this could be fixed by increasing the vertical scrollable size of the window when the last row is selected.

The vertical size already increases based on the length of file names in the last row, this would just be an extension of that. The comment on Bugzilla also does not say what they are replacing the floating bar with. Being able to see the size of a file, without having file size always enabled at default zoom level, using just a single click is useful and it shouldn't go away.

Alt-enter is not a replacement because it takes longer, and not everyone has a fast computer. The lag it takes to open the properties window also seems to scale with the number of items in the folder.

David Agudo (dagudoj) wrote :

Very very very annoying, it's impossible to rename the file at the bottom, the tooltip hides the filename. Please remove the tooltip or locate it over or below the selected file, but never on top of it.

Rudolf (rk-com) wrote :

Indeed *extremely* annoying - at renaming a file and other occasions.

webjunkie (webjunkie) wrote :

For the love of all that's holy... Please fix this because it is driving me insane!

David Agudo (dagudoj) wrote :

I remember this bug every day of my life... like a pain in the ass. Four years. Four.

Jordan Bowman (jordanbowman) wrote :

I can't even begin to explain how annoying this "feature" is to me. Sometimes I have an extremely hard time understanding UI design choices. A file browser has one major purpose: to show me ALL the files in a given directory; but when I can't see my bottom row of files because of a damn floating status bar that I have no way of removing, said file browser fails miserably at its ONE job.

florin (florin-arjocu) wrote :

I am sick of this bug either, but I cannot see another solution but to wait for some revelation. I have also posted a bug report on Gnome Bugzilla, but my experience shows that Gnome devs do not really care about user reported bugs (I reported more bugs and the usual answer is that I use an older version).

tags: added: rls-x-incomingh
tags: added: rls-x-incoming
removed: rls-x-incomingh
Christopher M. Rogers (cajhne) wrote :

This bug is still in 3.16.4. It's still annoying as hell, and disrupts my daily work.

mara sdr (paren8esis) on 2015-12-27
no longer affects: nautilus (Fedora)
Fábio (machado2) wrote :

What was the last version of Nautilus without this bug? This version is unacceptable, it shouldn't be installed on any stable distro

Axel Hanusch (axelh) wrote :

In May 2016 the corresponding gnome bug (#651293) will have it's fifth anniversary and is still status "NEW". I would not expect this to change soon and waiting for it does not contribute to Ubuntu bug #1 very well. They probably have other priorities.
When searching on Google for "ubuntu nemo instead of nautilus" I get 13400 results.
Maybe Nautilus' time as default file manager for Ubuntu should be over.

Will Cooke (willcooke) on 2016-02-15
tags: added: rls-x-notfixing
removed: rls-x-incoming
seldomridgej (seldomridgej) wrote :

Just adding to the pile here. This bug is terrible and has been around forever. Just need a simple fix, a small space at the bottom of the window.

peter kodermac (navalspycom) wrote :

This is very annoying, each new version of Ubuntu is worse, decision makers have no idea what is user friendly. We will leave Ubuntu so you do not have to repair it.

Rafael Leite (leite08) wrote :

Really? Five years to solve a problem like this?
Guys, this is basic: the user cannot rename a file!

Changed in nautilus:
status: Confirmed → Fix Released
webjunkie (webjunkie) wrote :

> → Fix Released

Wow... did hell freeze over last night?

HJC (huangjccn) wrote :

Find this bug annoying so I start googling. Glad to see it solved after 5 years.

Sebastien Bacher (seb128) wrote :

commited the fix to the packaging vcs so it's going to be in the upload then if it works correctly a stable update can be considered

Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (6.5 KiB)

This bug was fixed in the package nautilus - 1:3.20.2-0ubuntu1

---------------
nautilus (1:3.20.2-0ubuntu1) yakkety; urgency=medium

  * Merge with Debian. Remaining changes:
    - Multiarchify the library packages
    - debian/control.in:
      + Build-Depends on dh-migrations, libunity-dev, and libzeitgeist-2.0-dev
      + updated gnome-pkg-tools requirement
      + lower gnome-sushi Recommends to a Suggests
      + Replace nautilus-data (<< 1:3.18.1-1ubuntu1) for appdata move
      + nautilus-data should not need to recommends nautilus,
        lower to a suggests so file-roller doesn't bring in nautilus
    - debian/changelog, debian/rules: set epoch number (which was added by error)
    - debian/mount-archive.desktop:
    - debian/mount-archive.desktop.in:
      + New nautilus context menu item to allow mounting zip, iso, etc
    - debian/nautilus.install:
      + install mount-archive menu
      + install nautilus-folder-handler.desktop
    - debian/nautilus-data.install:
      + install apport hook
    - debian/nautilus-folder-handler.desktop:
      + ship a copy of nautilus.desktop with NoDisplay=true since some user
        configurations refer to it
    - debian/nautilus.migrations, debian/nautilus-unity-launcher-icon.py:
      + change the nautilus.desktop entry in the unity configuration to the
        new org.gnome.Nautilus name (lp: #1436297)
    - debian/source_nautilus.py:
      + Apport hook to list versions of files in /usr/lib/nautilus and
        reassign the crashes when they are not due to nautilus code directly
    - debian/rules:
      + use dh_migrations and build compat desktop entries
      + Bump dbgsym migration version
    - debian/patches/03_translations_list_update.patch:
      + Translate the mount-archive menu entry
    - 04_suppress_umount_in_ltsp.patch:
      + Don't list unmount and eject actions on LTSP clients
    - 06_never_exec_nonexec_launchers.patch:
      + Implement non-exec policy for .desktop handler.
    - 08_clean_session_capplet.patch:
      + use NoDisplay for the new autostart desktop to keep the capplet clean
    - 12_unity_launcher_support.patch:
      + unity launcher integration (list bookmarks in the context menu,
        display a bar on the icon during copies)
    - 15_use-ubuntu-help.patch:
      + use the ubuntu documentation
    - 16_unity_new_documents.patch:
      + display the "new document" menu under unity, even if there is no
        template installed
    - 18_unity_icon_color.patch:
      + specify a background color for the unity launcher icon
    - dont_wrap_labels_after_dots.patch:
      - don't wrap labels after a dot if they are followed by a number,
        the upstream code has a hack for 3 digit version numbers which
        doesn't really make sense
    - 19_unity_open_location_xid.patch:
      + Add a new dbus property to store the lists of opened locations
        referenced by their parent nautilus window XID.
    - 20_add_timestamp_to_operations.patch:
      + Add *WithTimestamp dbus methods for file operations that
        might trigger a dialog, that should be presented with time.
    - ubuntu_revert_no_wallpaper.patch:
      + revert upstream changes to us...

Read more...

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
LorenRosen (lorenrosen) wrote :

Until the fix appears (in a future release of Ubuntu) one workaround is to toggle the sort order so the file is at the top instead of the bottom.

Robert Orzanna (orschiro) wrote :

Dear all,

Just a quick question:

Does the released fix cover the problem that I try to demonstrate in the attached gif animation?

Thankfully,

-Robert

florin (florin-arjocu) wrote :

I have the latest updates and still experience the bug. Maybe the fix is not released yet?

Attached is a debdiff (for Xenial) that implements hiding the nautilus-floating-bar on hover.

Oops, the patch above is not the debdiff. This is the debdiff for Xenial) that implements hiding the nautilus-floating-bar on hover.

Changed in nautilus (Ubuntu Xenial):
assignee: nobody → Martin Wimpress (flexiondotorg)
importance: Undecided → Medium
status: New → In Progress
description: updated
summary: - Status Bar Covers File Name at Bottom
+ SRU: Status Bar Covers File Name at Bottom
tags: added: patch
removed: rls-x-notfixing
description: updated
David Imiri (techbin1) wrote :

Thank you for working on this! It was first reported in 2011 ~ I'm trying to tell everyone Ubuntu is a mature OS, this is a maddening daily problem...

David Imiri (techbin1) wrote :

I see the tooltip there as completely unnecessary. Your selected file is already highlighted in color. What's the point, and what's the delay just stripping it out?

Iain Lane (laney) wrote :

I just uploaded the proposed update, thanks. You should get a call for testing soon when it's available.

Robie Basak (racb) wrote :

Accepting, but a couple of comments:

1) "Regression potential: none" is not acceptable. See https://wiki.ubuntu.com/StableReleaseUpdates#Procedure. Please fix this before SRU verification.

2) Instead of " Adapted from https://git.gnome.org/browse/nautilus/commit/?id=e66d3ca" in the description of your dep3 header, you could say "Origin: backport, https://git.gnome.org/browse/nautilus/commit/?id=e66d3ca" which describes exactly the same thing but is machine readable.

Changed in nautilus (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed

Hello willm.wade, or anyone else affected,

Accepted nautilus into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nautilus/1:3.18.4.is.3.14.3-0ubuntu6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-done
removed: verification-needed
D H (d-e-h0987) wrote :

I don't understand why you would get rid of the status bar in the first place. It would be much better to just leave the older status bar and have the option for the new overlay bit. You just have a check box defaulted to the new system and us old timers who are set in our ways can go in and click the box turning on the status bar.

I have no problem with new things but when you take away things people have used for years you end up ticking off the people whom have supported your software for years.

Robie Basak (racb) wrote :

Please:

1) Confirm how you tested (referring to the test plan is fine, but please do so) what the results were, and which package versions you tested before marking verification-done.

2) Fix the "Regression Potential: None" in the bug description and explain how you have considered other users who might be broken by this change. I asked for this in comment 43. For example, see D H's comment 45 above. Should I take this as an unfortunate side effect of this proposed fix that needs to be considered? I don't know, so I don't know whether it is safe to release this update or not.

Please mark verification-done after you've done the two things above. This will help prevent users being regressed. Thanks!

tags: added: verification-needed
removed: verification-done
Xtien (xtien) wrote :

This is still happening.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.