Ubuntu

nautilus crashes on opening folder containing broken symlinks

Reported by arjun on 2010-06-23
86
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
nautilus (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: nautilus

whenever i open the '/usr/bin' folder of my lucid partiton, nautilus crashes.This happens every time i open the folder. when i run it in the terminal this is the output i get
--------------------------------------------------------------------------------
arjun@arjun-desktop:~$ nautilus

(nautilus:5034): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

Initializing nautilus-gdu extension
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

Segmentation fault
----------------------------------------------------------------------------------
Description: Ubuntu maverick (development branch)
Release: 10.10

nautilus:
  Installed: 1:2.30.1-0ubuntu3
  Candidate: 1:2.30.1-1ubuntu1
  Version table:
     1:2.30.1-1ubuntu1 0
        500 http://in.archive.ubuntu.com/ubuntu/ maverick/main Packages
 *** 1:2.30.1-0ubuntu3 0
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: nautilus 1:2.30.1-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.34-5.13-generic 2.6.34
Uname: Linux 2.6.34-5-generic x86_64
Architecture: amd64
Date: Wed Jun 23 15:42:13 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100602.2)
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: nautilus

arjun (arjunak01) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
arjun (arjunak01) wrote :

Running gdb shows the program exited normally but the window is still open and i can crash it by visiting the folder

Changed in nautilus (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

that's because you tried to run it again while it was already running so it exited, you should attach gdb to the running one rather

Changed in nautilus (Ubuntu):
status: New → Incomplete
arjun (arjunak01) wrote :

I'm getting a segmentation fault. but running "backtrace full" doesn't seem to end. i ran it for over half an hour,

=============================================================================================
 __PRETTY_FUNCTION__ = "nautilus_file_changed"
#97656 0x00000000004d241f in nautilus_file_emit_changed (file=0x7f1af81129a0) at nautilus-file.c:7126
        link_files = 0x7f1af8342580
        p = 0x7f1af8342580
        __PRETTY_FUNCTION__ = "nautilus_file_emit_changed"
#97657 0x00000000004b9911 in nautilus_directory_emit_change_signals (directory=0x1d7b360, changed_files=0x0) at nautilus-directory.c:785
        p = 0x7fff485dc550
#97658 0x00000000004d2341 in nautilus_file_changed (file=0x7f1af81129a0) at nautilus-file.c:7066
        fake_list = {data = 0x7f1af81129a0, next = 0x0, prev = 0x0}
        __PRETTY_FUNCTION__ = "nautilus_file_changed"
#97659 0x00000000004d241f in nautilus_file_emit_changed (file=0x7f1af81126a0) at nautilus-file.c:7126
        link_files = 0x7f1af8342640
        p = 0x7f1af8342640

  <this goes on...>

===========================================================================================

Changed in nautilus (Ubuntu):
status: Incomplete → New
arjun (arjunak01) on 2010-06-24
tags: added: lucid
arjun (arjunak01) wrote :

it is happening in lucid also. Ive attached the list of files in the directory

Pedro Villavicencio (pedro) wrote :

May you please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus (Ubuntu):
importance: Low → Medium
status: New → Incomplete
arjun (arjunak01) wrote :

I'm able to open the folder using dolphin without any issues

Changed in nautilus (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

the valgrind log has no error, did you stop the running nautilus when to run the new one? does gvfs-ls work correctly there?

arjun (arjunak01) wrote :

gvfs-ls works correctly. here is the log file,

arjun (arjunak01) wrote :

i have found the files that caused nautilus to crash. i've attached the files as an iso (compressing did not work) use ubuntu live cd and mount the image.

arjun (arjunak01) on 2011-04-15
summary: - nautrilus crashes on opening /usr/bin
+ nautilus crashes on opening folder containing broken symlinks
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus:
importance: Medium → Critical
status: New → Incomplete
Changed in nautilus:
status: Incomplete → New
Changed in nautilus (Ubuntu):
status: New → Triaged
aleandro (aleandrodasilva) wrote :

in natty I have same bug

Vasilis Mavroudis (vmavroudis) wrote :

I also confirm the same bug in Lucid.

Alexander Untch (untcha) wrote :

I can confirm the same bug in Natty after installing the following package:
openmpi-bin

Daniel Ejsing-Duun (zilvador) wrote :

I had the same problem (dublicate bug https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/734212) and a source was found, but at that time nautilus did not crash anymore when entering /usr/bin even though the files are still there. This could be because of upgrading to Nautilus 3.2.0.

Daniel Ejsing-Duun (zilvador) wrote :

I was too fast. The some of the files had been changed and were no longer symlinks. I am sorry for the false alarm.

Haitao Li (lht) wrote :

The bug should have been fixed in upstream according to Nautilus developers mentioned in anther gnome bug report [1].

1. https://bugzilla.gnome.org/show_bug.cgi?id=607974

Haitao Li (lht) wrote :

I am still seeing the crash with Nautilus 3.2.1 on Oneiric.

Minimum steps to reproduce:
$ mkdir /tmp/dbg
$ cd /tmp/dbg
$ ln -s a b
$ ln -s b a
$ nautilus .
Initializing nautilus-gdu extension
Initializing nautilus-dropbox 0.6.8
Segmentation fault

$ apt-cache policy nautilus
nautilus:
  Installed: 1:3.2.1-0ubuntu2

Changed in nautilus:
status: New → Confirmed
Changed in nautilus:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.