Crashes when entering the /usr/bin directory

Bug #734212 reported by Daniel Ejsing-Duun on 2011-03-13
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
New
Undecided
Unassigned
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

Whenever I go to the /usr/bin directory, Nautilus crashes and restarts within two seconds. I don't recall the last time I've been able to go in there, but it shouldn't be a problem.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: nautilus 1:2.32.0-0ubuntu1.3
ProcVersionSignature: Ubuntu 2.6.35-27.48-generic 2.6.35.11
Uname: Linux 2.6.35-27-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Sun Mar 13 09:57:01 2011
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=da_DK:da
 LANG=da_DK.utf8
 SHELL=/bin/bash
SourcePackage: nautilus

Daniel Ejsing-Duun (zilvador) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Daniel Ejsing-Duun (zilvador) wrote :

I did as you asked by following the category for running programs. the backlog trace printed out very similar lines with descending memory addresses (I believe), so after a few minutes, I aborted it. I made a new run to get the other information (in the file at line 207980). The same happened when I ran 'thread apply all backtrace', so again I aborted after about a minute. I hope it's fine. If not I can let it run for longer.

Sebastien Bacher (seb128) wrote :

it seems it's going over the same functions again and again, do you have a symlink on the directory itself there or something?

Daniel Ejsing-Duun (zilvador) wrote :

Interesting. I found this in there:

lrwxrwxrwx 1 root root 1 2010-11-14 00:17 X11 -> .

I haven't touched the folder myself, so I have no idea how it got in there. But I guess this was causing it.

Sebastien Bacher (seb128) wrote :

that's not likely the issue, that one is there on a standard installation and the issue is not happening for others

Daniel Ejsing-Duun (zilvador) wrote :

I see. So what am I looking for?

Daniel Ejsing-Duun (zilvador) wrote :

I added a 'ls -lt' of my /bin/dir in case it can help. I don't see anything else suspicious. I figured a timely ordering of the list was most convenient.

Changed in nautilus (Ubuntu):
status: Incomplete → New
Soo (soowjo) wrote :

I'm having the same problem on Lucid.

Excerpt from /var/log/messages:
Apr 15 11:47:45 ubuntu kernel: [ 708.177498] nautilus[2094]: segfault at 7fffd5e01fe8 ip 00007f6e35daf56e sp 00007fffd5e01ff0 error 6 in libglib-2.0.so.0.2400.0[7f6e35d53000+db000]

Soo (soowjo) wrote :

Just upgraded to Maverick, and this problem still exists.

Soo (soowjo) wrote :

Just tried gnome-commander to see if it can open /usr/bin, and it can. So it means something is wrong with nautilus.

Haitao Li (lht) wrote :

According to attachment "List of files in /bin/dir", below symlinks are invalid.

lrwxrwxrwx 1 root root 15 2011-02-23 18:19 ompi-checkpoint -> orte-checkpoint
lrwxrwxrwx 1 root root 12 2011-02-23 18:19 ompi-restart -> orte-restart
lrwxrwxrwx 1 root root 15 2011-02-23 18:19 orte-checkpoint -> ompi-checkpoint
lrwxrwxrwx 1 root root 12 2011-02-23 18:19 orte-restart -> ompi-restart

Please remove them and try if nautilus works.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Daniel Ejsing-Duun (zilvador) wrote :

Actually Nautilus opens the directory now without a problem, though the mentioned files are still there. I don't know when this has been fixed, but I can't reproduce the problem anymore. Thank you for looking at it.

Haitao Li (lht) wrote :

The broken symlinks are from openmpi-checkpoint. Bug #797091. Upstream fix has been included in Oneiric.

Haitao Li (lht) wrote :

Are you sure the mentioned files there are exactly the same as you previously reported? I mean,

ompi-checkpoint -> orte-checkpoint and orte-checkpoint -> ompi-checkpoint, forming an invalid endless loop.

I am asking because I can reproduce the SEGV fault by simply creating symlinks like this in any directory.

Daniel Ejsing-Duun (zilvador) wrote :

Oh..I am sorry. I saw that the ompi files were still symlinks, but in fact the orte files are not any more. So the loop has been broken. I didn't look carefully enough.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers