Light 1px border around desktop

Bug #507263 reported by Hernando Torque on 2010-01-13
504
This bug affects 101 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Sebastien Bacher
Lucid
Low
Sebastien Bacher

Bug Description

Binary package hint: nautilus

When creating or renaming objects on the desktop, a light, 1px wide border appears around the desktop (panels and maximized windows do overlap). The border only disappears when killing the process 'nautilus'.

Screenshot: http://launchpadlibrarian.net/37931074/837162.png

See also: http://ubuntuforums.org/showthread.php?t=1379469

ProblemType: Bug
Architecture: i386
Date: Thu Jan 14 00:33:58 2010
DistroRelease: Ubuntu 10.04
Package: nautilus 1:2.29.1-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SourcePackage: nautilus
Tags: lucid
Uname: Linux 2.6.32-10-generic i686

Related branches

Hernando Torque (htorque) wrote :
Doug McMahon (mc3man) wrote :

I also see it occurring when changing themes

screenshot here if need be
http://ubuntuforums.org/showthread.php?p=8660492#post8660492

Changed in nautilus (Ubuntu):
status: New → Confirmed
description: updated
Mike Durham (mdurhamesq) wrote :

Interestingly, it also appears in the 'current workspace' Workspace Switcher.

Pedro Villavicencio (pedro) wrote :

may you please add the screenshots as an attachment to the report? I'm not able to access that page. thanks.

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: Confirmed → Incomplete
Hernando Torque (htorque) wrote :

Sorry, a bad habit.

description: updated
Pedro Villavicencio (pedro) wrote :

that was *fast*; Thanks Hernando, will have a look upstream.

Pedro Villavicencio (pedro) wrote :

looks like bug https://bugzilla.gnome.org/show_bug.cgi?id=605704 ; linking the report.

Changed in nautilus (Ubuntu):
status: Incomplete → Triaged

When we are already exchanging screen shots... http://i48.tinypic.com/2yxpwef.png
This bug affects me too. Since I started using Ubuntu.
Minor annoyance, but annoying as hell!

vmc (vmclark) wrote :

We still have this "white border", when renaming a file or folder on the desktop.

Use 'nautilus -q' to extinguish it.

I'm getting the frame when renaming files on my desktop, changing themes and/or fonts, font size...

Doing nautilus -q each time I make a minor adjustment is getting really annoying. Hope a fix is in the works.

I also want to mention that the right-click doesn't work on the border.

tekstr1der (tekstr1der) wrote :

I've been following Bug #519996 regarding this problem. They seem to be the same bug. Which is a dupe?

tekstr1der (tekstr1der) wrote :

EDIT: Sorry, I meant Bug #529996. Launchpad needs editing capability so badly.

Timo Reimerdes (timorei) wrote :

This is getting annoying.

A thought I was having is: could this be the result of something like a spacing or thickness setting in the gtk theme files?

Just wondering. If I take a break from work again, I might toy abit with different themes, and see what that does.

Benjamin Humphrey (humphreybc) wrote :

Effects me here too. Seems to be present on pretty much every theme I've tried. It's worse on the default themes than some other ones.

Hernando Torque (htorque) wrote :

I'm still seeing the BT messages but the audio output works reliably (I didn't remove any BT related packages).

espeak:
  Installed: 1.43-0ubuntu1
  Candidate: 1.43-0ubuntu1
  Version table:
 *** 1.43-0ubuntu1 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

Timo Reimerdes (timorei) wrote :

After playing around with some of the easier themes (Simple-Generic) and modifying it a little in regard to the x- and ythickness values I can indeed confirm that these cause the border around the desktop.

   xthickness = 0
   ythickness = 0

in the "/usr/share/themes/Simple-Generic/gtk-2.0/gtkrc" (if you have that theme installed) - no border around the desktop.

I cannot find the widget class name of the nautilus desktop only, wich would provide a quick workaround for any theme with this problem. Anyone happen to know this?

Posting this at the end of any theme with the border problem should remove this - replace <X> by the widget name, once you found it. ;)

style "fix_nautilus_desktop_border"
{
  ythickness = "0"
  xthickness = "0"
}
widget_class "<X>" style "fix_nautilus_desktop_border"

Sebastien Bacher (seb128) wrote :

the issue could be a theme one then?

Changed in nautilus (Ubuntu Lucid):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Canonical Desktop Team (canonical-desktop-team)

I don't think so. Those "error" occured the first time after a nautilus-update and every theme I tried the last time has it. Some, like elementary, more and some less. But I havn't seen a single theme without it. And the Themes havn't changed.

Hernando Torque (htorque) wrote :

Err, sorry about #16. :-)

tekstr1der (tekstr1der) wrote :

@Timo: according to the lastest comment upstream, this does not appear to be a theme-dependant bug:

> Luke Symes 2010-03-09 09:41:32 UTC

>Problem happens from libnautilus-private/nautilus-icon-container.c,
>nautilus_icon_container_start_renaming_selected_item:
>~8419: gtk_widget_show (details->rename_widget);

>I found this by putting "return;" in likely places in the function until the
>behaviour appeared.

Jan Nekvasil (jan-nekvasil) wrote :

Theme dependent? Yes and no. Yes because that border line changes it's color according to selected theme (try DarkRoom). No because our line is exactly the _same_ line which was added to Nautilus few months ago to prettify the main folders & files pane. This line wasn't there before, and the troubles with the desktop border line started just after it's first appearance on the stage.

Why the border line appears only after some manipulation with desktop items remains mystery.

Ivan M (i2initiatives) wrote :

The same 1px borders appear on the left and right side of my desktop. I have a fresh install of Lucid with the default Ambiance theme. The borders only appear on the desktop - they do not cover the panels and do not appear when I have a maximised window on the screen.

The only software that I have installed was from the updates recommended in Update Manager - I haven't done anything else.

Timo Reimerdes (timorei) wrote :

I have just done the following to the ambience theme:

$ sudo gedit /usr/share/themes/Ambience/gtk-2.0/gtkrc

edit line 11 & 12 to
xthickness = 0
ythickness = 0

safe and close.

reload the theme by clicking on some other and than on ambience again.

See if this 'fixes' it for you, too.

Sebastien Bacher (seb128) wrote :

changing the theme as suggested is not a fix and might create other bugs, it's suggested to wait for a fix rather. There is also enough information in this bug to have it confirmed and worked now so please stop adding comments there to confirm you get the issue too and move discussions about workaround to user forums or lists

Luke Symes (allsymes) wrote :

I've submitted a patch upstream that turns off the desktop border. Tested it by renaming, changing theme and changing font. Hopefully it will be fixed soon.

Timo Reimerdes (timorei) wrote :

The workaround might not be a fix, but it might point to where specifically something changed that makes this an issue in many themes/engines. I am sry if I repeated myself, sometimes I write with lack of coffee in blood. Looking forward to the patch so eCO looks beautifull again. ;)

tags: added: gloam
Changed in nautilus (Ubuntu Lucid):
assignee: Canonical Desktop Team (canonical-desktop-team) → Sebastien Bacher (seb128)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.29.92.1-0ubuntu2

---------------
nautilus (1:2.29.92.1-0ubuntu2) lucid; urgency=low

  * debian/patches/92_git_change_no_desktop_frame.patch:
    - git change to not display a border around the desktop background
      (lp: #507263)
 -- Sebastien Bacher <email address hidden> Thu, 18 Mar 2010 15:29:48 +0100

Changed in nautilus (Ubuntu Lucid):
status: Fix Committed → Fix Released
Bernhard (b.a.koenig) wrote :

Thanks for fixing this and I have no more 1px borders around desktop but I see the same problem now in firefox using the "homosapien" theme.

Bernhard (b.a.koenig) wrote :

To reproduce:

1) use "homosapien" theme
2) in firefox, go to a page with dark background

Luke Symes (allsymes) wrote :

Hi Bernhard. Your issue with the Homosapien window border theme is entirely different from this issue. That theme has a white border around windows by design. You'll have to either ask the author of the theme about it or change it for yourself.

Bernhard (b.a.koenig) wrote :

Hi Luke, are you sure? I'm not talking about the line around non-maximized windows. I know some themes have that. I'm talking about a maximized firefox window. If you look closely, homosapien has a 1px line horizontally and vertically, whereas human has it only horizontally at the bottom. I'm pretty sure this is not by design. (Sorry, I would post a screenshot, but they hardly show these 1px lines.)

Bernhard (b.a.koenig) wrote :

Yeah, just tested and these lines don't show up in screenshots.

Bernhard (b.a.koenig) wrote :

I managed to capture it somehow, check for the white vertical line at the left:

Bernhard (b.a.koenig) wrote :

As compared to here (you might need a dark background to see it....)

Luke Symes (allsymes) wrote :

Bernhard, the theme is definitely doing this. Do you know how to edit the theme manually? Open up:
/home/$USER/.themes/Homosapien [Small | Medium | Large]/metacity-1/metacity-theme-1.xml
Find the tag that starts like <frame_geometry name="geometry_maximized" ...
Within that, change the left_width and right_width <distance> tags to have value="0". There, no more white border.

Bernhard (b.a.koenig) wrote :

Yes, you are right. It's not a bug in metacity. But I don't understand why human has this 1px bottom in max windows and homosapien has 1px at left, right and bottom. When I download homosapien from http://www.zacbarton.com/homosapien/customizer/ then it doesn't have these 1px lines. Hmm, I might file against gnome-themes-ubuntu.

Bernhard (b.a.koenig) wrote :

OK, filed this under bug 549952.

This Bug is only fixed partially. The white Line is gone, but the behaviour of the borders is still the same. Rightclick still doesn't works on it and it is not possible to change opened Programs when the Pointer is on the outer top or buttom Border.

The white line has been hidden, but this is only an optical workaround. The problem obviously still exists.

Hernando Torque (htorque) wrote :

I can right-click at all edges of the desktop (I couldn't when the border was visible).

Bernhard (b.a.koenig) wrote :

Yeah, works for me. I do not have Thorsten's problems either.

I first thought it was because of my modified radiance.osliner theme. But I've tested it with ambiance and other Themes and it occours on all themes I use. Also, opening "Applications/Places/System" on the top panel doesn't work if I'm on the top line.

I've reinstalled the whole system to be shure that no modifications are the reason for this, but I happens anyway.

Nautilus -q doesn't helps.

Hernando Torque (htorque) wrote :

It's back again.

nautilus:
  Installed: 1:2.31.6-0ubuntu3.1

Changed in nautilus (Ubuntu):
status: Fix Released → New
Luke Symes (allsymes) wrote :

I don't have maverick installed, but i checked out the relevant file of maverick's nautilus:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/maverick/nautilus/maverick/annotate/head:/src/file-manager/fm-desktop-icon-view.c
Line 573 is what had fixed this bug, and it's still there, so I don't know why you would be getting the 1px border. Can anyone else confirm the desktop border is back?

@Hernando: Which theme are you using when you see the desktop border?

Luke Symes (allsymes) wrote :

Need to investigate this upstream commit (although I wouldn't have thought it would affect the desktop...):

Add a border around info bars (#621366): http://git.gnome.org/browse/nautilus/commit/?id=48c0e19e60eee88f38a6e9c7a51211376a4c90f9

Hernando Torque (htorque) wrote :

Like with the original bug, the thickness and color of the border changes with the theme, but it's there for all of them.

Hernando Torque (htorque) wrote :

Compiled Nautilus with that commit reverted and the border is gone. Nice find!

Sebastien Bacher (seb128) wrote :

don't reopen closed bugs when you have similar issues, register a new bug and give reference to the close bug rather...

Changed in nautilus (Ubuntu):
status: New → Fix Released
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.