Ubuntu

nautilus doesn't honor gnome theme

Reported by Paolo Benvenuto on 2009-12-25
188
This bug affects 39 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

Reproduce it:

- open nautilus
- open system - preferences - aspect, theme tab
- click on the various themes: the internal part of nautilus doesn't vary in no aspect, while you expect that the theme affects the various elements that are shown in a nauilus window interior

ProblemType: Bug
Architecture: i386
Date: Fri Dec 25 21:28:33 2009
DistroRelease: Ubuntu 9.10
Package: nautilus 1:2.28.1-0ubuntu3
ProcEnviron:
 LANGUAGE=it_IT.UTF-8
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic-pae
SourcePackage: nautilus
Uname: Linux 2.6.31-17-generic-pae i686

Paolo Benvenuto (donpaolo) wrote :
Chris Johnston (cjohnston) wrote :

Unable to reproduce on 9.10 x64.

Thank you for your bug. I can not reproduce this here, either. If you mean the icon theme by "the internal part of nautilus", then many themes in Ubuntu actually use the same icon theme. Have you tried selecting the theme "Clearlooks"?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Paolo Benvenuto (donpaolo) wrote :

In this moment I can't either reproduce it.

But sometimes, specifically after boot, nautilus uses a different theme than the one that I selected in previous session.

Possibly this is still https://bugs.launchpad.net/metacity/+bug/391070

Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in nautilus (Ubuntu):
status: Incomplete → Invalid
bastafidli (ubuntu-bastafidli) wrote :

I seems to be affected by this defect. I am attaching screenshot of my desktop. Notice that the system toolbar and windows decoration reflect the theme, but interior of the Nautilus windows (and e.g. desktop popup menu) doesn't. This appeared after upgrade to 9.10, it wasn't present on 9.04.

Changed in nautilus (Ubuntu):
status: Invalid → Incomplete
status: Incomplete → New
bastafidli (ubuntu-bastafidli) wrote :

Please let me know what kind of information you need. This defect is intermitent. After login the session is using correct theme but sometimes after a while the Nautilus starts looking differently. I have no deterministic way of reproducing this but if I can provide some information when this occurs I will.

Sense Egbert Hofstede (sense) wrote :

To me this looks like the GNOME Settings Daemon crashed or that the GTK+ engine for the theme you selected isn't installed. Did you receive any errors about that?

bastafidli (ubuntu-bastafidli) wrote :

I have not received any error. Also the Nautilus does reflect the theme majority of the time, just sometimes it come like that. At that time for example even the popup menu on the desktop doesn't reflect the theme even though other windows still do.

Sense Egbert Hofstede (sense) wrote :

bastafidli: Are you using anything related to the translucency caused by enabling RGBA support in GTK+ as described on <http://www.omgubuntu.co.uk/2009/12/lucid-to-get-aero-style-rgba.html> and in bug #491521? If you did (and installed the packages from ppa:ubuntu-desktop/ppa ), then you should take a look in bug #491521.
Why am I asking this? The symptoms you're reporting have shown up previously in relation to these changes.

Changed in nautilus (Ubuntu):
status: New → Incomplete

I am getting this bug.

I am not using "translucency caused by enabling RGBA support in GTK+". I am simply using standard GTK 2.0 themes (I get this problem with any GTK 2.0 theme I try)

Running gnome-settings-daemon in terminal gives me:

^[[Aian@COOLERMASTER2:~$ gnome-settings-daemon
(gnome-settings-daemon:3174): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
(gnome-settings-daemon:3174): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
ian@COOLERMASTER2:~$

Changed in nautilus (Ubuntu):
status: Incomplete → New

@Bastafidli - when you get this problem, is "gnome-settings-daemon" running?

OK, more bad news I'm afraid.

I have been running a Lucid 10.04 test install, and updating it daily (currently at Alpha 2). Everything has been working fine since 10.04 Alpha 1 was first released.

Todays updates on Lucid 10.04 Alpha 2 (21st February 2010) triggered this same bug.

I hope this can help pin down what the problem is.

bastafidli (ubuntu-bastafidli) wrote :

Seems like it is not. My computer is a multiseat setup. Today I have restarted the computer and after I logged in my theme was not present. Then a second user logged in and he has the theme present just fine. When looking for gnome-settings-daemon I see it only for the second user but not for me

bastafidli@computer:~$ ps -elf | grep gnome-settings
1 S fidlibasta 3260 1 0 80 0 - 24877 poll_s 21:56 ? 00:00:01 /usr/lib/gnome-settings-daemon/gnome-settings-daemon
0 R bastafidli 13437 5458 0 80 0 - 760 - 22:03 pts/0 00:00:00 grep gnome-settings

Then I manually run it

miro@gizmo:~$ ps -elf | grep gnome-settings
1 S lindsey 3260 1 0 80 0 - 24877 poll_s 21:56 ? 00:00:01 /usr/lib/gnome-settings-daemon/gnome-settings-daemon
0 R miro 13437 5458 0 80 0 - 760 - 22:03 pts/0 00:00:00 grep gnome-settings
m

bastafidli (ubuntu-bastafidli) wrote :

sorry, my browser messed up. So I manually run it and got

bastafidli@computer:~$ gnome-settings-daemon &
[1] 16981
(gnome-settings-daemon:16983): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(gnome-settings-daemon:16983): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
Unable to find a synaptics device.

bastafidli (ubuntu-bastafidli) wrote :

and third time the charm (sorry again): and my theme is back.

Pedro Villavicencio (pedro) wrote :

closing then, thanks.

Changed in nautilus (Ubuntu):
status: New → Invalid
bastafidli (ubuntu-bastafidli) wrote :

I have has another occurrence of this problem and this time the behavior was different. I have logged in and the theme wasn't applied again. I have started the gnome-settings-daemon and the them came back to windows. But then I used popup menu on the desktop and have noticed that the popup menu didn't have the theme applied. So the theme was applied only partially.

@Pedro - Sorrry, but I don't understand why you mark this bug as "invalid". This is a vaqlid bug. I am still getting the same bug on Karmic, and also on latest Beta builds of Lucid 10.04.

@Pedro - Sorry, but I don't understand why you mark this bug as "invalid". This is a valid bug. I am still getting the same bug on Karmic, and also on latest Beta builds of Lucid 10.04.

@Bastafidli - the error message you describe in #15 is exactly the same as what I get.

Changed in nautilus (Ubuntu):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

the issue is not specific to nautilus is it?

lhotari (lartsa) wrote :

workaround that worked for me: I removed  ~/.gconf/apps/nautilus and killed the nautilus process. After that the problem went away.

willjcroz (willjcroz) wrote :

I can confirm this happens to me also in Lucid final (originally installed from scratch as Beta2). Thanks for the workaround! It occured for me after setting up my 2nd monitor (along with other annoying Gnome issues such as panel items being rearranged). Gnome is really starting to let Ubuntu down IMHO.

willjcroz (willjcroz) wrote :

@ Sebastien Bacher: While my whole desktop got changed back to some kind of default theme after changing my monitor setup (possibly a different bug), I managed to restore the theme using Preferences -> Appearance -> Theme dialog, except for Nautilus. Nautilus is the only app that I have noticed (so far) that did not respond to resetting the theme. Ihotari's workaround worked for me. It seems Gnome are changing the meta-data system from gconf to gsettings and this is likely to do with this problem (http://library.gnome.org/devel/gio/unstable/ch23.html)

@Pedro - OK, perhaps this is a bug with gnome-settings-daemon, rather than Nautilus. I didn't mean to appear rude, but I am not a developer, so I'd don't know which it is (I'm just trying to be helpful, and to report bugs and get issues fixed). If this is a bug in gnome-settings-daemon, then I feel the bug should be passed on to somebody who deals with gnome-settings-daemon, rather than just being marked as "invalid".

@everybody - I'm still getting this bug on Lucid 10.04 final. It has happened with my own icon and GTK2.0 themes, and also with the default Lucid themes.

@Willjcroz - yup, thats exactly what happens to me...

@Ihotari - thanks for suggesting that workaround - I'll give it a try.

@Pedro - just one last thing - I think there is a duplicate bug of this one - see bug 516384 - there is some discussion on that bug thread, which is marked as being a "Nautilus" bug - that is why I was thinking this bug should be marked as a Nautilus bug as well - perhaps both bugs should be marked as a gnome-settings-bug - what do you (and the other folks watching this bug) think?

@ Sebastien Bacher - Sir, I'm just seeking your wisdom on this bug - would you consider this to be a gnome-settings-daemon bug? Or should it be described in another way? Please can you advise. Thanks in advance.

August Karlstrom (fusionfile) wrote :

I am experiencing this bug in Ubuntu 10.04 as described by willjcroz in post 24. I think the bug was triggered when I closed GEdit. A Nautilus window also was open.

August Karlstrom (fusionfile) wrote :

When the bug appeared I had not made any theme changes since the Ubuntu installation. When I opened Appearance Preferences a theme named Custom was selected (with an icon identical to the default Ambiance theme).

bastafidli (ubuntu-bastafidli) wrote :

Every since I followed the fix from #22 I have not encountered this problem. Thank you

bear24rw (bear24rw) wrote :

Had this problem as well. Fix from post 22 worked, thanks

ashgtx (ashwinhgtx-yahoo) wrote :

Fix from post 22 worked. Thanks. On Lucid i386.

bastafidli (ubuntu-bastafidli) wrote :

I actually have to report, that the problem came back, so the fix 22 doesn't fix it for good, but it needs to be repeated.

Mark S. Bentley (msbentley) wrote :

I have this problem on 3 different machines, all running Lucid - removing the .gconf/apps/nautilus and restarting nautilus helps, but some reboots later the problem returns.

Lapppi (k-jenkins) wrote :

Removing the nautilus config file and killing all nautilus processes did the trick here:
rm -vr ~/.gconf/apps/nautilus && killall nautilus
Relevant discussion at ubuntuforums.org: http://ubuntuforums.org/showthread.php?t=1483838

Kenrick Bingham (loxo) wrote :

Same problem here. Fix #22 worked, at least for a while. Lucid i386.

kidknapp (emckidknap) wrote :

Dell Inspiron 1440-Karmic 32x- So I have had this same problem - after rebooting for the first time after installing Amarok- I uninstalled Amarok and ran the fix and it works great - have rebooted multiple times and am having no further issues. However, I wonder if this is a conflict regarding the KDE libraries and how being installed as requisites for other programs may conflict with the gnome-settings daemon for Nautilus as KDE programs don't generally use the Gtk theme. Maybe some of you have cross installed KDE applications?

Its sad that a command-line fix tends to end all discussion on simple bugs like this, but I believe for the end user switching to Linux it is crucial we don't rail people over searching for help for issues they may not even know how to describe. Don't get me wrong, I LOVE the forums and documentation, but some people have no tolerance for pouring over technical documentation when they just want something to WORK - regardless of OS...IMHO...Love, Thank You, Sorry,

kidknapp (emckidknap) wrote :

I'm very sorry- my hypothesis at the moment is incorrect...I have reinstalled Amarok and rebooted and have not recreated the problem. I am curious as to what happened that caused the problem.....

Still getting this problem on Maverick 10.10 Beta.

For the first time ever, I've managed to capture this gnome-settings-daemon crash with Apport and been able to submit a bug report with a full trace:

gnome-settings-daemon crashed with signal 5 in xkl_process_error()

See:

https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/635616

Essence (bryanmcconkey) wrote :

This bug also occours on my system.

First after installing, and switching to the nvidia drivers and enabling my second monitor, all applications lost their theme settings. I eventually 'fixed' this by killing the gnome-settings-daemon and then restarting it. (Changing themes in the appearance settings didn't do it, nor did rebooting).

Occationaly it seems to revert, and restarting the gnome-settings-daemon seems to solve that probelm when it arises.

However, nautilus stays stuck in the 'no theme' state, even thoguh all other applications now seem to honour the theme settings.
Deleting the .gconf/apps/nauilus folder also seems to resovle this issue for now.

Essence (bryanmcconkey) wrote :

PS: I am running 10.10

Vlad Novak (vnovak06) wrote :

I ran across this page as this bug affected me a couple of minutes ago. I'm using 10.10 and I have no idea what caused this bug to occur. I'm using some eye-candy gnome theme from external repository and all out of a sudden it started changing and the theme was lost. When I restored it via right click on desktop Change Desktop Background -> Themes, it was restored but Nautilus just wouldn't respect it.

Killing the nautilus process fixed it.

Alexander Telenga (telenga) wrote :

This bug affects me too. I've got this behaviour after reboot despite of I've got ~/.gconf/apps/nautilus removed.

I just experienced this for the first time (Ubuntu 10.10 AMD64). Nautilus came up with a theme that reminded me of motif (gag). The suggestion by lhotari in #22 was effective in clearing it.

@Alexander Telenga: to make it work, you need to go to a shell and do "ps aux | grep nautilus" (without the quotes) and note the PID of the nautilus process. It will look something like this:

your-user-id 2538 0.1 1.0 744556 42208 ? Sl 14:00 0:08 nautilus --sm-client-id 10f1e5588b647711d7128888650527035500000018260031 --sm-client-state-file /home/jonathan/.config/session-state/nautilus-1294783068.desktop

The PID is in the second column, and it is 2558. Then, in the same shell, type "kill 2558" (again, without the quotes).

Make sure that ~/.gconf/apps/nautilus is still gone (it should be; never came back on my system).

The start Nautilus and it should now honor the system theme.

HTH,

Jonathan

SirPecanGum (sirpecangum) wrote :

#22 seems to have fixed it for me too. I'm using 10.10. Thanks!

Sebastien Bacher (seb128) wrote :

the comment #22 is not a fix just a workaround and removing the configuration is not required, just restarting nautilus should be enough

Orbital_sFear (orbital-sfear) wrote :

My issue wasn't fixed until I restarted gnome-settings-daemon.

Here's what I did, it works 100% of the time, but its a total hack.

Go in synaptic, reinstall nautilus.

I made a one liner shell script that runs when my computer starts:
sleep 5; ps -aef | grep gnome-settings-daemon | grep -v grep | awk '{ print $2 }' | xargs kill -9; sleep 2; gnome-settings-daemon

This completely 'fixed' the problem, but again, total hack and would like to know why gnome-settings-daemon is having issues in the first place.

-Orbital

Ben Klaasen (ben-fluidlogic) wrote :

I'm a fresh install of 10.10 on a Samsung NC10 Atom-powered netbook. This issue has just started to affect me. Applying the fix described in comment 22 and restarting gnome-settings-daemon didn't fix the problem.

calimocho (d-martinez7) wrote :

I'm seeing this too.
I think the commens that suggest the problem is outside of nautilus could be right -
I haven't seen any pattern to this, but sometimes when i boot up, my theme isn't applied to ANY of gnome (default icon theme, default color scheme, default window controls). If I open Preferences->Appearance, most of the theme gets instantly applied (i.e. with just opening that program, not changing any settings). However, even after that, nautilus doesn't change. The workaround suggested in comment 22 does make nautilus display correctly for me.

Keith Drummond (victor9098) wrote :

This is occurring on my system too on virtually every boot up. Only way to restore correct settings is by killing nautilus. Have tried deleting my nautilus folder, adding the delay, reinstalling, even tried the elementary tweaked version of nautilus but the problem still persisted.

Current version of nautilus is 1:2.32.0-0ubuntu1.3
Running on Ubuntu 10.10

Keith Drummond (victor9098) wrote :

I can confirm that this still occurs in Ubuntu Natty Beta.

thinkpad (fellowsgarden) on 2011-05-03
tags: added: maverick natty
thinkpad (fellowsgarden) wrote :

duplicate of 574296 ?

https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/574296

~.~.~

I noticed that this (probably) only happens when I start my IBM Thinkpad X41 (with SSD) on _BATTERY_ power.

If I start with AC adapter plugged in, however, everything seems to be fine...

Reproducible: likely so (will keep observing, but won't restart system several times now).

Thanks.

tp

Rolo (rolo-wildfish) wrote :

Does you X41 have Optimus switchable graphics? Most likely the machine will use the integrated graphics rather than discrete when on battery power. You can test that this is what's causing it by switching to constantly use discrete or integreated in the BIOS (watch out for the BIOS option which automatically sets it back to optimus as well)

Not sure if that's of use.

Maxime R. (max.r) wrote :

I was also affected by this bug after a reboot under 11.04.
Fix #22 did not solved the problem.
Fix #47 solved it.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Paolo Benvenuto (donpaolo) wrote :

still affects 11.04 in gnome classic mode

@ Paolo - I'm still getting this in GNOME Classic mode on 11.04 too...

Justin Young (mathman316) wrote :

I see this intermittently as well. I'm using 11.04 Classic on a Dell laptop.

Usually this occurs when I wake up the computer after it was suspended, especially if it was not docked when suspended, and then I dock to wake it up. (The dock has an external monitor attached.)

Restarting nautilus worked for me, though I've only tried it once. Previously I logged out and back in, which also worked.

Justin Young (mathman316) wrote :

More specifically, sometimes after a wake-up my entire theme is wrong, and it looks like a default Gnome theme has been applied. Re-selecting my theme in Appearances fixes everything except Nautilus itself (i.e., the title bar is fixed, but not the "internal" window). So I see the same behavior as initially reported.

Heres what I got from one such instance of this bug a while back. Anybody else getting anything similar?

ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcCwd: /
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
Signal: 5
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/libgdk-x11-2.0.so.0
 xkl_process_error () from /usr/lib/libxklavier.so.16
 _XError () from /usr/lib/libX11.so.6
 ?? () from /usr/lib/libX11.so.6
 _XReply () from /usr/lib/libX11.so.6
Title: gnome-settings-daemon crashed with signal 5 in xkl_process_error()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (bluetooth-applet:1829): Gtk-CRITICAL **: IA__gtk_widget_set_sensitive: assertion `GTK_IS_WIDGET (widget)' failed
 (polkit-gnome-authentication-agent-1:1854): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1813): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

Vincent Tschanz (fogia) wrote :

I have the same problem here in fresh install of 11.10 after adding the ubuntu-x-swat for my nvidia gtx 570 who was not recognized by the system.

terminating the nautilus process resolved this.

entonjackson (aj-mysc) wrote :

Same problem continues on Precise Pangolin 64bit.
Good luck ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers