Ubuntu

Gnome theme not applied on session start

Reported by João Pinto on 2010-05-03
346
This bug affects 73 people
Affects Status Importance Assigned to Milestone
gnome-settings-daemon (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-session

The problem is happening on my desktop with a high frequency but is not 100% reproducible. It usually happens on the first login after booting the system and can be fixed with a re-login.
The gnome theme simply fails to get applied, I get a working system but with a stock GTK theme.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-session 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Mon May 3 09:47:13 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=pt:pt_BR:en
 PATH=(custom, user)
 LANG=pt_PT.utf8
 SHELL=/bin/bash
SourcePackage: gnome-session

João Pinto (joaopinto) wrote :
affects: gnome-session (Ubuntu) → gnome-settings-daemon (Ubuntu)
João Pinto (joaopinto) wrote :

I have enabled apport and added "-sync", I hope to catch the crash and eventually file a new bug from apport .

Wes (wesley-neo) wrote :

How do I reload the theme if it fails at startup? I mean, without logging in again.

Id2ndR (id2ndr) wrote :

This bug is probably a duplicate of Bug #588155.

@Wes : just run gnome-settings-daemon (you can use alt-f2 for example)

Alex Black (alex-alexblack) wrote :

I think I'm experiencing this bug too. In the past few weeks, I've installed Ubuntu 10.10 x64 desktop on brand new self-built machines. One of the first things I did to each was to activate the Nvidia driver, once I rebooted, themes no longer seem to be applied, the UI looked like 9.04.

Details:
http://askubuntu.com/questions/11406/gnome-settings-daemon-doesnt-apply-themes-unless-i-kill-it-and-start-it-manuall
http://askubuntu.com/questions/14115/xsession-errors-is-2-7gb-big-and-growing-on-fresh-install-caused-by-gnome

Issue:
- (everytime) when I log in, the UI appears to have no theme, and looks old school like 9.04
- if I kill gnome-settings-daemon, and then invoke it manually from the command line, the themes then get applied, except in the file viewer (nautilus) it seems

Got the same problem here on a clean install of Maverick. Attaching my session-errors.
I'm left with no theme applied when this happens. I never got this problem some time after the bootup. Either I get the theme or not at all (1/10 times).

..edrik (fr-edrik) wrote :

Is a common factor here that Ubuntu is running on a SSD drive?

If so, it's most likely the same issue reported in bug #625670 and bug #649809 as well.
Affecting reasonably fast setups like Core i7 and an SSD boot drive. With the scenario that gnome-settings-daemon is running fine after startup but the theme setting are not applied.

Alex Black (alex-alexblack) wrote :

Yes, both my installs were on computers with SSD drives and i7 cpus.

lucaf (luca-lucarol) wrote :

I have the same problem on a self-built computer with SSD and i7 cpu.

Rory Kurek (barry3000) wrote :

I'm also getting the same error with an i7 CPU and and SSD. As suggested in the thread above, I killed and restarted gnome-settings-daemon, which restored the panel theme. However, changing the theme in the Appearance window would not change the skin for the panel. As you can see, the rest of the theming is messed up as well. After a reinstall, it seemed like I could avoid the bug by not installing the fglrx drivers for my Radeon card, but after a while, the bug showed up anyway. May try installing to a new partition on a mechanical drive in the next few days just to see what happens.

Laurent Dinclaux (dreadlox) wrote :

Could that be related to SSD HDD ??? I have the same problem: I changed my HDD for a SSD and did a fresh install (3 in fact....)

Maybe SSD is too fast for Ubuntu?

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Oleguer Huguet (olegueret) wrote :

This started to happen to me yesterday, but I don't hive a high end system: it's a Intel(R) Pentium(R) Dual CPU E2160 @ 1.80GHz with a normal hard disk (not SSD)

When staring gnome-settings-manager from the console to solve it, I see this warning:

oleguer@moria:~$ Unable to find a synaptics device.

** (gnome-settings-daemon:2019): WARNING **: Got less number of items in credentials hash table than expected!

Oleguer Huguet (olegueret) wrote :

I meant gnome-settings-daemon in previous post

Arno Dirlam (arnodirlam) wrote :

Got the same problem since some days ago.
But my laptop is 4 years old, has SATA drive and Intel Core 2 Duo CPU.
I usually use "sudo /etc/init.d/gdm restart" and then the themes are applied.
Would love to get updates on the issue! :-)

Same problem here. And I'm using a SATA HDD and a slow processor.

I think that is a problem related to the hard drive disc (because the boot is slow, and this happens). But I've already checked the filesystem and it's clean. I don't know what to do.

The relevant part of lshw (the complete log is attached):

     *-cpu
          description: CPU
          product: Intel(R) Atom(TM) CPU N270 @ 1.60GHz
          vendor: Intel Corp.
          physical id: 4
          bus info: cpu@0
          version: 6.12.2
          serial: 0001-06C2-0000-0000-0000-0000
          slot: PBGA 437
          size: 1600MHz
          capacity: 1600MHz
          width: 32 bits
          clock: 133MHz
          capabilities: boot fpu fpu_exception wp vme de pse tsc msr pae mce cx8
 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx c
onstant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl est tm2 s
sse3 xtpr pdcm movbe lahf_lm cpufreq
          configuration: id=0
        *-storage
             description: SATA controller
             product: 82801GBM/GHM (ICH7 Family) SATA AHCI Controller
             vendor: Intel Corporation
             physical id: 1f.2
             bus info: pci@0000:00:1f.2
             logical name: scsi0
             version: 02
             width: 32 bits
             clock: 66MHz
             capabilities: storage msi pm ahci_1.0 bus_master cap_list emulated
             configuration: driver=ahci latency=0
             resources: irq:43 ioport:d080(size=8) ioport:d000(size=4) ioport:cc00(size=8) ioport:c880(size=4) ioport:c800(size=16) memory:f7db7800-f7db7bff

alexpennos (pennos) wrote :

This bug affects me too. I am running 10.10 on a Dell with core i7.

Rookie-mp (rookie-mp) wrote :

Apparently I am not the only one with this issue. It appears on my laptop with NVIDIA drivers (mesa experimental, not the proprietary ones), but not on my netbook with ATI drivers (again, not proprietary).

dino99 (9d9) wrote :

have the same issue here too. But i think its happening for the same reason described in report bug 439448 # 335
( maverick/natty theme race/conflict on a single shared /home)

João Pinto (joaopinto) wrote :

din99,
thanks for your willingness to help resolving this bugs, but your assessment is incorrect, please read the previous comments before adding your own to a bug report, many of the reports for this bug just as for bug 439448 are from people with a single home, single release configuration.

There maybe issues resulting from running multiple releases with a shared home, that is related to how different application versions manage their data/settings, such issues (which seems to be your case) are not related to the bugs being reported.

mitch (mitch-embry) wrote :

I had this same issue on my i7 box (no SSD though) in both Ubuntu 10.10 and Linux Mint 10. I was able to fix the issue by following the solution posted here <https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/649809> post #68 which adds a short delay to the daemon loading on startup.

Basically it involves editing /etc/xdg/autostart/gnome-settings-daemon.desktop and changing line 4 to:

Exec= bash -c "sleep 2; /usr/lib/gnome-settings-daemon/gnome-settings-daemon"

Hope this helps.

The above workaround didn't help me. Core i7 & SSD.

The daemon doesn't crash - it requires a SIGKILL and then manual re-launching. This happens *every* time I login, in natty.

Also, if you send SIGTERM, the process just does this over and over:
write(2, "\n(gnome-settings-daemon:3263): G"..., 116) = 116
write(2, "\n(gnome-settings-daemon:3263): G"..., 113) = 113
write(2, "\n(gnome-settings-daemon:3263): G"..., 116) = 116
write(2, "\n(gnome-settings-daemon:3263): G"..., 113) = 113
write(2, "\n(gnome-settings-daemon:3263): G"..., 116) = 116

A trace of the misbehaving gnome-settings-daemon looks the same as a functioning one, sadly :(
(it's just polling various file descriptors)

Sanjeev Sharma (swtbase) wrote :

I think the problem is two instances of 'gnome-settings-daemon' being run. Normally, they had to be run one after another.

The following fixed the problem for me:

Step 1: Create a script (I called it gnome-settings-daemon-fix.sh) under /etc/xdg/autostart with the following:
#!/bin/bash
# gnome-settings-daemon-fix.sh

pid='pgrep gnome-settings-'
wait pid

exit 0

Step 2: Edit 'gnome-settings-daemon.desktop' under 'Exec=' entry and replace it with:
Exec=bash -c 'bash /etc/xdg/autostart/gnome-settings-daemon-fix.sh ;/usr/lib/gnome-settings-daemon/gnome-settings-daemon'

6 restarts show this works. But can somebody report if this worked for you?

My system is Dell XPS 14 with I7 processor and Ubuntu installed with Wubi. The problem seemed to occur after installing NVIDIA drivers but as I installed these drivers immediately after I installed Ubuntu, I cannot confirm.

Sebastien Bacher (seb128) wrote :

comment #23 seems to describe an issue similar to bug #649809

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

note that the original description shows that gsd crashes with a badmatch error which is different from the issue described in comment #23

This bug is the same that bug #649809 (which already has a proposed solution).

For those that are experiencing this problem, please install the gnome-settings-daemon package from the ppa https://launchpad.net/~rodrigo-moya/+archive/ppa.

The proposed solution on ppa will be uploaded to natty repository soon, but I don't know if it will be backported to maverick.

Sorry, as Sebastien said, the original bug is *not* the same that bug #649809.

Anyway, probably the people that are having problems with theme at startup, are experiencing bug #649809.

Sanjeev Sharma (swtbase) wrote :

EDIT to comment #23:

Please excuse my newbieness with Linux systems but the shell script that I was intending had to be (and also if someone didn't know its executable bit must also be enabled by using chmod):

----------------------------------------------------------------------------------------------------------------------------------
#!/bin/bash
# gsettingsdaemonfix.sh

pid=$(pgrep gnome-settings-)

# if [ -n "$pid" ]
# then
# ps $pid &> /home/sanjeev/Desktop/gnomesettingsdebug1.txt
# else
# echo "No previous instance of gnome-settings-daemon running!" &> /home/sanjeev/Desktop/gnomesettingsdaemondebug.txt
# fi

while [ -n "$pid" ];
do
        pid=$(pgrep gnome-settings-)
        sleep 0
done

exit 0

----------------------------------------------------------------------------------------------------------------------------------
Turns out 'wait' only works for child processes. I wonder why.

Enabling the 'if' comments will output some useful information about previously running instance (be sure to change the path as according to your system). I also changed the name of the script from 'gnome-settings-daemon-fix.sh' to 'gnomesettingsdaemonfix.sh' as pgrep couldn't distinguish between process name of the running script and process name of the daemon as it compares only 15 characters of process names (Again, I cannot explain this). Hence, the edited 'gnome-settings-daemon.desktop' should be:

----------------------------------------------------------------------------------------------------------------------------------
[Desktop Entry]
Type=Application
Name=GNOME Settings Daemon
Exec=bash -c 'bash /etc/xdg/autostart/gnomesettingsdaemonfix.sh ;/usr/lib/gnome-settings-daemon/gnome-settings-daemon'
OnlyShowIn=GNOME;
NoDisplay=false
X-GNOME-Autostart-Phase=Initialization
X-GNOME-Autostart-Notify=true
X-GNOME-AutoRestart=true
X-Ubuntu-Gettext-Domain=gnome-settings-daemon
----------------------------------------------------------------------------------------------------------------------------------

I captured the following about the previously running instance of settings daemon:
  PID TTY STAT TIME COMMAND
 1514 ? Ds 0:00 [gnome-settings-]

Collision between this instance and the instance run by '.desktop' file may be the cause of the theme problem in my system. This solution seems to be working for me.

Changed in gnome-settings-daemon (Ubuntu):
importance: Low → High
thinkpad (fellowsgarden) on 2011-05-03
tags: added: maverick natty
thinkpad (fellowsgarden) wrote :

I noticed that this (probably) only happens when I start my IBM Thinkpad X41 (with SSD) on _BATTERY_ power.

If I start with AC adapter plugged in, however, everything seems to be fine...

Reproducible: likely so (will keep observing, but won't restart system several times now).

Thanks.

tp

Changed in gnome-settings-daemon (Ubuntu):
importance: High → Low
Michał J. Gajda (mgajda) wrote :

May it be related to or duplicate of https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/521766?

It seems that the bug is affecting many people, and newbies may not be comfortable with "killall gnome-settings-daemon; gnome-settings-daemon & nautilus -q" as a solution.

Thomas N (konstigt) wrote :

I also get this from time to time. Have had this bug a very long time, 1-2 years. Always fixable with killing gnome-settings-daemon and restarting it.

Thomas N (konstigt) wrote :

After rebooting a couple of times I noticed that I have the same issue as comment #29 , it only happens on battery!

thinkpad (fellowsgarden) wrote :

@ ThomasNovin: thanks for reading my post and noticing it too.

By now I can say:
Reproducible: YES.

Since I mainly do standby (especially when on the go) and can boot on AC Power (when eventually / occasionally I decide to (re-)boot)), this problem doesn't really affect me much.

Only when I forget to boot and find myself needing to boot on battery I'm in a bit of a trouble.

But I guess I can refer back to above posts about killing and restarting gnome-settings-daemon to help me out then...

tp.

thewade (wade-penner) on 2011-09-22
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers