Ubuntu

should ask confirmation before opening a multiple items selection

Reported by G. Ney on 2009-09-13
46
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Medium
One Hundred Papercuts
Low
Marcus Carlson
nautilus (Ubuntu)
Low
Unassigned

Bug Description

When you select multiple files in Nautilus and accidentally open them (by wrong click, by Intro key...), Nautilus tries to open all of them at once in multiple instances of the default application. This can make your system totally unresponsive and force you to do a hard restart if they are many (try with 2.000, for example) or they are heavy (video, for example). Even if it doesn't come to that, it's annoying to have to close then one by one.

In Windows if you try to open many files at once there is a warning ('You are trying to open multiple files', I think), giving you the option to cancel or open them anyway. I think Nautilus should do the same. After all, how often do you need to open 20 files at once?

To have an option to close all open instances of an app at once would be very usefull too.

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: https://bugzilla.gnome.org/show_bug.cgi?id=596577

summary: - accidental opening of many documents at once
+ should ask confirmation before opening a selection
Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Triaged
summary: - should ask confirmation before opening a selection
+ should ask confirmation before opening a multiple items selection
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in hundredpapercuts:
assignee: nobody → Marcus Carlson (0-launchpad-mejlamej-nu)
Changed in nautilus:
status: Unknown → New
Sense Egbert Hofstede (sense) wrote :

This would make a good paper cut, so I'm accepting it with the status 'Low'. Thank you for submitting this bug.

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Triaged
Vish (vish) on 2010-06-13
tags: added: nautilus
Vish (vish) on 2010-06-16
Changed in hundredpapercuts:
milestone: none → maverick-round-1-file-management
Kenneth Venken (kenneth-venken) wrote :

In stead of popping op a dialog asking the user to proceed (requiering another click), i think it would be better to have a dialog showing the progress and have the ability to abort the operation if needed.

X (axcoro) wrote :

i think it's highly inappropriate, imagine a low resources computer that by accident tryes to open 50 .mkv and the pc become overloaded..

Vish (vish) on 2010-06-28
tags: removed: nautilus
Changed in nautilus:
status: New → Confirmed
Vish (vish) wrote :

This has now been fixed upstream

Changed in hundredpapercuts:
status: Triaged → Fix Committed
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now...

Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in nautilus:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

the current upstream changes
http://git.gnome.org/browse/nautilus/commit/?id=525b54d9a2385efdae21fd0b0da3631ba0071ce1
http://git.gnome.org/browse/nautilus/commit/?id=6d91cfb1d053a433cc5e17336c2e22c4e1d71673

have issues, it will display a "do you really want to open those files, that will open 1 application" when selecting a bunch of videos which would normally just being queued in the player playlist, seems it will need work and not worth backporting now

Vish (vish) on 2010-08-10
tags: added: nebulous
Changed in nautilus:
status: Fix Released → Confirmed
Vish (vish) on 2010-08-23
tags: added: natty
removed: nebulous
Changed in nautilus:
importance: Unknown → Medium
Omer Akram (om26er) wrote :

setting this bug back to triaged since the upstream bug was re-opened

Changed in nautilus (Ubuntu):
status: Fix Committed → Triaged
Vish (vish) on 2010-11-23
Changed in hundredpapercuts:
milestone: maverick-round-1-file-management → nt4-nautilus
status: Fix Committed → Triaged
Changed in nautilus:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

The issue should be fixed in the Oneiric version

Changed in hundredpapercuts:
status: Triaged → Fix Released
Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
Timothy Arceri (t-fridey) wrote :

This is not fixed please reopen. As I commented upstream that last patch was a regression.

Steps to reproduce:

Copy 6 .jpg images into a directory.
Also copy a .txt file our something that will be opened by a different application.

Make Shotwell the default image viewer ( shotwell opens multiple instances for each file selected ).

Select all 6 jpg files right click and open with shotwell. Six instances of shotwell are opened NO warning.

Now this time select all the files. This time select the text file as well and select open. You have a warning now but it says two applications will be opened???
1. Why am I being warned if it really was only two applications being opened?? Surely 2 is not something to be warned about
2. Its really 7 instances being opened.

Timothy Arceri (t-fridey) wrote :

Note that the warning is given when more that 5 files are being opened thats why I suggest 6 jpg files.

Timothy Arceri (t-fridey) wrote :

Just fyi closed bugs reported in launchpad can now only be opened by package maintainers and bug reporters which I think is a very poor solution. Please see https://bugs.launchpad.net/launchpad/+bug/887875 for more info.

Sebastien Bacher (seb128) wrote :

> Just fyi closed bugs reported in launchpad can now only be opened by package maintainers and bug reporters which I think is a very poor solution.

No, it's an excellent solution, it's easy enough for maintainers to reopen a bug when new comments are added and it avoids having years old closed bugs reopened randomly by users who think they have "the same issue" when they clearly don't

Changed in nautilus (Ubuntu):
status: Fix Released → Triaged
Changed in nautilus:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.