nautilus-home.desktop silently fails to open home directory when is called by process started early at session startup

Bug #387723 reported by Jan Nekvasil on 2009-06-16
This bug affects 21 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Nautilus 1:2.26.2-0ubuntu2 silently fails to open user's home directory when is called trough
/usr/share/applications/nautilus-home.desktop by a process started early at the GNOME session startup.

This is bug heavily affects the GNOME Do's Files and Folders plugin - when GNOME Do is set to start with the session, opening home dir by it latter fails, showing only "Starting Home Folder" on taskbar for a few seconds, no further erros emmited. See bug 290136.

This can be easily solved by changing line 6 in /usr/share/applications/nautilus-home.desktop from "Exec=nautilus --no-desktop" to "Exec=nautilus --no-desktop .". Notice the whitespace and the dot at the end, pointing to the current directory, which is in this case user's home.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the command is correct though so that seems rather a gnomedo issue, why do you think it's a bug in nautilus?

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Jan Nekvasil (jan-nekvasil) wrote :

Try this:

sudo ln -s /usr/share/applications/nautilus-home.desktop /etc/xdg/autostart

Expected result: Home folder being opened in Nautilus at session startup.
Actual result: "Starting Home Folder" appears in taskbar at startup for a while, but no Nautilus window opens.

Change /usr/share/applications/nautilus-home.desktop as suggested, log out, log in, it works.
Revert the change, relog again, it doesn't.

Robert Dyer (psybers) on 2009-06-18
Changed in do:
importance: Undecided → Low
status: New → Invalid
Kim Alvefur (zash) wrote :

This could be solved by copying nautilus-home.desktop into $HOME/.local/share/applications/ and adding $HOME to the Exec line, perhaps on first login.

Jan Nekvasil (jan-nekvasil) wrote :

Still present in Karmic Beta.

Easy to fix, just add that one whitespace and one dot in /usr/share/applications/nautilus-home.desktop as I mentioned above in original report. It will be smallest patch ever, solves the problem for many, breaks nothing. What's the big deal? Who cares if it's gnome-do's or nautilus fault, people wants the things just works, That's called workaround or dirty hack. Ubuntu (and other OS's too) is just full of them, one more (till the real cause is found out solved) hurts nobody.

metchebe (metchebe) wrote :

I can confirm that this still happens with nautilus 2.28.1-0ubuntu3. I have to resort to Jan's fix to be able to use Gnome-Do, since it is very annoying.

Setting the bug to "triaged", since there is an upstream bug.

Changed in nautilus (Ubuntu):
status: Incomplete → Triaged
Michalxo (michalxo) wrote :

This bug is still in karmic. I had to add there "." to make it functional. It has not been "triaged" yet.
New installed karmic + up to date.

bwat47 (bwat47) wrote :

this still happens in lucid...

Changed in nautilus:
status: Unknown → New
Changed in nautilus:
status: New → Incomplete
Changed in nautilus:
importance: Unknown → Low
status: Incomplete → Confirmed
Changed in nautilus:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.