Ubuntu

'Open With' Nautilus list is unsorted

Reported by Gavin Hamill on 2009-04-13
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Low
One Hundred Papercuts
Undecided
Unassigned
nautilus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Package: nautilus
Version: 1:2.24.1-0ubuntu2

Ubuntu Intrepid

TESTCASE: I have .m4a files which Audacious can play, but although Audacious is installed, it's not listed on the 'Open With' list in Properties.

When I press 'Add' on the 'Open With' tab, I am given a list of all registered applications, but they are not sorted in any obvious or logical order - can they be sorted alphabetically, please?

I appreciate it is possible to find the application by typing the first few letters of its name, but this is far from intuitive for a GUI.

Related branches

Pedro Villavicencio (pedro) wrote :

thanks for the report Gavin, that's known upstream you can track it here: http://bugzilla.gnome.org/show_bug.cgi?id=547749

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Triaged
Changed in nautilus:
status: Unknown → New
Changed in nautilus:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

The list is sorted by most likely candidate, ie you get the applications corresponding to the file you want to open first and then other things, it's not clear that prefering alphabetic order and listing applications not working on the file first would be a win there

Gavin Hamill (gdh) wrote :

First, let's be sure we're talking about the same thing... I am referring to Right click -> Open With -> Open With Other Application, at which point a scroll list opens with the option to 'Use a custom command'. (the options in the first 'Open With' menu are indeed the 'most likely' ones and seem to work fine)

If so, then this seems to be a 'do what I'm thinking' feature.

Taking a single example, right clicking on a .txt file and selecting Open With -> Open With Other Application showed me a list which, on the first page, offers me 'Disc Burner' 'F-Spot Photo Viewer' and 'Rhythmbox Music player' amongst others.

Yet, if I scroll down a page, I can choose Document Viewer.. and if I scroll right to the bottom, I can choose Openoffice Writer - an application I might actually want to open a text file with.

I fail to see how this is either logical, or more importantly, intuitive. To me it is confusing, to a new user it must be at best a bug, and at worst elitist.

I have noticed that most applications do a very poor job of specifying supported
  MIME types, which would cause OpenOffice to not be suggested for opening a
.txt file as Gavin mentions. If there's a good chance that we will fail to make
good suggestions, alphabetizing the list of applications may turn out to be more
usable.

Sebastien Bacher (seb128) wrote :

the clever ordering seems to not be working in the current version or that was something which has been discussed but not implemented, what would be the best option though, to sort thing in alphabetic order or to try to present most likely choice at the start of the list?

Ricardo Pérez López (ricardo) wrote :

What about both? The list could have two sections separated by an horizontal line:

- the most likely candidates
  <a separator line>
- all the remaining options in alphabetical order

Darren Worrall (dazworrall) wrote :

I was going to suggest the same as Ricardo - A handful(max 5?) of likely candidates, a separator, and the remaining applications - each list sorted independently.

Gavin Hamill (gdh) wrote :

The 'top 5' should already be covered by the handful of 'Right click -> Open With -> Open With "Application Name"' . If the user has gone as far as 'Open With -> Open With Other Application' then an alpha-sorted list of all apps seems to be the only logical choice.

FWIW, Windows users will expect an alpha-sorted list given the operation of Windows' own 'Open With...' facility

A. Walton (awalton) wrote :

Patch attached upstream, but I'm going to have to commit it later (long shift at work here). Might want to review it though.

A. Walton (awalton) wrote :

Committed the fix upstream.

Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.27.2-0ubuntu1

---------------
nautilus (1:2.27.2-0ubuntu1) karmic; urgency=low

  * New upstream release: (LP: #387266)
    - Support ctrl-drop in list view (LP: #261108)
    - Allow user defined keyboard shortcuts for extension items
    - Fix crash on click on toolbar (LP: #375927)
    - Fix crash on entering empty location (LP: #378254)
    - Added daemon-mode (don't exit with last window)
    - Display info about the selected item in the information sidebar
      (LP: #23734)
    - Sort applications in open with (LP: #360553)
    - Fix text going dark if setting dark background (LP: #356289)
    - Update nautilus website url in about dialog (LP: #374555)

 -- Didier Roche <email address hidden> Mon, 15 Jun 2009 13:33:53 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: New → Fix Released
Changed in hundredpapercuts:
milestone: none → round-1
Changed in hundredpapercuts:
assignee: nobody → Matthew Paul Thomas (mpt)
Changed in hundredpapercuts:
assignee: Matthew Paul Thomas (mpt) → nobody
Changed in nautilus:
status: Confirmed → Fix Released

I had an entry in ubuntubrainstorm [*] about that but never thought of having a look/ reporting it in Launchpad.
Thanks for this one.

[*] http://brainstorm.ubuntu.com/idea/14296/

John Franklin (hondaman-nc) wrote :

Is this going to be released for Jaunty as well? I am still stuck with 1.2.26.2-0ubuntu2. Is there a PPA which contains the updates?

Sebastien Bacher (seb128) wrote :

> Is this going to be released for Jaunty as well?

No, that's a minor annoyance and not a candidate for a stable update

This may be a bit late, but I have a fairly similar problem. I have wine installed and when I want to set the default program for a pcap file (used with Wireshark), I see around fourty listings of "A wine application" and 10 listings of "Adobe Photoshop CS2" as well as "hh" (whatever that is).

Changed in nautilus:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.