Ubuntu

rhythmbox doesn't go directly to track-listing when autostarted by inserting an audio cd

Reported by Jackflap on 2008-11-18
50
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
Won't Fix
High
One Hundred Papercuts
Undecided
Unassigned
Rhythmbox
Invalid
Low
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: rhythmbox

When you insert an audio cd, the auto-run dialog comes up asking if I want to open it with Rhythmbox as default.

Clicking OK, opens Rhythmbox, but the default display is on my Library, and not on the Audio CD.

Ideally, Rhythmbox should open on the Audio CD pane, displaying the cd's track-listings.

Running Intrepid.

Changed in rhythmbox:
importance: Undecided → Wishlist
Pedro Villavicencio (pedro) wrote :

thanks for sent it upstream.

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: New → Triaged
Jackflap (deriziotis) wrote :

Actually, I've just realized that this bug is within Ubuntu, and not rhythmbox itself.

Running 'rhythmbox file:///dev/scd0' starts up rhythmbox with the selected pane on the Audio CD as expected.

This means that the issue isn't with rhythmbox, but with the way Ubuntu auto-runs the cd. This is easily fixable by running a manual command, entering the rhythmbox command above and setting that as the default action when a cd is inserted.

However, this should be fixed by default within Ubuntu itself.

Changed in rhythmbox:
status: Unknown → Invalid
Sebastien Bacher (seb128) wrote :

the issue could also be your user settings, what command do you use to play cds?

Jackflap (deriziotis) wrote :

I don't run a command, I put in the CD in the drive and an autorun dialog pops up on the desktop which defaults to open the cd with rhythmbox.

Clicking OK opens rhythmbox, but the focus isnt on the cd, but on the library. I haven't changed anything in my settings, this is default Intrepid behaviour.

Jackflap (deriziotis) on 2009-01-07
Changed in rhythmbox:
status: Triaged → Invalid
Changed in nautilus:
assignee: nobody → desktop-bugs
Pedro Villavicencio (pedro) wrote :

why did you opened a nautilus task? closing it since no information was given about that.

Changed in nautilus:
status: New → Invalid
Jackflap (deriziotis) wrote :

Sorry about that, I guess I should have commented.

I emailed desktop-devel-discuss to see what package this should go since it's not actually a problem with rhythmbox and someone said that the autorun dialog is a part of nautilus, so the bug should go to nautilus.

I believe this is an issue upstream, and will file a bug upstream when I get some time.

Changed in nautilus:
status: Invalid → New
Jackflap (deriziotis) on 2009-01-07
Changed in nautilus:
assignee: desktop-bugs → nobody
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus:
status: Unknown → Confirmed
Josh Holland (jshholland) wrote :

There is a similar issue with opening music files from nautilus in rhythmbox. If I double-click an mp3 file, my library starts playing. This is not what a user (or I) want.

Changed in rhythmbox:
status: Invalid → Triaged
Shahar Or (mightyiam) wrote :

I've commented upstream because it has been more than 10 months since the last comment about this.

Fermat (821152578-qq) wrote :

find the rhythmbox.desktop file in the ~/.local/share/applications/ dirctory or some other place such as /usr/share/applications/ and open the file and find the line
Exec=rhythmbox %U
and change it to
Exec=rhythmbox %f
and things are OK now.

I had the same problem and solve it in the way up.

Thanks so much for your assitance. Problem solved. Good wishes.

On Mon, Sep 14, 2009 at 3:19 AM, Fermat <email address hidden> wrote:

> find the rhythmbox.desktop file in the ~/.local/share/applications/
> dirctory or some other place such as /usr/share/applications/ and open the
> file and find the line
> Exec=rhythmbox %U
> and change it to
> Exec=rhythmbox %f
> and things are OK now.
>
> I had the same problem and solve it in the way up.
>
> --
> rhythmbox doesn't go directly to track-listing when autostarted by
> inserting an audio cd
> https://bugs.launchpad.net/bugs/299395
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Patrick (veinor) on 2009-10-03
Changed in hundredpapercuts:
status: New → Confirmed
Changed in nautilus:
importance: Unknown → High
Changed in rhythmbox:
importance: Unknown → Low
Vish (vish) wrote :

 - In Ubuntu 11.04, Rhythmbox will no longer be part of the default install. Hence not a papercut.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.
Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: Confirmed → Invalid
Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in nautilus:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.