[wayland, < disco] can't drag file from desktop to folder window

Bug #1704765 reported by Adam Dingle on 2017-07-17
312
This bug affects 73 people
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Medium
nautilus (Ubuntu)
High
Unassigned

Bug Description

I'm running Ubuntu 17.10 (Artful). If I create a text file on my desktop and then attempt to drag it into a Nautilus folder window, it fails: when I release the mouse cursor over the folder window nothing happens and the file is not moved.

Khurshid Alam (khurshid-alam) wrote :

Gnome wayland sesssion? It works fine in Unity.

Adam Dingle (adam-yorba) wrote :

Yes, I see this when logged into the (default) GNOME Wayland session.

Sebastien Bacher (seb128) wrote :

Under wayland it locks the mouse pointer in dnd mode and I can't interact with xwayland apps then (e.g firefox), I reported https://bugzilla.gnome.org/show_bug.cgi?id=786906

Changed in nautilus (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Confirmed
Ldx (a-giove) wrote :

(I post here the same comment I posted for duplicate bug #1716277):

Same issue on my Ubuntu 17.10 beta, freshly installed (no upgrade).

Just for completeness, this behaviour happens by just dragging any file from desktop to any other window of nautilus.

Dragging from nautilus to desktop works.
Dragging from nautilus to another nautilus windows works.
Cut/Paste from/to desktop works.

It's the dragging action from desktop that looks flawed.

If useful, here is a screen recording that shows the issue (well, the initial mouse drag and subsequent click attempts are not clearly visible but I think that one can get the idea of the problem):

https://www.dropbox.com/s/kjzqucqb7hdcnvy/Screencast_drag_issue_ubuntu-17-10-beta.mp4?dl=0

kalyp (kalyp) wrote :

Did someone figure out a workaround until the bug is fixed? in particular, is there any other solution than logging out when it happens? Since I cannot figure out how to log into the xorg session by default, once in a while I log into wayland without noticing, the bug happens and I have to close everything, log out and back in which is extremely annoying. So if someone has a trick for unlocking the mouse without logging out, I am more than interested... Thank you!!

tags: added: rls-bb-incoming
Adam Dingle (adam-yorba) wrote :

I still run into this bug all the time, and look forward to a fix.

In the meantime, here's how to recover without logging out:

1. Open a terminal window.
2. Run 'pkill nautilus'.
3. Run 'nautilus-desktop &'.

JLuc (jluc-q) wrote :

I have issues also when drag'n'droping files from a nautilus window to one of its subfolders (or any other place).

AMOF sometimes it works after 1 minutes of silent-doing-nothing. And since i have requested the same operation several times in the while, it also issues errors (maybe because the files have allready been moved at last and arent there anymore).

JLuc (jluc-q) wrote :

PS : i'm using XOrg session

JLuc (jluc-q) wrote :

Seems to be / Could be related to "Nautilus > Preferences > Experimental view" ("flowbox"). Seems fixed when unchecked.

Adam Dingle (adam-yorba) wrote :

JLuc, I don't see that option on Ubuntu 17.10. The only Experimental option in the Nautilus preferences is "Use the new views", which I have unchecked (as is the default), and this bug still occurs.

Grzegorz Śliwiński (fizyk) wrote :

Same here. It just bit my wife ;)

Theo (energeiai1) wrote :

Same here: Ubuntu 17.10.1 (Artful Aardvark) - the 2018-01-12 release.

Adam Dingle (adam-yorba) wrote :

This bug is still a major annoyance. It would be really nice to solve this for 18.04 (Bionic).

GNOME has recently removed the desktop code from Nautilus, so it seems very unlikely that this will be solved upstream. So presumably someone from Canonical or a community volunteer will need to fix this.

Tom Stewart (tomstewart) wrote :

It is so disappointing that this is not fixed 6 months after it was reported. I just freshly installed 17.10. This bug renders Chrome, text editor, and more unusable.

Pete (lance321) wrote :

I confirm this issue as well. Using latest build of 17.10 and updated. It requires me to log off/on to get things working again.

I found multiple duplicate bugs on this issue, and yes...wonder why its not fixed?

Warren (wseverin) wrote :

I too have this bug. It has been a constant annoyance for almost 3 months now. I have had to log out and log back in again hundreds of times, losing many hours of work in the process. Please, somebody do something about it!!!

bart (bart-wp) wrote :

For me the workaround is to use the xorg session. Both the gnome and the ubuntu session then works.

Latier (latier) wrote :

The same problem occurs when I drag a file or URL from Mozilla Firefox to Nautilus. (https://bugzilla.mozilla.org/show_bug.cgi?id=1431663)

Casey (sometimescasey) wrote :

Confirming that I'm seeing this as well. Switched to running Xorg to avoid it. Xorg drag and drop across screens results in a copy instead of a move but at least doesn't freeze.

Will Cooke (willcooke) wrote :

This is only a problem under Wayland, which is not the default session for Bionic. Untagging this for rls-bb-incoming.

tags: removed: rls-bb-incoming
Kim Ake (kim-ake) wrote :

Yup, under 17.10 dragging a file from the desktop onto Nautilus hangs cursor, need to pkill Nautilus after that.

Changed in nautilus:
status: Confirmed → Expired

Just ran into this on Bionic. The workaround (switch to Xorg) worked for me.

Ant Dickens (antonydickens) wrote :

Ubuntu: 18:04LTS (14.15.0.33)
Session: Wayland

Drag and drop not working as expected.
Dragging from the Desktop to Nautilus does not work. Cursor turns into hand but files not moved. Cursor stays as hand and selecting inputs in open applications not possible. Restart required to correct.
Dragging files from Nautilus ~/home to the Desktop copies files and does not move them.

Works fine in Xorg session.

MathUHenry (mathuhenry) wrote :

Problem remains in 18:10, Wayland, Gnome 3.30.1, 64-bit, 4.18.0-15-generic

Michael Satke (n9447354) wrote :

Also affects me (Gnome with Wayland) in 18.04 LTS.

Sebastien Bacher (seb128) wrote :

Nautilus doesn't handle the desktop anymore since Disco, the new component also lack working dnd though (bug #1813441)

summary: - can't drag file from desktop to folder window on Artful
+ [wayland, < disco] can't drag file from desktop to folder window
Sebastien Bacher (seb128) wrote :

Closing as fixed for nautilus, we could add a bionic target to the bug to SRU a fix there but there is currently none available and it's wayland which is not the default sesison in Ubuntu

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.