nautilus shows Windows Network but fails to open it

Bug #1640541 reported by Marius Gedminas on 2016-11-09
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)

Bug Description

1. Open Nautilus
2. Click 'Other Locations' in the sidebar
3. Click 'Windows Network'


- a list of local servers with Samba shares

Actual result:

- nothing happens for a while, then a popup saying "Could not get list of shares from the server: No such file or directory" (I'm translating back from lt_LT)

journalctl shows these errors:

    nautilus[8942]: Called "net usershare info" but it failed: Nepavyko paleisti antrinio proceso „net“ (Toks failas ar aplankas neegzistuoja)
    gvfsd[5799]: mkdir failed on directory /var/cache/samba: Permission denied
    gvfsd[5799]: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Nepavyko iš serverio gauti viešinių sąrašo: Toks failas ar aplankas neegzistuoja

The samba-common package is not installed (nautilus Recommends gvfs-backends which Suggests samba-common).

It would be nice if Nautilus asked me to install samba-common via packagekit or something instead of just failing.

(Although just 'samba-common' appears to be insufficient; I still can't browse the Windows Network in Nautilus after I 'apt install samba-common'.)

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: nautilus 1:3.20.3-1ubuntu3.1
ProcVersionSignature: Ubuntu 4.8.0-26.28-generic 4.8.0
Uname: Linux 4.8.0-26-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Nov 9 18:39:50 2016
GsettingsChanges: b'org.gnome.nautilus.window-state' b'geometry' b"'890x464+362+407'"
InstallationDate: Installed on 2016-09-10 (60 days ago)
InstallationMedia: Ubuntu-GNOME 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160720)
SourcePackage: nautilus
UpgradeStatus: Upgraded to yakkety on 2016-10-15 (25 days ago)
usr_lib_nautilus: gnome-terminal 3.20.2-1ubuntu5

Marius Gedminas (mgedmin) wrote :
Khurshid Alam (khurshid-alam) wrote :

It requires samba to be installed along with all dependencies.

Marius Gedminas (mgedmin) wrote :

I've been unable to get network browsing to work even after installing samba and disabling the firewall. smbtree -N shows other servers and shares on the LAN, but Nautilus just shows the Opening... dialog without making any progress even after several minutes.

(Accessing smb://server/share in Nautilus, OTOH, works fine even without apt installing samba and without disabling the firewall. If you know the name of the server and the share.).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Do you still get that issue? If so what's the output of "gio ls network:///" and "gio ls smb:///"?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Marius Gedminas (mgedmin) wrote :

Tried this again on Ubuntu 18.10, and I'm happy to report that almost everything works fine!

- "Other locations" in Nautilus shows my Samba server (after a couple of seconds)
- I can click on it, get an authentication dialog, then see the shares
- I can click on a share and see the files
- I can click on a file and discover that Totem is still hilariously broken on Wayland (that's a separate bug)

However some things are still broken:

- "Other locations" in Nautilus shows a "Windows network"
- I can click it and couple of seconds later I get an error dialog saying "Could not access location" (title): "Couldn't get a list of shares from server: No such file or directory" (translating from lt_LT again).

gio ls network:/// prints a usage message.

gio list network:/// shows


(VARLIUS2 is the name of my Samba server)

gio list smb:/// says

    gio: smb:///: Location is not a mountpoint

(I'm translating back from lt_LT because no amount of LC_ALL=C LANGUAGE=en is giving me English error messages, at best I get ?s instead of UTF-8 characters.)

Changed in nautilus (Ubuntu):
status: Incomplete → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers