Comment 17 for bug 150471

pisica (andrei-iftimovici) wrote :

I have experienced (computer HP intel dual core 2 and Ubuntu 7.10 installed on a virgin space i.e. no upgrade) almost all the other contributors said about that bug; it seems that the bug hasn't been solved yet, so, I'll bring some precisions about its behavior:

1) logging into another account or re-logging into the same, is not relevant: the bug is still present.
2) I think there is no connection with compiz (since even when the desktop is in very bad shape, compiz works, the cube rotates, so on...), nor with beagled nor with trackerd: I have disabeled all of them at startup and the bug is still there.
3) I tried to make a script shell (called clear.sh) like this:
Code:

#!/bin/bash
sleep 3
killall -9 nautilus 1>/dev/null
nautilus&
exit

and added it to the System > Preferences > Sessions, to be taken into account when the new session starts (hoping the old nautilus process will be killed). Unfortunately, it has no effect, whatever I put 3 or 5 or 6 or etc... seconds of sleep. But it has an effect when I run it after I login in the BAD working nautilus session. (Of course it has!)

4) Still, the effect of killing and restarting nautilus is NOT complete, i.e. it doesn't kill the bug completely. Indeed,

a) It kills the bad behaviour of the desktop, so the icons are coming back on it, the panel buttons are working well and the processors are stoping their mad activity.

b) But it doesn't bring back my Disk Mounter applet from one of the panels. Nor allows me to put other such applets on panels. This is quite odd. Then, if I restart the computer and login for the first time, my disk mounter applet appears normally and the other applets I have tried to put on the panel are appearing too !

********************

I think that this is a severe bug (not a "medium" one, as it has been classified) especially for computers used by more than one person (e.g. in a university). Thank you for fixing it as soon as possible.