The names column has its width dictated by other columns

Bug #1243806 reported by Shunsuke Akagi on 2013-10-23
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Fix Released
nautilus (Ubuntu)

Bug Description

* Impact
In some cases the names column is reduced to "..." and names can't be read

* Test case
open the trash: location in list view (with some deleted files), look at the filemanes column (reduce the window if needed)

* Regression potential
check that the columns content is readable


Folder names in Location area keeps the width even though when I go back to upper folder.
First of all this new downgraded nautilus folder section holds its width and I cannot even change the width at all.
Then when I go deep down lower folders or open folder with long name, it would squeeze down the "Name" part and I cannot even see names anymore. Then when I go up to upper folder or root, I cannot see the names anymore becaue location column takes up all the space. Once I click one of the unseen folder, I may see the names again.
This is one of too many problems of 13.10.

Vladislav (olunet) wrote :


Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Vladislav (olunet) wrote :

That is how it looks like. I can not change the width of any column.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Shunsuke Akagi (shoon) wrote :

How come this issue could be "Low"?
Do we need to handle files/folder blindly?
We should advertise "Even blind people can use ubuntu as well as other people can!"

mario (marava1) wrote :

I too have the same very annoying issue in two PCs that i have upgaded to ubuntu 13.10. The file manager is absolutely unusable.
I have attached s screenshot. so everybody can see how much this bug is relevant.

Shunsuke Akagi (shoon) wrote :

The developpers must have extremely wide monitors. My regular computer monitor for documents is 90 degree turned so it would have been horrible but very luckly I did not upgrade it.
Please confirm the following issue, too.
#1243659 folder opens when I place mouse without clicking or releasing button. 13.10
#1243256 when location name is long or deep, I cannot even see file names.
 All together it is almost impossible to use regular ubuntu.

mario (marava1) wrote :

#1243659: no, it does not happen to me,.
#1243256: yes! googling around there are many people affected by this issue.
The developers monitors are extremely wide or elastic. it is possible?

Shunsuke Akagi (shoon) wrote :

The column should be elastic instead of screen because we cannot afford to buy elastic screen or extremely wide screen.
We should not discuss about #1243659 here but is it true? I wonder what kind of setting you have.
Every time when I copy/move a file into a folder, my folder opens up.

I will also have this problem

Jose Manuel Perdomo (joz3) wrote :

same problem here.... Ubuntu 13.10

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Sebastien Bacher (seb128) wrote :

I can't confirm the issue there, the name columns can be moved by simple dnd...

Sebastien Bacher (seb128) wrote :

Oh, in fact I can confirm with small windows, seems like the other columns have a fixed size and that the adjustment is done on the name one, which work fine unless you have small windows...

Changed in nautilus (Ubuntu):
importance: Low → High
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

Ok, the bug has been reported upstream as well:

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
mario (marava1) wrote :

Today I was in airport and I accidentally have cancelled an important file from the pc and, as usual, I opened the trash for restoring it. Because the width of the column "Original position" is fixed I could not restore the file because the names are all "..."(see the attached screen shot). I am not a medium so I installed thunar with which i could see the file and restore it.
I have no world for whom have had written such a kind of unusable file manager. Please can we hope that the bug will be corrected?

Shunsuke Akagi (shoon) wrote :

To Mario:

I think it seems to be fix this problem but when similar thing happens, you should try ctrl+2.

Currently the new version has too many problem but I am avoiding with this method.
I hope the other issue will be fixed soon.

Changed in nautilus (Ubuntu Trusty):
status: Triaged → Fix Released
Sebastien Bacher (seb128) wrote :

@Shunsuke: why did you close the bug?

Changed in nautilus (Ubuntu Trusty):
status: Fix Released → Triaged
Shunsuke Akagi (shoon) wrote :

I am sorry. Do you still have the issue?
My nautilus does not have the issue anymore.
The name column does not have fixed width now.
Therefore I considered this case would be closed.

Right now, for me, this is the problem.
 #1243659 A folder opens when I place mouse on it while left button is pressed. 13.10
It drives me nuts!

Sebastien Bacher (seb128) wrote :

The issues with the name column being too small and leading to have "..." is still there yes

#1243659 is not a bug, it's a wanted upstream change ... dragging over a folder enter this one to let you browse subdirectories

Shunsuke Akagi (shoon) wrote :

>#1243659 is not a bug, it's a wanted upstream change ... dragging over a folder enter this one to let you browse subdirectories

I should not talk about it here but nobody talk about this so I am describing here.
If that's not a bug then the spec is wrong.
Have you ever tried to move a file at bottom of folder that contains at least 20 or 30 folders, to a folder that is located at top?
If we move slowly, it defenetly would be caught by a folder on the way.
When it has to be scrolled, it is impossible to reach there.
I am not trying to play a game. This is very tricky to avoid the problem.
If you release nautilus as a game, it would be great because it is very difficult.
Right now, I have to open the target folder as a new tub then I can move a file to the folder tab because I can move a mouse fast enough or it would not require scroll.
The many new specs seem to be completely wrong. One of the major wrong thing was that tree view has gone.

Sebastien Bacher (seb128) wrote :

similar bug in the fedora bug tracker,

summary: - Folder names in Location area keeps the width (13.10)
+ The names column has its width dictated by other columns
Changed in nautilus:
status: New → Invalid
mario (marava1) wrote :

Sorry for my ignorance, but I do not understand, why the bug was "Changed in nautilus: status: New → Invalid ". This means that it is solved or that it is the actual and will be the future behavior of nautilus? Please someone can explain me? Actually I am using PCManFM as file manager. Thank you

Shunsuke Akagi (shoon) wrote :

I may not be answering your question mario but the last time when I used nautilus, columns became re-sizeable so I thought that was enough. At least it was useable thought it might be incovenient.
Nautilus has been getting worse and worse so I am using Nemo now and you are using PCManFM so forget about nautilus.
It should be terminated.

Sebastien Bacher (seb128) wrote :

@mario: the upstream bug been marked as duplicate of another one, which triggered the status update

Changed in nautilus:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Confirmed
Pierre Blanche (pablanche) wrote :

Same problem here with 14.04.
Had to remove the "original location" column to be able to see the file/folder name

mario (marava1) wrote :

I happens to me too. The ridicolous is that, for me, is an important information. I am becomig crazy.

Alexander Adam (7ql6) wrote :

This is especially nasty while nautilus doesn't really distinguish between the filetypes anymore.
So an .epub, .doc, .mobi, .odt and a .pdf will always show as 'Document' in the type column.

While I am interested in the in the real filetype, I had to remove the type column and add the mime-type column which made the 'too small name column' just worse while mime types are very big.
You can't even make the mime-type column smaller, so that bug here just made nautilus unusable for me.

If even would switch to nautilus again if this mega-package of bugs would be fixed. :-)

Maximiliano (meilan) wrote :

Ubuntu 14.04
Nautilus 3.10.1
Can't expand name width column. But things go worst when click search icon and Nautilus display the search result, because the width of the names column decreases.

For me the problem is when you search in folders with deep nesting ; one hit in a deeper folder and your Name column is compressed to an ellipsis.

I think it should be the location column that's compressed (by omission of some text).

Adnan (adnan-rauff) wrote :

impossible to navigate with "location" column displayed because for some reason "location" column width keeps getting change automatically. please fix ;(

Ric Flomag (ricflomag) wrote :

This page:

Strongly suggests its a GTK3 bug.

runner (runner2) wrote :

I confirm this problem is still with us in 14.04. Just to clarify, the problem occurs not just when the combined length of data in all columns is as wide as the frame of teh nautilus. I see it when some columns have space beyond the data they hold and still can not resize the columns.
So we have two cases.
When the data of all columns is narrow enough.
You do not care that you can not resize the columns. However in this case it is not huge problem because you can see all the data.
When the data of all columns is so long that it does not fit.
Example is when you search for data and the path is long and so as pointed out by Mario so eloquently you see:
instead file name and path you get:
fi..... /home/smith/class2014/this/that............
fi..... /home/smith/class2013/blah/.................
fi..... /home/smith/class2012/so/and............
and this is the situation when it hurts a lot.
thank you for listening

Craig (craig-st) wrote :

I"m seeing the same bug in Nemo 1.8.4 as well.

merlin (merlin-re-cycle) wrote :

Workaround - remove location column from view
Right click on the top row, un-tick it
Quite a bug though.....

mario (marava1) wrote :

Why not? I need such info! Please (Following your workaround I could also create folder with one-letter-name)

Changed in nautilus:
status: Confirmed → Invalid
floid (jkanowitz) wrote :

Does this mean it's fixed or someone just pushed the "ignore pesky users" button again? I see no new Nautilus updates since last week.

Does this mean 14.10's version will be improved?

The 14.04 examples in the attachment are a bit forced with non-sensitive data from my home machine, but when you're at work dealing with files and paths like "/Clients/Lastname, Firstname/adv. Plaintiff/for filing/Motion (Second) for Extension of Time to File Opposition.pdf" and any column gets truncated, you're in for a bad time when all search results return as e.g. "Mot...".

The Dash search also seems to have issues being useful with these common cases of 'important metadata is in the path as well as the filename' if you're trying to find Bob's motion and not Alice's.

I know I'm without gruntle, but I'm told all of these features break equally when working with multiple git repos, so what audience is being adequately served by any of this again?

floid (jkanowitz) wrote :

re: my #38 above: Those screenshots accidentally expose another funny behavior - yes, when the yellow 'tip' appears at the bottom of the window it does at least tell you about the individual file that's been highlighted.

Apparently in the contrived case of a window that small (felt like fitting both in one png and not sharing the labels of my external drives) it doesn't fully appear, different bug. But at normal window heights that part does work if you feel like individually examining each one.

Alex Burdu (alex.burdu) wrote :

this bug is not invalid. this bug exists and is very annoying.

TBeholder (turbobeholder) wrote :

Auto column size in general. Which cannot even be turned off (of course, any feature that cannot be turned off already is a potential bug, this just illustrates the principle).

Columns are often bigger than needed, and it looks like they are resizeable, yet if you move separator between column headerss #2 and #3 to the right(!), #3 stays the same, #2 expands and #1 (Name) shrinks. How it's not a bug?

Todor Andreev (toshko3) wrote :

This is not ANNOYING. This is work BLOCKING! Please, realize it!

Changed in nautilus:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
floid (jkanowitz) wrote :

Oof. Well, glad someone may be addressing it - kudos and all love to Carlos Soriano, it appears?

Apparently it's a simple one-liner:

...that won't be in upstream until GNOME 3.16, and Ubuntu is sticking with GNOME 3.12 stuff for Ubuntu 14.10. Any chance that is cherry-pick-able?

floid (jkanowitz) wrote :

@Sebastien Bacher: Awesome, thanks! From the timing I guess that landed between visiting Launchpad and finishing typing. (Obviously got all that from your link to the GNOME bug just prior but I wasn't sure how much activity that indicated.)

Now to actually try it out after work... :)

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.10.1-0ubuntu15

nautilus (1:3.10.1-0ubuntu15) utopic; urgency=medium

  * debian/patches/git_name_column.patch:
    - "nautilus-list-view: Avoid unreadable names" (lp: #1243806)

  [ Lars Uebernickel ]
  * debian/patches/properties_window_set_max_width_for_value_labels.patch:
    - avoid very wide properties window (GNOME: #732117)
 -- Sebastien Bacher <email address hidden> Mon, 20 Oct 2014 09:05:18 -0400

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
description: updated
Changed in nautilus (Ubuntu Trusty):
status: Triaged → In Progress

Hello Shunsuke, or anyone else affected,

Accepted nautilus into trusty-proposed. The package will build now and be available at in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at . Thank you in advance!

Changed in nautilus (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

Daniel, the "open with" feature doesn't have anything to do with the columns layout, so no

ZaZy (zazy) wrote :

I regret to say that the patch solves the problem only in part. Now there is a lower bound for column width that lets a scrollbar appear but when managing long filename the problem is still there: no way to read the whole filename. The status bar still not help because it put ellipsis in the middle of filename. The ONLY solution here is the one that let the filname column to expand as wide as I need it, allowing scrollbar to appear. The same should be told for foldername column.
In the attached image I try to expand the Filename (Nome in italian) column but the sum of all columns width is limited to the available space.

Sebastien Bacher (seb128) wrote :

The solution is not perfect but it's better than not having it so setting as verification-done, we can get this improvement in while still working on a better solution

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for nautilus has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.10.1-0ubuntu9.4

nautilus (1:3.10.1-0ubuntu9.4) trusty; urgency=medium

  * debian/patches/git_name_column.patch:
    - "nautilus-list-view: Avoid unreadable names" (lp: #1243806)
 -- Sebastien Bacher <email address hidden> Mon, 20 Oct 2014 17:33:22 -0400

Changed in nautilus (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.