Ubuntu

[ffe] Restore a traditional menu under Unity

Reported by Michael Terry on 2013-02-20
142
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
nautilus (Ubuntu)
Medium
Lars Uebernickel

Bug Description

When fixing this bug, also take a look at bug #1131664 at the same time if possible.

------------------------------------------------------------

In Nautilus 3.6, introduced in raring, the menu layout was changed from the traditional all-entries-in-one-menubar to:
* an application menu called "Files" in the Unity menu bar
* a view menu has moved to some toolbar buttons and a dropdown under an arrow in the upper right of a window
* all other menu items have moved to a cog button dropdown in the upper right of a window

For Unity, we should probably switch back to the more traditional layout (and keep the new layout for GNOME). I'll assign an Ayatana task to get design guidance on what the layout should be.

------------------------
Desired resolution:

- Remove the 'cog' icon from the top right of the Nautilus toolbar. Move the view and search buttons over to the right, so that the right most view button occupies the position which previously held the cog button.

- Patch Nautilus to have the following menu layout:

=== File ===

New Window
New Tab
---------
Connect to Server
Enter Location
---------
Create New Folder
Create New Document >
---------
Properties
Restore Missing Files...
Ubuntu One
---------
Quit

=== Edit===

Undo
Redo
---------
Select All
Select Items Matching...
Invert Selection
---------
Cut
Copy
Paste
---------
Preferences

=== View ===

Zoom In
Zoom Out
Normal Size
---------
Reload
---------
Icons
List
--------
By Name
By Size
By Type
By Modification Date
---------
Reversed Order
---------
Show Sidebar
Show Location Bar text / Hide Location Bar text
---------
Reset View to Defaults
Show Hidden Files

=== Go ===

Open Parent
Back
Forward
---------
Location...
Search for Files...

=== Bookmarks ===

Add Bookmark
Edit Bookmark
---------
Home
Computer
Trash
Network
[list of all current Nautilus bookmarks]

=== Help ===

Help
About Files

Tags: udp Edit Tag help
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2013-02-21
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
tags: added: udp
description: updated
John Lea (johnlea) on 2013-02-21
description: updated
Changed in nautilus (Ubuntu):
assignee: nobody → Michael Terry (mterry)
importance: Undecided → Medium
John Lea (johnlea) on 2013-02-22
description: updated
Jeremy Bicha (jbicha) on 2013-02-22
description: updated

I guess the biggest problem here is not being able to use the HUD for most cases.

Shahar Or (mightyiam) wrote :

Exactly, Stéphane

Michael Terry (mterry) on 2013-04-30
Changed in nautilus (Ubuntu):
assignee: Michael Terry (mterry) → nobody
Changed in nautilus (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
status: Triaged → In Progress
Xavier Guillot (valeryan-24) wrote :

Andrea, will you also work on other Gnome applications with the same "bug" (Evince, Eye of Gnome...), it is a global behavior ?

Thanks !

Andrea Azzarone (andyrock) wrote :

Not sure, for the moment gnome-calculator, gnome-control-center and nautilus

Changed in nautilus (Ubuntu):
status: In Progress → Confirmed
John Lea (johnlea) wrote :

@valeryan-24; feel free to propose a new bug for those apps with what you think is the correct solution. Use both this bug and also bug #1131664 as a template. I'll review, amend if necessary and approve.

John Lea (johnlea) on 2013-07-09
description: updated
Changed in nautilus (Ubuntu):
assignee: Andrea Azzarone (andyrock) → Lars Uebernickel (larsu)
status: Confirmed → In Progress
summary: - Change nautilus menu layout in Unity back to the style of 3.4
+ [ffe] Restore a traditional menu under Unity
Iain Lane (laney) wrote :

I think this probably counts as a bug fix → no FFe needed. Feel free to upload these changes up to UIF.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.10.1-0ubuntu6

---------------
nautilus (1:3.10.1-0ubuntu6) trusty; urgency=medium

  * debian/patches/restore-traditional-menu-bar.patch:
    - Restore a traditional menu under Unity, thanks Lars Uebernickel
      (lp: #1130722)
 -- Sebastien Bacher <email address hidden> Thu, 27 Feb 2014 17:04:30 +0100

Changed in nautilus (Ubuntu):
status: In Progress → Fix Released
Attila Hammer (hammera) wrote :

Lars, not possible restoring traditional menu bar for Nautilus with not only Unity sessions too?
For example the file-roller application both GNOME Classic session and Unity presenting the traditional menu bar, Nautilus now only Unity session presenting the restored main menu.
If this is impossible now, sorry the unneed comment.
In file-roller application I wonderful have possibility to use restored main menu bar with keyboard and Orca Screen Reader, I using GNOME Shell classic session.

Attila

Lars Uebernickel (larsu) wrote :

Hi Attila. The patch only enables the menubar when the "Gtk/shell-shows-menubar" xsetting is set. That means, only on desktop environments that show the menu bar outside of the application's window.

I don't think it is wise to check for the desktop environment to decide whether to show the menu bar in the window or not (we'd need to do that because we wouldn't want the menus in windows in gnome shell).

Attila Hammer (hammera) wrote :

Hi Lars,

A last question:
Possible toggle on this xsetting in the .config/gtk-3.0/settings.ini file or any other way?

Attila

Attila Hammer (hammera) wrote :

Unfortunately the installable GNOME Flashback (Metacity) session doesn't presenting too the new menu bar, so now affected sessions is GNOME Shell Classic session and GNOME Flashback various sessions (Compiz and Metacity).
I don't no what happening other desktop environments (for example XFCE and LXDE).
Testcase:
1. Enable universe and multiverse repositoryes, and install gnome-session-flashback package.
2. Logout, and login the GNOME Flashback session (Metacity).
3. Launch Nautilus, and press the F10 key.
Expected result future if this is possible: need presenting restored traditional menubar.
Actual result: the one column context menu presenting.

Attila

Peng (pengwg) wrote :

The "Open in Terminal" plugin is harder to access now.

It can be accessed through right-click menu but is difficult under list view.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints