There's no easy way to undo file copying, moving, deletion, etc.

Bug #109170 reported by Matthias Meulien
114
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Wishlist
One Hundred Papercuts
Undecided
Unassigned
nautilus (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

To be HIG compliant, nautilus should allow the user to undo file copying, moving, bookmarks creation, change of zoom level, etc.

Related branches

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug. The HIG is about user interfaces it doesn't describe what actions should be available, undo is non trivial to code. There is already a request upstream on http://bugzilla.gnome.org/show_bug.cgi?id=167501

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Changed in nautilus:
status: Unknown → Confirmed
Changed in nautilus:
status: Confirmed → Triaged
Revision history for this message
Tom (tom6) wrote :

Wishlist for extra-functionality that Windows already has (i think Win98 had it?)

It might be trivial in terms of coding (still waaay beyond my skill-set) but is an issue of the usefulness/productivity of using Linux in comparison to Windows - "For extra productivity stick with Windows, only use Linux if you want good code" is an attitude hardly likely to attract people away from Windows and into the joys of Linux.

Undo is still missing from the Edit menu & the right-click menu (which is considerably shorter and less useful than the Windows (i can't bear to write Microsoft) one).

In Windows a long history of previous actions is remembered and right-clicking within the empty area in a file-browser window would typically have an item that might read "Undo rename" or "Undo delete", depending on what the last action had been, sometimes it's quite ridiculous quite how much it lets me undo.

Sigh, it's clearly not enough to make me go back to #$*£^ Windows but i kinda miss it when i do something dumb (quite often happens sadly)

Anyway, thanks all for your hard work in keeping me happy with Linux, particularly with Ubuntu. Well done :)
regards and happy new year from
Tom :)

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/nautilus
NonfreeKernelModules: fglrx
Package: nautilus 1:2.24.1-0ubuntu1
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
Uname: Linux 2.6.27-11-generic i686

Revision history for this message
Tom (tom6) wrote :

The bugzilla thread has a patch for a previoous version of Nautilus but somehow it didn't get included as a basic feature of the newer version of Nautilus. A shame really because it's the kind of thing that Windows would shout out about although its old news for Windows, they're way ahead of us with that feature.

Revision history for this message
Tom (tom6) wrote :

Sorry, that was rude of me. Apologies to all - please ignore that previous post.

Revision history for this message
David Siegel (djsiegel-deactivatedaccount) wrote :

This would be a great addition, but it is too large to be considered a paper cut.

Changed in hundredpapercuts:
status: New → Invalid
summary: - No undo mechanism
+ There's no easy way to undo file copying, moving, deletion, etc.
Revision history for this message
Tom (tom6) wrote :

Omg, i had no idea it was such a tough functionality to add! In the duplicate recently linked to this someone said it was over 2,000 lines of code! I had no idea. Feedback like that is useful because otherwise it might seem like a trivial issue just being ignored.
Regards from
Tom :)

Revision history for this message
Amos Brocco (mriya3) wrote :

FYI... I've updated my previous patch to work with the latest version of nautilus (2.29, in git). See the gnome bugzilla
page https://bugzilla.gnome.org/show_bug.cgi?id=167501 .

Revision history for this message
Amos Brocco (mriya3) wrote :

Patched packages for Karmic and Lucid are available in my PPA, at https://launchpad.net/~mriya3/+archive/ppa

Revision history for this message
Tom (tom6) wrote :

hi :)

Great, that does make it a lot easier i think! Sorry about all my posts in the upstream bug-report at
https://bugzilla.gnome.org/show_bug.cgi?id=167501
Thanks for making this much easier to access
Many regards from
Tom :)

Changed in nautilus:
importance: Unknown → Wishlist
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.3.5-0ubuntu1

---------------
nautilus (1:3.3.5-0ubuntu1) precise; urgency=low

  * New upstream version, thanks Jeremy Bicha who started on the update:
    - Introduce Undo support for common file operations (lp: #109170)
    - Fix a crash when middle clicking icons on the desktop (lp: #817861)
      (lp: #927998)
    - Fix split view actions not updating properly (lp: #912746)
    - Fix wrong places sidebar selection under some locales (lp: #917875)
    - Fix a crash when enabling desktop icons handling
    - Fix invalid write error on tab closing (lp: #918907)
    - Correclty update menu checkmarks (lp: #912746)
 -- Sebastien Bacher <email address hidden> Tue, 07 Feb 2012 10:57:47 +0100

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
Changed in nautilus:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.