No option to create a New Document from context menu

Bug #1014876 reported by Doug McMahon on 2012-06-18
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Wishlist
Unassigned
Quantal
Wishlist
Unassigned
Raring
Wishlist
Unassigned

Bug Description

seems related to this -
http://git.gnome.org/browse/nautilus/commit/?id=9538d1a640fda650e4866d2cdcc69b9e1cfa3a35

Don't know what Ubuntu's intention is here, whether to have the option or if it's up to the user to deal with

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: nautilus 1:3.5.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.2.3-0ubuntu3
Architecture: amd64
Date: Mon Jun 18 18:13:21 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120603)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, I'm not sure what you suggest there ... you would like an empty menu when there are not templates installed? what's the rational to have that menu if it's of no use?

Changed in nautilus (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Doug McMahon (mc3man) wrote :

Well this is what was previously in the context menu with no templates, it allowed users to create an empty/untitled text document anywhere from context menu

Doug McMahon (mc3man) wrote :

Now there is nothing there

Doug McMahon (mc3man) wrote :

So the question is. is it expected the user will know to create a template in ~/Templates & if only looking to have one for text Not to put a text template in there

An "Empty Document" option is auto added once any template is in place, if you add one for a plain text docu then you get 2 options for the same thing

Sebastien Bacher (seb128) wrote :

Thanks, can't you just add an "Empty Document" to your template directory if you want that feature?

In practice how often users want to create an empty text file? That somewhat goes back to the bug saying that the default installation should have template for useful types like libreoffice writer texts though...

Sebastien Bacher (seb128) wrote :

seems like your previous comment arrived while I was writing my reply, at this point the bug seems a duplicate of bug #372132?

Doug McMahon (mc3man) wrote :

"at this point the bug seems a duplicate of bug #372132?"
Possibly
The difference would be that this has been a default supplied option (r. clicck > new docu..) that users have have had available in prior Ubuntu releases for some time.

Whether using 'Templates' is difficult I'm not in a position to judge how difficult it would be for users to figure out or even if it would be missed (though I guarantee many current Ubuntu users will notice it's gone.
Maybe that's something for user studies or design

What does come up is it seems nautilus has a 'built-in' template for text, but it won't show until something is placed in the Templates folder.
So if a user puts a text file 'template in, then they can get 2 options for the same thing. So that may be confusing instead of difficult

Sebastien Bacher (seb128) wrote :

well, providing a default set of template would fix both issues it seems...

Sebastien Bacher (seb128) wrote :

Setting wontfix, if we fix it that will be by providing a set of templates by default which is already tracked in another report

Changed in nautilus (Ubuntu):
status: Incomplete → Won't Fix
Doug McMahon (mc3man) wrote :

That seems to be the best action (won't fix), though it's hard to understand why gnome/nautilus provides a 'template' for text/plain but the context and file menu option won't show until any other template is created by the user.

Sebastien Bacher (seb128) wrote :

I guess you can open a bug on bugzilla.gnome.org about that if you feel strongly about it ;-) (it's too minor of an issue to be likely that somebody in the desktop team will be wanting to deal with that)

Doug McMahon (mc3man) wrote :

I'll let it go - no issue here, I just put in an odt template
It's just that when things go away users (prior) start complaining, ect.

Thanks for time on.

Changed in nautilus (Ubuntu):
status: Won't Fix → Triaged
importance: Low → Wishlist
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/1014876

tags: added: laptop-testing
Sebastien Bacher (seb128) wrote :

it's getting some duplicates, let's keep it open as a wishlist and consider what to do exactly about it for quantal

Changed in nautilus (Ubuntu Quantal):
status: Triaged → Won't Fix
LantzR (lantzr) wrote :

The contrived qa Test is a bit misleading.

- I believe that it was better to always show the Create New Document context menu

- As it is now, if we can not go back - Do NOT ship with the Template Folder Empty

- I personally prefer 12.10 style where if i move a doc into Template in Bash it will show up in the menu
 - It should not matter how the file gets there

- Dragging a document into the Templates folder with Nautilus work immediately

- The is still the problem that Nautilus does a copy not a move when you drop a doc into a folder

https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1119832/comments/7

Doug McMahon (mc3man) wrote :

This bug was fixed in the package nautilus - 1:3.6.3-0ubuntu6

Changed in nautilus (Ubuntu Raring):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers