Comment 8 for bug 1016559

Hey guys, I'm relatively new at Ubuntu in general, so I may not be that helpful. I would just like to say that not only does this bug affect me (I clicked the link at the top of the page), but it is a BIG problem. It seems to be making it impossible to install anything. I found my own work around which is basically what everyone else is doing (I neglected to use Google--big mistake). However, something messed up with my dpkg (keep in mind I'm a Linux newbie, so I don't know if all I say will make entire sense). Terminal keeps telling me to run "sudo dpkg --configure -a" because something is broken and/or something is wrong with locking a file.

I run it, and it comes up with the dropbox-nautilis download, which makes little sense to me, personally, because I already have the workaround listed above installed. However, it seems to be preventing me from installing anything... because of the bug when I run "sudo dpkg --configure -a" and it tries to reinstall.

Thanks for any help you could provide, as it seems as if I am going to have to some how completely take Dropbox off of my computer at this point. I suppose below I will post a detailed 'diagram' of what happens.


So, to begin with I run "sudo apt-get update" (This is the simplest command that shows the bug). When I do this, it updates everything. At the end, it displays two error messages, however:

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Then, I run "sudo dpkg --configure -a" like I have found out else where. (I have no idea if I'm doing something wrong with Terminal)

However, it begins stating the Dropbox download that stalls at 99 percent, just as everyone else is experiencing. Same message and everything. This prevents me from installing anything, since I can't use "apt-get" or the Ubuntu Software manager--even Synaptic Package Manager (More obvious than the Software center, as it is a GUI front-end for "apt-get" to my understanding).

If you guys could help me find a workaround for this, I would greatly appreciate, as I'm a novice user. (I'm not scared to run a few commands in Terminal though). If there's any other info I should know, I'll gladly take it, as I have never even used Launchpad before. Dropbox is absolutely necessary for me to stay on Ubuntu, so it's very urgent!

Thanks in advance,