mythfrontend resets volume to 100% with PulseAudio:default

Bug #551088 reported by Hannu Teulahti on 2010-03-29
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
MythTV
Won't Fix
Unknown
mythtv (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: mythtv

mythfrontend resets volume to 100% when starting playback or skipping back or forward while watching a recording using PulseAudio:default output if the option "Use internal volume controls" is not checked.

If using internal volume controls the volume sets to the adjusted value at every time the recording is skipped back or forward.

There is no way of using mythfronted with pulseaudio in a way that mythfrontend would not touch the volume settings.

Description: Ubuntu lucid (development branch) as of 29.3.2010
Release: 10.04

mythtv-frontend 0.23.0+fixes23820-0ubuntu1

MarcRandolph (mrand) wrote :

Howdy, and thank you for helping to improve Mythbuntu by opening this ticket. I have confirmed this behavior and have forwarded the issue to the MythTV developers

Changed in mythtv (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in mythtv:
status: Unknown → New
Jeremy Nickurak (nickurak) wrote :

Since ALSA:pulse doesn't seem to work any more (as it did in Karmic), Pulseaudio:default is the only option... not having that working means mythtv is largely unusable under Lucid. :(

Changed in mythtv:
status: New → Confirmed
Changed in mythtv:
status: Confirmed → Won't Fix
madmax2 (tyler-durden404) wrote :

I also got the same problem.

After rewinding the volume goes lower than 100%.

It starts at 3 full bars then goes to 2 bars or 2/3 of 100%.

Fisslefink (erin-simonds) wrote :

This is still an issue in Lucid official release.

Reassigning it to the MythTV devs, while the correct course of action, resulted in a political dispute and no resolution for users:

http://<email address hidden>/msg06978.html

According to a later comment on the thread (dated May 2010), there is another version of MythTV on the way with better pulseaudio support:

http://<email address hidden>/msg06979.html

....still no word on that.

In the meantime, the following workaround restored functionality on my system, allowing me to use Mythfrontend with the PulseAudio:default audio codec, and still get sound from other applications spawned while mythfrontend was running (i.e. VLC, Mplayer).

Here are my settings for mythfrontend (Utilities/Setup --> Setup --> General)
- Audio output device = "PulseAudio:default"
- Internal Volume Controls = on
            - Mixer device = software
            - Mixer controls = Master
            - Master mixer volume = 50
            - PCM mixer volume = 70

........I control the volume with the pulseaudio command line tool "pacmd" using LIRC and irexec, as shown in this script:
http://gzn.pastebin.com/zV0f7Pmv

Jeremy Nickurak (nickurak) wrote :

It's still an issue in Maverick.

It's also still an issue in the 0.24 branch of mythtv.

I'll try your workaround at least to see if that helps.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.