Ubuntu

mythtv-frontend dependency problems on powerpc

Reported by Dustin Kirkland  on 2008-04-03
10
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: mythtv

Trying to install mythtv-frontend on powerpc, I get the following failure:

The following packages have unmet dependencies:
  mythtv-frontend: Depends: mythtv-common (= 0.21.0-0ubuntu2) but 0.21.0+fixes16838-0ubuntu1 is to be installed
E: Broken packages

Looking at the repository, I see that there is no powerpc build for the equivalent i386/amd64 builds:
mythtv-frontend_0.21.0+fixes16838-0ubuntu1_amd64.deb 30-Mar-2008 09:03 1.8M
mythtv-frontend_0.21.0+fixes16838-0ubuntu1_i386.deb 30-Mar-2008 08:03 1.8M

Note:
https://edge.launchpad.net/ubuntu/+source/mythtv/0.21.0+fixes16838-0ubuntu1/+build/549956

Seems that it needs building.

----
Bug Impact: All users on the port to powerpc are unable to install MythTV.

This has been addressed in Intrepid by modifying build-dependencies.

Test Case:
1) Install Ubuntu on PPC
2) Attempt to install MythTV

Dustin Kirkland  (kirkland) wrote :

Actually, the powerpc build queue is just very backed up

Changed in mythtv:
status: New → Invalid
AJL (ajl+) wrote :

As of build 562211, mythtv is still in "Dependency wait". Are we going to see a pre-compiled version before the Hardy release? Would be fantastic for all the G4 Mac Mini users that use their box as a home theatre central.

https://edge.launchpad.net/ubuntu/+source/mythtv/0.21.0+fixes16838-0ubuntu3/+build/562211

Unai Uribarri (unaiur) wrote :

I think that Mythtv will not work in a PowerPC with Ubuntu Hardy. It depends on xserver-xorg-video-openchrome which only works on i386 and amd64. So we must hope that someone fix that broken dependency and wait until 8.10.

Unai Uribarri wrote:
> I think that Mythtv will not work in a PowerPC with Ubuntu Hardy. It
> depends on xserver-xorg-video-openchrome which only works on i386 and
> amd64. So we must hope that someone fix that broken dependency and wait
> until 8.10.
>
We will be doing a backport once the HD-PVR patch is ready. We can roll in the
fix for this at the same time.

--
Mario Limonciello
<email address hidden>

Dustin Kirkland  (kirkland) wrote :

Changing to 'confirmed'.

This dependency problem continues to exist. Let's close when the necessary packages are available for mythtv on powerpc.

:-Dustin

Changed in mythtv:
status: Invalid → Confirmed
Mario Limonciello (superm1) wrote :

this is fixed in bzr #97.

i'd like to do a backport for hardy after this clears the intrepid build daemons

Changed in mythtv:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 0.21.0+fixes17416-0ubuntu1

---------------
mythtv (0.21.0+fixes17416-0ubuntu1) intrepid; urgency=low

  * New checkout of release-0-21-fixes branch.
  * debian/mythfrontend.sh:
    - check for /etc/mythtv/session-settings when sourcing it. (LP: #220681)
  * debian/mythtv-backend.postinst:
    - check for directories before overriding (LP: #223988)
  * drop debian/mythtv-database.postrm
    - Wasn't doing anything productive but causing crashes. (LP: #213200)
  * debian/control:
    - Adjust dependencies to only build depend on chrome for i386 and
      amd64. This should fix all other archs. (LP: #211125)
  * add debian/patches/17_pvr350_tvout_fix:
    - Fixes PVR-350 tv output's EPG. (LP: #236498)
      Thanks bal_zac for tracking this down.
  * update debian/patches/07_glx-procaddressARB-configure
    - Certain parts are absorbed upstream.

 -- Mario Limonciello <email address hidden> Sun, 01 Jun 2008 17:04:11 -0500

Changed in mythtv:
status: Fix Committed → Fix Released
Mario Limonciello (superm1) wrote :
description: updated
Luke Yelavich (themuso) wrote :

SRU ACK.

Changed in mythtv:
status: New → Confirmed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in mythtv:
status: Confirmed → Fix Committed
Dustin Kirkland  (kirkland) wrote :

On Tue, Jun 3, 2008 at 5:36 AM, Martin Pitt <email address hidden> wrote:
> Accepted into -proposed, please test and give feedback here

I will test on powerpc as soon as I have access to my powerpc machine
again (June 8th).

:-Dustin

Dustin Kirkland  (kirkland) wrote :

Tested -proposed, and it works for me!

mythtv-frontend installs and runs on powerpc Hardy.

:-Dustin

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in mythtv:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments