XFCE bar is visible over Mythfrontend on a fresh 14.04 install

Bug #1282868 reported by Thomas Mashos on 2014-02-21
144
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Mythbuntu
Critical
Unassigned
mythtv (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
xfce4-panel (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned

Bug Description

The XFCE bar is visible over mythfrontend on a fresh install.

Reproduce:

Install from Mythbuntu 14.04 ISO. Install with frontend+master backend. After install, when mythfrontend starts the XFCE bar is visible at the top of the screen. Historically, this has been an issue with Compiz (fixable by enabling the compiz legacy window mode).

Thomas Mashos (tgm4883) on 2014-02-21
Changed in mythbuntu:
importance: Undecided → Critical
Thomas Mashos (tgm4883) wrote :

This only appears to happen in virtualbox. Does not happen in a real install

Changed in mythbuntu:
status: New → Invalid
Mario Limonciello (superm1) wrote :

Well so this is still happening. I think mythfrontend must not be setting a fullscreen attribute properly or something.

Running this will fix the behavior. Until we have a proper fix i've just bound it to my harmony startup script when I press power.

DISPLAY=:0 wmctrl -r "MythTV Frontend" -b add,fullscreen

Changed in mythbuntu:
status: Invalid → Confirmed
Changed in mythtv (Ubuntu):
status: New → Confirmed
milestone: none → ubuntu-14.04.1
Louis (louis-louis) wrote :

This does also affect me upon upgrading from Mythbuntu 12.04 to 14.04.

Louis (louis-louis) wrote :

If I do no modifications I can still put the frontend in full screen, by closing it and opening it again.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfce4-panel (Ubuntu):
status: New → Confirmed
Hermann (launchpad-net-hermann) wrote :

I also upgraded to 14.04 and now I have this. Very annoying.

Carl (cdhunter2) wrote :

I started noticing this after upgrading to 13.04. 13.10 and 14.04 also have this issue for me. Not sure if that helps track down the bug. Exiting mythfrontend and starting from the menu fixes it for me until the next reboot.

Trey Boudreau (trey-v) wrote :

I resolved this issue locally by adding a two second sleep to /usr/share/mythtv/mythfrontend.sh
This suggests that some service that it requires has not completed initialization prior to the start of mythfrontend.

Jens Höft (velberrocks) wrote :

In Ubuntu 14.04 (Unity) the starter and title bar are visible too while Mythfrontend is running. This was not happening in 12.04.

Which kind of startup script must be used for
DISPLAY=:0 wmctrl -r "MythTV Frontend" -b add,fullscreen
?

I inserted this line into mythfrontend.sh without any result and would be happy if someone could give me a hint. Thank you!

Louis (louis-louis) wrote :

Jens,

Start a terminal

Run:
sudo nano -c +4 /usr/share/mythtv/mythfrontend.sh

You should now be standing on line 4 which is blank, here you add:
sleep 2

And save by pressing Ctrl + 0 and Ctrl + X (which saves and closes the file)
Now when you boot Mythfrontend is set to started with a delay of 2 seconds which will make it start in full screen.

Hope it helps :)

Hi Louis,

Thank you very much! That's what I tried initially but it did not help. I will try it again, perhaps I made a mistake.

Kind Regards
  Jens

> Am 10.05.2014 um 00:39 schrieb Louis <email address hidden>:
>
> Jens,
>
> Start a terminal
>
> Run:
> sudo nano -c +4 /usr/share/mythtv/mythfrontend.sh
>
> You should now be standing on line 4 which is blank, here you add:
> sleep 2
>
> And save by pressing Ctrl + 0 and Ctrl + X (which saves and closes the file)
> Now when you boot Mythfrontend is set to started with a delay of 2 seconds which will make it start in full screen.
>
> Hope it helps :)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1282868
>
> Title:
> XFCE bar is visable over Mythfrontend on a fresh 14.04 install
>
> Status in Mythbuntu, Ubuntu derivative focused upon MythTV:
> Confirmed
> Status in “mythtv” package in Ubuntu:
> Confirmed
> Status in “xfce4-panel” package in Ubuntu:
> Confirmed
>
> Bug description:
> The XFCE bar is visable over mythfrontend on a fresh install.
>
> Reproduce:
>
> Install from Mythbuntu 14.04 ISO. Install with frontend+master
> backend. After install, when mythfrontend starts the XFCE bar is
> visable at the top of the screen. Historically, this has been an issue
> with Compiz (fixable by enabling the compiz legacy window mode).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mythbuntu/+bug/1282868/+subscriptions

You're welcome Jens.

What happens when you boot your machine. Do you just get mythfrontend with a visible top banner or do you also get a pop up saying an internal error has happened with Ubuntu?

If you run "cat /usr/share/mythtv/mythfrontend.sh" and post the output I can try to see if it's correct.

rhpot1991 (rhpot1991) wrote :

I added the following in /etc/mythtv/session-settings to work around this issue:
sleep 10 && DISPLAY=:0 wmctrl -r "MythTV Frontend" -b add,fullscreen

Phil Brady (phil-brady) wrote :

I think this bug is showing inconsistent symptoms. I’ve seen four solutions proposed:

1. Restart frontend (or equivalently: delay it starting). Just does not work for me.

2. Set ‘legacy fullscreen’ and ‘enable workarounds’.in Compiz settings manager.
It required agreement to use OpenGL (Do I need it? – I am set to use VDPAU). Not working for me either.

3. I was able to force fullscreen by switching themes in frontend setup but it reverted at next frontend startup. This no longer works anyway but unsure why.

4. The DISPLAY wmctrl solution which does work. The DISPLAY must be issued after frontend has started. In order to catch all starting conditions I chose to spawn a background script with a new line at the start of /usr/bin/mythfrontend:

/usr/bin/ fullscreenfrontend.sh &

The fullscreenfrontend.sh script is as others have cleverly suggested is:

#!/bin/bash
sleep 10
DISPLAY=:0 wmctrl -r "MythTV Frontend" -b add,fullscreen

Now why is this all so inconsistent? Why do solutions work for some but not for others? What might be different about the setups?

I’m using Asus M3N78EM mobo with AMD CPU and onboard Nvidia 8300 graphics, 64 bit Mythbuntu 14.04, Nvidia 304 drivers ( 331.38 is unstable) VDPAU (not OpenGL) and mythwelcome.

Phil

MarcRandolph (mrand) wrote :

Changeset 25876a76e (MythTV 0.27.1 on 2014-05-25) might have fixed this, at least for some users.
More details here: https://code.mythtv.org/trac/ticket/7958

MarcRandolph (mrand) wrote :

I've confirmed that, at least for me, the latest fixes (0.27.1) indeed resolves this issue. Anyone else still seeing this?

Changed in mythbuntu:
status: Confirmed → Fix Committed

The fix in 0.27.1 works fine!
Ubuntu 14.04/upgraded from 12.04 install/Unity/MythTV ppa repository.

Thomas Mashos (tgm4883) on 2014-06-12
Changed in mythbuntu:
status: Fix Committed → Fix Released

a few weeks ago I upgraded to 0.27.1 and this bug duly vanished.

Today I edited 2 files to change my system's host name (/etc/hosts and /etc/hostname), rebooted and the fault has re-appeared.

I tried in vain:

  sudo add-apt-repository ppa:mythbuntu/0.27
  sudo apt-get update
  sudo apt-get install mythtv

No changes made - up to date already. Frontend info page shows "Mythfrontend Version: fixes/0.27 (v0.27.1-16-gaa822f5)"
Mythbuntu 14.04 64 bit, Asus M3N78EM mobo. Running with mythwelcome.

Phil

You can't say "I made these 2 changes" and then immediately say "No
changes made". Granted I don't think they are related, but don't do
that.
Thanks,

Thomas Mashos

On Tue, Jun 24, 2014 at 11:15 AM, Phil Brady <email address hidden> wrote:
> a few weeks ago I upgraded to 0.27.1 and this bug duly vanished.
>
> Today I edited 2 files to change my system's host name (/etc/hosts and
> /etc/hostname), rebooted and the fault has re-appeared.
>
> I tried in vain:
>
> sudo add-apt-repository ppa:mythbuntu/0.27
> sudo apt-get update
> sudo apt-get install mythtv
>
> No changes made - up to date already. Frontend info page shows "Mythfrontend Version: fixes/0.27 (v0.27.1-16-gaa822f5)"
> Mythbuntu 14.04 64 bit, Asus M3N78EM mobo. Running with mythwelcome.
>
> Phil
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1282868
>
> Title:
> XFCE bar is visable over Mythfrontend on a fresh 14.04 install
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mythbuntu/+bug/1282868/+subscriptions

Sorry if I wasn't clear.

I had indeed changed the 2 files holding host name and rebooted and that's when the visible xfce bar re-appeared in frontend.

'No changes made' was what was reported as a result of the futile attempt to reset mythtv with:
  'sudo apt-get install mythtv'

I'm back with my spawned script workaround - see the 19 May 2014 entry above.

Phil

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mythtv (Ubuntu Trusty):
status: New → Confirmed
Changed in xfce4-panel (Ubuntu Trusty):
status: New → Confirmed
Jim (mythjim) wrote :

I have found this issue on a Frontend only box running a fresh install of 14.04.

MythTV Version : v0.27-193-g8ee257c
MythTV Branch : fixes/0.27

I added the following work around.

sleep 2 to /usr/share/mythtv/mythfrontend.sh

This worked for me, but why? I have 14.04 on 2 other machines in the house and I'm not seeing this issue.
The machine I am seeing this on has a SSD and the boot up time is short. Is the SSD related to the issue?

Thomas Mashos (tgm4883) wrote :

@Jim

Is this on a fully updated (including our mythtv repos) box? What is the output of

'dpkg -l | grep mythtv'

Jim (mythjim) wrote :

@ Thomas

On the box that is causing the issue:

dpkg -l | grep mythtv
ii libmythtv-perl 2:0.27.0+fixes.20140324.8ee257c-0ubuntu3 all A PERL library to access some MythTV features
ii mythtv-common 2:0.27.0+fixes.20140324.8ee257c-0ubuntu3 i386 Personal video recorder application (common data)
ii mythtv-dbg 2:0.27.0+fixes.20140324.8ee257c-0ubuntu3 i386 Debug symbols for mythtv packages
ii mythtv-frontend 2:0.27.0+fixes.20140324.8ee257c-0ubuntu3 i386 Personal video recorder application (client)
ii mythtv-theme-mythbuntu 2:0.27.0+fixes.20140324.8ee257c-0ubuntu3 all The mythbuntu MythTV Theme
ii mythtv-transcode-utils 2:0.27.0+fixes.20140324.8ee257c-0ubuntu3 i386 Utilities used for transcoding MythTV tasks
ii php-mythtv 2:0.27.0+fixes.20140324.8ee257c-0ubuntu3 all PHP Bindings for MythTV

Jim (mythjim) wrote :

Re-readin the comments above, I see that it looks like it was fixed in 0.27.1.

I thought my box was up to date. My mistake. 0.27.0.

I will update and remove the sleep from the /usr/share/mythtv/mythfrontend.sh.

Will let you know the outcome ASAP.

Jim (mythjim) wrote :

This has fixed it for me. thank you for your help. I have tried it >10 times, and not seen the issue.

On some boots, the task bar can been seen with the front end loaded but with no menu or clock. In this state for 5 seconds.
Then once the menu and clock appears, the screen is redrawn and the task bar disappears.

For completeness here is what I am running now:

ii libmythtv-perl 2:0.27.4+fixes.20150305.f1115fc-0ubuntu0mythbuntu3 all A PERL library to access some MythTV features
ii mythtv-common 2:0.27.4+fixes.20150305.f1115fc-0ubuntu0mythbuntu3 i386 Personal video recorder application (common data)
ii mythtv-dbg 2:0.27.4+fixes.20150305.f1115fc-0ubuntu0mythbuntu3 i386 Debug symbols for mythtv packages
ii mythtv-frontend 2:0.27.4+fixes.20150305.f1115fc-0ubuntu0mythbuntu3 i386 Personal video recorder application (client)
ii mythtv-theme-mythbuntu 2:0.27.4+fixes.20150305.f1115fc-0ubuntu0mythbuntu3 all The mythbuntu MythTV Theme
ii mythtv-transcode-utils 2:0.27.4+fixes.20150305.f1115fc-0ubuntu0mythbuntu3 i386 Utilities used for transcoding MythTV tasks
ii php-mythtv 2:0.27.4+fixes.20150305.f1115fc-0ubuntu0mythbuntu3 all PHP Bindings for MythTV

On a related but side note: After this testing, it has highlighted another issue I was having, regarding not connecting to the database. I think this is timing issue (tbc) pinging before network up, so the sleep has been added back in, but now increased to 5 seconds. Off to start debugging this now ;)

Changed in mythtv (Ubuntu):
milestone: ubuntu-14.04.1 → none
importance: Undecided → Medium
Changed in mythtv (Ubuntu Trusty):
importance: Undecided → Medium
Changed in xfce4-panel (Ubuntu):
importance: Undecided → Medium
Changed in xfce4-panel (Ubuntu Trusty):
importance: Undecided → Medium
tags: added: trusty
Jarno Suni (jarnos) on 2015-11-17
summary: - XFCE bar is visable over Mythfrontend on a fresh 14.04 install
+ XFCE bar is visible over Mythfrontend on a fresh 14.04 install
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.