MythTV doesn't go full screen without desktop visual effects off

Bug #348934 reported by Nils Grimsmo on 2009-03-26
90
This bug affects 13 people
Affects Status Importance Assigned to Milestone
MythTV
Unknown
Unknown
mythtv (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: mythtv

If "Visual Effects" are enabled on the Gnome desktop (System --> Preferences --> Appearance --> Visual Effects), mythfrontend doesn't go full screen, but the Gnome panels show.

$ lsb_release -r
Release: 9.04

$ uname -a
Linux kuken 2.6.28-11-generic #37-Ubuntu SMP Mon Mar 23 16:40:00 UTC 2009 x86_64 GNU/Linux

~$ apt-cache policy mythtv-frontend
mythtv-frontend:
  Installed: 0.21.0+fixes19961-0ubuntu8

Not sure if this is the fault of MythTV or Compiz though.

Klem fra Nils

Revision history for this message
Jeff Sereno (jsereno) wrote :

I've just upgraded to Jaunty 64-bit from Intrepid 64-bit and can confirm this bug. I'm running the exact same kernel version as the OP.

I use two 1920x1080 monitors run by an NVidia 8800GT gfx card using TwinView (effective screen size 3840x1080) and usually have MythTV running on the second display. Under Intrepid this worked fine. It also works under Jaunty, however there is a gap at the top of the screen showing the background wallpaper. The MythTV screen is not cropped - it is actually pushed down and starts underneath this gap.

The gap is the same size as the top Gnome panel on the first screen. If I activate AutoHide on that panel then restart MythTV-Frontend, the gap is now reduced to the small-size Gnome panel.

If I turn OFF Compiz effects, then MythTV instantly goes full-screen (without needing to restart it). If I turn Compiz effects back ON, the gap returns instantly (without needing to restart MythTV).

I'm using a patched version of MythTV with VDPAU support, however I've repeated the test using the Ubuntu-supplied version of MythTV in a separate test install and the problem is still present.

mythtv-frontend:
  Installed: 0.21.0+fixes-svn20397-openglvdpau-0ubuntu2
  Candidate: 0.21.0+fixes-svn20397-openglvdpau-0ubuntu2
  Version table:
 *** 0.21.0+fixes-svn20397-openglvdpau-0ubuntu2 0
        500 http://mirror.serenux.com jaunty/release Packages
        100 /var/lib/dpkg/status
     0.21.0+fixes-svn20320-openglvdpau-debug-0ubuntu2 0
        500 http://mirror.serenux.com jaunty/testing Packages
     0.21.0+fixes-svn20320-openglvdpau-0ubuntu2 0
        500 http://mirror.serenux.com jaunty/release Packages
     0.21.0+fixes-svn20310-openglvdpau-0ubuntu5 0
        500 http://mirror.serenux.com jaunty/release Packages
     0.21.0+fixes19961-0ubuntu8 0
        500 http://mirror.serenux.com jaunty/multiverse Packages

This gap issue was not present under Intrepid.

Attached is a screenshot illustrating the gap at the top of the Myth display. The gap shows the desktop wallpaper and is the size of the top Gnome panel on the first screen.

Cheers.

Revision history for this message
Andrew Ross (rockclimb) wrote :

I can confirm the same behavior on the x86 version in Jaunty.

Revision history for this message
Joe (jaoag) wrote :

using:

ubuntu 9.04 amd64 (clean install)
mythtv-frontend 0.21.0+fixes19961
nvidia-glx 180.44

This issue was present in Hardy, corrected in Intrepid and resurfaced in Jaunty. It appears to be Gnome specific, as I cannot duplicate the issue in kde.

Workaround:

sudo aptitude install compizconfig-settings-manager

System->Preferences->CompizConfig Settings Manager -- enable legacy fullscreen support in the workarounds section.

This is only a partially effective workaround, and will result in video artifacts if you are working in another window (scroll in another window for an example)

Revision history for this message
innominate (natenate) wrote :

I had the same issue with gnome-panels showing with myth-tv full screen on my primary monitor. But when on my secondary monitor i did not get the gap issue mentioned above. My monitors are not at the same resolution thats the only reason i can think of as to why.

With Joes fix full screen works on both monitors.

Revision history for this message
Jeff Sereno (jsereno) wrote :

I can confirm Joe's Legacy Full-Screen fix works perfectly for me. Myth now opens on the second screen full-screen without an issue now.

Revision history for this message
Virtually Insane (stevef51) wrote :

I have just upgraded from 8.04 through 8.10 (1 day) and to 9.04 (to get support for my DVICO DVB-T FusionHDTV card) and although the card now works in Myth I also see the desktop banner at the top. If I turn Compiz effects Off (set to None in Windows - Appearance) then Myth goes full-screen, and I can turn Compiz effects back on again (Full) and it still works until I close Myth and restart it (with effects On). If I restart Myth with effects Off then all is good.

Revision history for this message
pedemoz (pedemoz) wrote :

Confirmed, after update to 9.04. Legacy full-screen hack solves the issue, but what (if any) are the side effects of using this?

Revision history for this message
pedemoz (pedemoz) wrote :

Forgot to add...
Running amd64 with Myth 0.21 on top of Ubuntu (not Mythbuntu) and nvidia 180.44.

Revision history for this message
JT Wilkinson (jtw-dartmouth) wrote :

I can confirm this bug on jaunty x86.

Revision history for this message
Richard Hansen (rhansen) wrote :

I have this same problem but compiz is disabled (System -> Preferences -> Appearance -> Visual Effects = None). I have two monitors (laptop screen and external monitor) with gnome panels at the top and bottom of each. These panels display above MythTV no matter which screen I select for MythTV.

I'm running Jaunty.

Changed in mythtv (Ubuntu):
status: New → Confirmed
Revision history for this message
Mike Holland (z-launchpad-myk-id-au) wrote :

Myth 0.22 on ubuntu 9.10, compiz, myth runs fullscreen but gnome panels show on top.
Same "legacy fullscreen" workaround fixes it.

Revision history for this message
Alfredo Pironti (alfredo.pironti) wrote :

So, it seems to me that this is an upstream bug (because they should switch to the "new" fullscreen mode). Has this bug already be reported to upstream?

Revision history for this message
MarcRandolph (mrand) wrote :

Upstreaming

Changed in mythtv (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in mythtv:
status: Unknown → New
Changed in mythtv:
status: New → Fix Released
Revision history for this message
Mario Limonciello (superm1) wrote :

As upstream fixed this in trunk i'll mark this in the trunk packaging as fixed. When we upload a build to the current Ubuntu development release (currently Lucid Lynx) with this fix, this bug will be automatically closed.

Changed in mythtv (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Mario Limonciello (superm1) wrote :

This was fixed in this bug. Looks like forgot to include it in the most recent changelog:

mythtv (0.23.0~trunk23567-0ubuntu1) lucid; urgency=low

 * Bump builds to start with 0.23
 * debian/control:
   - Fix vcs-bzr
   - Update depends to include ttf-droid, ttf-liberation, and ttf-dejavu.
     (LP: #224114)
   - Drop quilt build-dep, it appears to be included w/ dh7
   - Bump standards version
 * Introduces stable pulseaudio support (In Theory! :)) (LP: #311328)
 * Print message to stdout for MythTV.pm (LP: #327406)
 * debian/patches:
   - Drop 16_hal_shutdown. No longer necessary after r23518.
 * Allow shutdowns when mythtv is running (LP: #174712)
   - Comes from upstream changeset r23455.
 * Mythbackend now supports the --user flag to drop permissions from
   upstream changeset r23521.
 * Use the upstart script from the upstream contrib directory instead.
   Now uses the --user flag to drop permissions. (LP: #445953)
 * Update 30_python26_transition for changes upstream.
 * mythtv-database.templates:
   - refer to the proper location for backups.
 * Switch to use the upstream backup scripts. (LP: #469792)
 * Helps with HDTV stuttering. (LP: #451394)
 * Drop old debian/myth-*.sh scripts since we now use dbus for shutdown
   and reboot etc.
 * Drop old debian/mythtv-backend.default. It's just available for upgrades.
 * Drop old debian/mythtv-backend.init initscript. We're only supporting
   upstart going forward with these builds.
 * Drop unnecessary patch, 02_settings_pro.dpatch
 * Drop unused patch, 23_video_device_symlinks.dpatch
 * Drop unused patch, 25_skiploop_option.dpatch
 * Convert packaging to dh7.
 * Convert packaging to source v3 (w/ quilt).
 * Add debian/README.source as a symlink to the quilt README.source
 * Convert all .files into .install.
 * Refresh patches as quilt format instead
 * Rewrite get-orig-source rules to parse the changelog for version info.
 * Drop any of the Top Secret Options build flags
 * Include a custom snippet for debian/rules mythtv packages in libmyth-dev.
 * Drop old, unused templates from debian/templates.

Changed in mythtv (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
James Cuzella (trinitronx) wrote :

Switched to gnome desktop in Mythbuntu 10.04 Beta 2 encountered this bug. Needed to do the workaround.

Latest available version of mythtv on synaptic is: 0.23.0+fixes24158-0ubuntu2

Not sure if the numbering on trunk vs. fixes correlates... it still seems to appear in this 'fixes' branch however.

Revision history for this message
Jeff Sereno (jsereno) wrote :

Did my own test with a fresh install of Lucid RC with MythTV Frontend 0.23.0+fixes24158-0ubuntu2 and also found that I still had to do the workaround.

My other desktop with Ubuntu Karmic and MythTV Frontend 2:0.24.0~trunk-24111-0ubuntu1 (latest Trunk release) is also still suffering the same issue.

Installing 2:0.24.0~trunk-24111-0ubuntu2 on Lucid RC also did not fix the problem and still required the workaround.

I tested the Lucid RC MythTV Frontend in both a real PC with an NVidia GeForce 9400GT gfx card and also a Virtualbox 3.1.6 installation, both with the same results.

Revision history for this message
monkeys_typing (monkeys-typing) wrote :

I am running a fresh install of 10.04 LTS, with mythtv -.23+fixes from the mythbuntu auto-builds repo. I have this same issue. I have tried the compiz "legacy workarounds" fix to no avail. I will try rebooting shortly to see if I just need X to restart (have some other reboot needed tasks), but my limited understanding is that Compiz shouldn't need an X restart.

I am running the AMD64 version, with the nVidia 195 drivers and an 9800GT video card.

Revision history for this message
Michael Martin-Smucker (mmartinsmucker) wrote :

Since I seem to be the 4th person running into this issue on Lucid, it seems like the problem isn't fixed (at least not in the Ubuntu package). I'm reopening.

Changed in mythtv (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Gadgetman (stewart-gadget) wrote :

I dont understand..
Michael Martin-Smucker:-
Changed in mythtv (Ubuntu):
status: Fix Released → Confirmed

Is this fixed?

Revision history for this message
mirage (tusi-mora) wrote :

Try this:
From: http://www.serenux.com/2009/04/howto-fix-mythtvs-frontend-not-going-full-screen-in-ubuntu-jaunty/

    Go to System->Preferences->CompizConfig Settings Manager. If you do not have this option in your Preferences, then you need to add it. Quickly jump into a terminal and type in at the $ prompt:

    $ sudo apt-get install compizconfig-settings-manager

    …and hit Enter. Once installed, go back into the Preferences menu and bring it up.
    Scroll down until you get to the “Utility” section and then click on “Workarounds”. It should alredy be selected as enabled, but if not, also make sure the checkbox next to it is enabled too.
    .
    The window changes to show you the Workaround options. The very first option is “Legacy Fullscreen Support”. This is unchecked by default. Click on the checkbox so that it IS checked, and then click on the Back button, then close the window.
    .
    Quit the MythTV Frontend if you had it open already and then restart it. You will now find that the gap has disappeared, and that the MythTV display is now appearing full-screen properly instead of just being a window.
    .
    Pat yourself on the back.

Revision history for this message
Daniel Ellis (danellisuk) wrote :

This is still an issue with Ubuntu 11.10. The compiz settings workaround mentioned above works, but I had to logout and re-login for the change to take effect.

Revision history for this message
Mario Limonciello (superm1) wrote :

It was fixed upstream, but then reverted.

$ git show 3ad6c81aa83491b7e6d2d54c15daf16894a72299
commit 3ad6c81aa83491b7e6d2d54c15daf16894a72299
Author: Mark Kendall <email address hidden>
Date: Wed Mar 16 11:53:06 2011 +0800

    libmythui: Fix fullscreen windowing with Compiz (and Gnome?)

    This is based on the patch from Lawrence Rust in ticket #9589 which
    notes that Compiz requires the window to be visible before we set its
    state.

    Testing across various Ubuntu desktops (with and without Compiz and
    composite enabled) and on OSX and windows suggests that it is safe just
    to show the window earlier in the initialisation process and avoid the
    ifdef.

diff --git a/mythtv/libs/libmythui/mythmainwindow.cpp b/mythtv/libs/libmythui/mythmainwindow.cpp
index 1d4e046..6e917cb 100644
--- a/mythtv/libs/libmythui/mythmainwindow.cpp
+++ b/mythtv/libs/libmythui/mythmainwindow.cpp
@@ -915,6 +915,7 @@ void MythMainWindow::Init(void)
 #endif

     setWindowFlags(flags);
+ Show();

     if (d->does_fill_screen && !GetMythUI()->IsGeometryOverridden())
     {
@@ -929,7 +930,6 @@ void MythMainWindow::Init(void)
     setFixedSize(QSize(d->screenwidth, d->screenheight));

     GetMythUI()->ThemeWidget(this);
- Show();

     if (!GetMythDB()->GetNumSetting("HideMouseCursor", 0))
         setMouseTracking(true); // Required for mouse cursor auto-hide

$ git show 003fc8fb14acc9a6c4aeea2001d33d4cdb3c253d
commit 003fc8fb14acc9a6c4aeea2001d33d4cdb3c253d
Author: Mark Kendall <email address hidden>
Date: Sun Mar 20 11:21:26 2011 +0800

    libmythui: Revert recent Compiz/fullscreen window fixes.

    Some multi-screen setups (TwinView) are still broken despite an
    attempted fix. I can't honestly see any combination of initialisation
    sequence that fixes both the Compiz issue and doesn't break Twinview
    setups, so reverting until someone can figure out a better way.

    Refs #9589

diff --git a/mythtv/libs/libmythui/mythmainwindow.cpp b/mythtv/libs/libmythui/mythmainwindow.cpp
index f75e75d..1d4e046 100644
--- a/mythtv/libs/libmythui/mythmainwindow.cpp
+++ b/mythtv/libs/libmythui/mythmainwindow.cpp
@@ -916,21 +916,20 @@ void MythMainWindow::Init(void)

     setWindowFlags(flags);

- d->screenRect = QRect(d->xbase, d->ybase, d->screenwidth, d->screenheight);
- d->uiScreenRect = QRect(0, 0, d->screenwidth, d->screenheight);
-
- Show();
-
     if (d->does_fill_screen && !GetMythUI()->IsGeometryOverridden())
     {
         VERBOSE(VB_GENERAL, "Using Full Screen Window");
         setWindowState(Qt::WindowFullScreen);
     }

+ d->screenRect = QRect(d->xbase, d->ybase, d->screenwidth, d->screenheight);
+ d->uiScreenRect = QRect(0, 0, d->screenwidth, d->screenheight);
+
     setGeometry(d->xbase, d->ybase, d->screenwidth, d->screenheight);
     setFixedSize(QSize(d->screenwidth, d->screenheight));

     GetMythUI()->ThemeWidget(this);
+ Show();

     if (!GetMythDB()->GetNumSetting("HideMouseCursor", 0))
         setMouseTracking(true); // Required for mouse cursor auto-hide

Revision history for this message
Axel Pospischil (apos) wrote :

I found out that enabling the "legacy fullscreen support" in CCSM while using a multihead environment (!!!) causes a lot of trouble.

I am using an intel graphics onboard chipset (Intel HD P3000 integrated / Xeon E3-1200) which is common in a lot of common intel cpu's.

Problems:
---------------
- When I like to write an email with evolution, the window boarders disappear.
- Launcher does not react with mouse
- Under some circumstances the right click button of the mouse is not usable any more

Temporary solution:
------------------------------
- unity --replace

Meanwhile I didn't found a solution that really works an accept having the menu bar on top of the screen, so that the system can be used without trouble.

Again: please be aware, that I am talking about a multihead (multi monitor) environment!

Changed in mythtv:
status: Fix Released → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.